Results 1 to 5 of 5

Thread: Can't update packages from terminal and GNOME Package Updater application

  1. #1
    Join Date
    Aug 2011
    Location
    Russia
    Posts
    233

    Default Can't update packages from terminal and GNOME Package Updater application

    Hi everyone,

    I try to update packages from terminal command "zypper up", but it shows this:

    Code:
    linux-0k86:/home/andranik # zypper up
    Timeout exceeded when accessing 'http://download.opensuse.org/repositories/Education/openSUSE_Leap_42.1/repodata/repomd.xml'.
    
    Abort, retry, ignore? [a/r/i] (r): 
    Autoselecting 'r' after 26 seconds. i
    Do you want to disable the repository Education permanently? [yes/no] (no): no
    Skipping repository 'Education' because of the above error.
    Timeout exceeded when accessing 'http://download.opensuse.org/repositories/mozilla/openSUSE_Leap_42.1/repodata/repomd.xml'.
    
    Abort, retry, ignore? [a/r/i] (r): 
    Trying again...
    Timeout exceeded when accessing 'http://download.opensuse.org/repositories/mozilla/openSUSE_Leap_42.1/repodata/repomd.xml'.
    
    Abort, retry, ignore? [a/r/i] (r): 
    Trying again...
    i
    Timeout exceeded when accessing 'http://download.opensuse.org/repositories/mozilla/openSUSE_Leap_42.1/repodata/repomd.xml'.
    
    Abort, retry, ignore? [a/r/i] (r): 
    Do you want to disable the repository Mozilla permanently? [yes/no] (no): no
    Skipping repository 'Mozilla' because of the above error.
    Timeout exceeded when accessing 'http://download.opensuse.org/repositories/Virtualization/openSUSE_Leap_42.1/repodata/repomd.xml'.
    
    Abort, retry, ignore? [a/r/i] (r): 
    Trying again...
    Timeout exceeded when accessing 'http://download.opensuse.org/repositories/Virtualization/openSUSE_Leap_42.1/repodata/repomd.xml'.
    
    Abort, retry, ignore? [a/r/i] (r): 
    Autoselecting 'r' after 12 seconds. i
    Do you want to disable the repository Virtualization permanently? [yes/no] (no): no
    Skipping repository 'Virtualization' because of the above error.
    Timeout exceeded when accessing 'http://download.opensuse.org/repositories/Emulators:/Wine/openSUSE_Leap_42.1/repodata/repomd.xml'.
    
    Abort, retry, ignore? [a/r/i] (r): 
    Autoselecting 'r' after 25 seconds. 
    Do you want to disable the repository Wine permanently? [yes/no] (no): no
    Skipping repository 'Wine' because of the above error.
    Timeout exceeded when accessing 'http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/content'.
    
    Abort, retry, ignore? [a/r/i] (r): 
    Trying again...
    Timeout exceeded when accessing 'http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/content'.
    
    Abort, retry, ignore? [a/r/i] (r): 
    Trying again...
    Timeout exceeded when accessing 'http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/content'.
    
    Abort, retry, ignore? [a/r/i] (r): 
    Trying again...
    i
    Timeout exceeded when accessing 'http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/content'.
    
    Abort, retry, ignore? [a/r/i] (a): 
    Do you want to disable the repository Main Repository (NON-OSS) permanently? [yes/no] (no): no
    Skipping repository 'Main Repository (NON-OSS)' because of the above error.
    Timeout exceeded when accessing 'http://download.opensuse.org/update/leap/42.1/non-oss/repodata/repomd.xml'.
    
    Abort, retry, ignore? [a/r/i] (r): 
    Autoselecting 'r' after 18 seconds. 
    Do you want to disable the repository Update Repository (Non-Oss) permanently? [yes/no] (no): no
    Skipping repository 'Update Repository (Non-Oss)' because of the above error.
    Timeout exceeded when accessing 'http://download.opensuse.org/distribution/leap/42.1/repo/oss/content'.
    
    Abort, retry, ignore? [a/r/i] (r): 
    Autoselecting 'r' after 4 seconds. i
    Do you want to disable the repository Main Repository (OSS) permanently? [yes/no] (no): no
    Skipping repository 'Main Repository (OSS)' because of the above error.
    Timeout exceeded when accessing 'http://download.opensuse.org/update/leap/42.1/oss/repodata/repomd.xml'.
    
    Abort, retry, ignore? [a/r/i] (r): 
    Trying again...
    i
    Timeout exceeded when accessing 'http://download.opensuse.org/update/leap/42.1/oss/repodata/repomd.xml'.
    
    Abort, retry, ignore? [a/r/i] (r): 
    Do you want to disable the repository Main Update Repository permanently? [yes/no] (no): no
    Skipping repository 'Main Update Repository' because of the above error.
    Timeout exceeded when accessing 'http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_Leap_42.1/repodata/repomd.xml'.
    
    Abort, retry, ignore? [a/r/i] (r): 
    Autoselecting 'r' after 28 seconds. i
    Do you want to disable the repository Packman Repository permanently? [yes/no] (no): no
    Skipping repository 'Packman Repository' because of the above error.
    Timeout exceeded when accessing 'http://download.opensuse.org/repositories/openSUSE:/13.2:/Update/standard/repodata/repomd.xml'.
    
    Abort, retry, ignore? [a/r/i] (r): 
    Trying again...
    Timeout exceeded when accessing 'http://download.opensuse.org/repositories/openSUSE:/13.2:/Update/standard/repodata/repomd.xml'.
    
    Abort, retry, ignore? [a/r/i] (r): 
    Trying again...
    Timeout exceeded when accessing 'http://download.opensuse.org/repositories/openSUSE:/13.2:/Update/standard/repodata/repomd.xml'.
    
    Abort, retry, ignore? [a/r/i] (r): 
    Trying again...
    Timeout exceeded when accessing 'http://download.opensuse.org/repositories/openSUSE:/13.2:/Update/standard/repodata/repomd.xml'.
    
    Abort, retry, ignore? [a/r/i] (a): 
    Trying again...
    ABORT request: Aborting requested by user
    linux-0k86:/home/andranik #
    It shows error with repos, but I have checked every repo -- they are work.
    Nothing more than that packages upgrades from YAST (GUI).


    Here is my list of repos:

    Code:
    #  | Alias                               | Name                                    | Enabled | GPG Check | Refresh
    ---+-------------------------------------+-----------------------------------------+---------+-----------+--------
     1 | Education                           | Education                               | Yes     | (r ) Yes  | Yes    
     2 | Mozilla                             | Mozilla                                 | Yes     | (r ) Yes  | Yes    
     3 | Virtualization                      | Virtualization                          | Yes     | (r ) Yes  | Yes    
     4 | Wine                                | Wine                                    | Yes     | (r ) Yes  | Yes    
     5 | download.opensuse.org-non-oss       | Main Repository (NON-OSS)               | Yes     | (r ) Yes  | Yes    
     6 | download.opensuse.org-non-oss_1     | Update Repository (Non-Oss)             | Yes     | (r ) Yes  | Yes    
     7 | download.opensuse.org-oss           | Main Repository (OSS)                   | Yes     | (r ) Yes  | Yes    
     8 | download.opensuse.org-oss_1         | Main Update Repository                  | Yes     | (r ) Yes  | Yes    
     9 | ftp.gwdg.de-suse                    | Packman Repository                      | Yes     | (r ) Yes  | Yes    
    10 | http-download.opensuse.org-6476cff6 | openSUSE:13.2:Update                    | Yes     | (r ) Yes  | Yes    
    11 | http-download.opensuse.org-7f0567ef | home:antonbatenev:tox                   | Yes     | (r ) Yes  | Yes    
    12 | linuxdownload.adobe.com-linux       | Adobe Flash Plugin                      | Yes     | ( p) Yes  | Yes    
    13 | openSUSE-42.1-0                     | openSUSE-42.1-0                         | No      | ----      | No     
    14 | repo-debug                          | openSUSE-Leap-42.1-Debug                | No      | ----      | Yes    
    15 | repo-debug-non-oss                  | openSUSE-Leap-42.1-Debug-Non-Oss        | No      | ----      | Yes    
    16 | repo-debug-update                   | openSUSE-Leap-42.1-Update-Debug         | No      | ----      | Yes    
    17 | repo-debug-update-non-oss           | openSUSE-Leap-42.1-Update-Debug-Non-Oss | No      | ----      | Yes    
    18 | repo-source                         | openSUSE-Leap-42.1-Source               | No      | ----      | Yes    
    19 | repo-update                         | openSUSE-Leap-42.1-Update               | No      | ----      | Yes
    Also I can't update from GNOME Package Updater application. It shows this message: "ABORT request: Aborting requested by user".
    openSUSE Tumbleweed (x86_64) 64-bit
    Xfce

  2. #2
    Join Date
    Aug 2011
    Location
    Russia
    Posts
    233

    Default Re: Can't update packages from terminal and GNOME Package Updater application

    Now GNOME Package Updater application shows this errors:
    "nothing provides libgpg-error.so.0(GPG_ERROR_1.0)(64bit) needed by libksba8-1.3.1-4.1.x86_64
    nothing provides libicuuc.so.53.1()(64bit) needed by libmspub-0_1-1-0.1.2-2.4.1.x86_64
    nothing provides perl(:MODULE_COMPAT_5.20.1) needed by perl-YAML-LibYAML-0.59-2.4.1.x86_64
    nothing provides perl(:MODULE_COMPAT_5.20.1) needed by perl-IO-Socket-SSL-1.997-2.3.1.noarch
    nothing provides libicuuc.so.53.1()(64bit) needed by libwebkitgtk-3_0-0-2.4.9-10.1.x86_64
    nothing provides perl(:MODULE_COMPAT_5.20.1) needed by perl-XML-LibXML-2.0121-2.3.1.x86_64
    gpg2-lang-2.0.26-2.3.1.noarch requires gpg2 = 2.0.26, but this requirement cannot be provided
    nothing provides libexiv2.so.13()(64bit) needed by kdebase4-runtime-15.08.3-19.1.x86_64
    cron-4.2-57.5.x86_64 requires cronie = 1.4.11-57.5, but this requirement cannot be provided
    nothing provides libgpg-error.so.0(GPG_ERROR_1.0)(64bit) needed by gpg2-2.0.26-2.3.1.x86_64
    patchpenSUSE-2015-879-1.noarch conflicts with kernel-default-base.x86_64 < 4.1.13-5.1 provided by kernel-default-base-4.1.12-1.1.x86_64"
    openSUSE Tumbleweed (x86_64) 64-bit
    Xfce

  3. #3

    Default AW: Can't update packages from terminal and GNOME Package Updater application

    Quote Originally Posted by andranique View Post
    Here is my list of repos:

    Code:
    #  | Alias                               | Name                                    | Enabled | GPG Check | Refresh
    ---+-------------------------------------+-----------------------------------------+---------+-----------+--------
     1 | Education                           | Education                               | Yes     | (r ) Yes  | Yes    
     2 | Mozilla                             | Mozilla                                 | Yes     | (r ) Yes  | Yes    
     3 | Virtualization                      | Virtualization                          | Yes     | (r ) Yes  | Yes    
     4 | Wine                                | Wine                                    | Yes     | (r ) Yes  | Yes    
     5 | download.opensuse.org-non-oss       | Main Repository (NON-OSS)               | Yes     | (r ) Yes  | Yes    
     6 | download.opensuse.org-non-oss_1     | Update Repository (Non-Oss)             | Yes     | (r ) Yes  | Yes    
     7 | download.opensuse.org-oss           | Main Repository (OSS)                   | Yes     | (r ) Yes  | Yes    
     8 | download.opensuse.org-oss_1         | Main Update Repository                  | Yes     | (r ) Yes  | Yes    
     9 | ftp.gwdg.de-suse                    | Packman Repository                      | Yes     | (r ) Yes  | Yes    
    10 | http-download.opensuse.org-6476cff6 | openSUSE:13.2:Update                    | Yes     | (r ) Yes  | Yes    
     11 | http-download.opensuse.org-7f0567ef | home:antonbatenev:tox                   | Yes     | (r ) Yes  | Yes    
    12 | linuxdownload.adobe.com-linux       | Adobe Flash Plugin                      | Yes     | ( p) Yes  | Yes    
    13 | openSUSE-42.1-0                     | openSUSE-42.1-0                         | No      | ----      | No     
    14 | repo-debug                          | openSUSE-Leap-42.1-Debug                | No      | ----      | Yes    
    15 | repo-debug-non-oss                  | openSUSE-Leap-42.1-Debug-Non-Oss        | No      | ----      | Yes    
    16 | repo-debug-update                   | openSUSE-Leap-42.1-Update-Debug         | No      | ----      | Yes    
    17 | repo-debug-update-non-oss           | openSUSE-Leap-42.1-Update-Debug-Non-Oss | No      | ----      | Yes    
    18 | repo-source                         | openSUSE-Leap-42.1-Source               | No      | ----      | Yes    
    19 | repo-update                         | openSUSE-Leap-42.1-Update               | No      | ----      | Yes
    Well, this list is next to useless, please rather post the output of "zypper lr -d" to also show the repo URLs.

    But, you probably broke your system by adding the 13.2 update repo (#10).
    Unfortunately, there's no easy way to fix this if zypper doesn't work anymore.

    I'm afraid your only option is a new installation. I would suggest to boot from a Leap 42.1 installation medium and choose "Upgrade" so that you keep your installed packages, that should fix it.

    In the future, please only add repositories intended for your openSUSE version (unless you are 1000% sure about what you are doing).

  4. #4
    Join Date
    Aug 2011
    Location
    Russia
    Posts
    233

    Default Re: AW: Can't update packages from terminal and GNOME Package Updater application

    Quote Originally Posted by wolfi323 View Post
    Well, this list is next to useless, please rather post the output of "zypper lr -d" to also show the repo URLs.

    But, you probably broke your system by adding the 13.2 update repo (#10).
    Unfortunately, there's no easy way to fix this if zypper doesn't work anymore.

    I'm afraid your only option is a new installation. I would suggest to boot from a Leap 42.1 installation medium and choose "Upgrade" so that you keep your installed packages, that should fix it.

    In the future, please only add repositories intended for your openSUSE version (unless you are 1000% sure about what you are doing).
    "13.2 update" repo installed automatically with Tox application (and its repo).

    Thank you.
    I've done "Upgrade" the system.
    Now GNOME Package Updater application works.
    openSUSE Tumbleweed (x86_64) 64-bit
    Xfce

  5. #5

    Default Re: Can't update packages from terminal and GNOME Package Updater application

    Quote Originally Posted by andranique View Post
    "13.2 update" repo installed automatically with Tox application (and its repo).
    Then you probably clicked on the 1-click install for 13.2.

    As indicated, you should only use 1-click installs for your distribution version, as they normally also add additional repos.
    Or at least deselect wrong repos in the dialog that appears.

    But tox is available for Leap 42.1 as well, so there's no need (and actually a bad idea) to install the 13.2 version.

    Thank you.
    I've done "Upgrade" the system.
    Now GNOME Package Updater application works.
    You're welcome.

    Glad to hear that your system is working again...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •