Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: Looping login to OpenSuse Leap and booting to Windows 10 not working after installation of Leap

  1. #11
    Join Date
    Sep 2012
    Posts
    4,972

    Default Re: Looping login to OpenSuse Leap and booting to Windows 10 notworking after installation of Leap

    Quote Originally Posted by flymail View Post
    What kind of implementation precludes OS knowledge of its own boot state?
    You can check current state of secure boot using SecureBoot EFI variable; it is read-only as soon you leave firmware. I think current efibootmgr displays its value; you can also install efivar package that provides command to help manipulating EFI variables.

    And no, it is not OS state - it is firmware state. Strictly speaking it is of no concern to OS.

  2. #12
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,345
    Blog Entries
    3

    Default Re: Looping login to OpenSuse Leap and booting to Windows 10 notworking after installation of Leap

    Quote Originally Posted by flymail View Post
    That's terrible!... I didn't know that! What kind of implementation precludes OS knowledge of its own boot state?
    Code:
    bootctl status
    should tell you whether you booted with secure-boot.
    openSUSE Leap 15.1; KDE Plasma 5;

  3. #13

    Default Re: Looping login to OpenSuse Leap and booting to Windows 10 notworking after installation of Leap

    Thank you all for your help!

    So, yes, I won't give up until this Leap is installed on my computer.

    Yes I had some connection when I pinged www.opensuse.org.

    YAST mentioned grub in the boot option and I saw that the 'nouveau' driver was installed for my display, so it seems that I am experiencing the same issue as many users reported, e.g. nrickert in a separate thread).

    The 'secure boot' is enabled but I cannot figure out how to switch it to 'disabled'... The only options I have in the BIOS/EFI secure boot menu is to switch between 'Windows' and 'other OS' and change some 'CSM' options. There is another menu to 'clear secure boot keys' but since I could not save these to a USB drive, I did not want to take the risk to delete them.

    I tried the 'zypper inr' command since it has been mentioned to ignore some restrictions YAST is having with 'zypper up', but it did not solve the problem.

    I have downloaded the NVIDIA driver to a USB stick in Windows and will try to install it from the USB stick through the console.
    How would you advise me to install the driver?
    What I have in mind is:
    Code:
    fdisk -1
    mount device /mnt/usb
    NVIDIA-Linux-x86_64352.63.run
    I will see if this works...

  4. #14
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,645

    Default Re: Looping login to OpenSuse Leap and booting to Windows 10 not working after installation of Leap

    may want to google for your BIOS's doc's Secure boot is supposed to be an option not a forced thing

    `

  5. #15

    Default Re: Looping login to OpenSuse Leap and booting to Windows 10 not working after installation of Leap

    I could start the installation of the NVIDIA driver with
    Code:
    mkdir /mnt/usb
    mount /dev/sdd1 /mnt/usb
    sh NVIDIA-Linux-x86-64-352.63.run
    There, the system tells me that the 'nouveau' driver is already installed and needs to be disabled or removed prior to the installation of the new driver.

    I will try this solution: http://www.allaboutlinux.eu/remove-n...-ubuntu-15-04/

  6. #16
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,345
    Blog Entries
    3

    Default Re: Looping login to OpenSuse Leap and booting to Windows 10 notworking after installation of Leap

    Quote Originally Posted by yanfri View Post
    YAST mentioned grub in the boot option and I saw that the 'nouveau' driver was installed for my display, so it seems that I am experiencing the same issue as many users reported, e.g. nrickert in a separate thread).
    The installer runs on Icewm. So if the installer could run in graphic mode, you ought to be able to use Icewm. That's a very limited desktop, but it is still more congenial than using a command line login for things like installing Nvidia drivers.

    The 'secure boot' is enabled but I cannot figure out how to switch it to 'disabled'... The only options I have in the BIOS/EFI secure boot menu is to switch between 'Windows' and 'other OS' and change some 'CSM' options.
    BIOS settings vary from computer to computer. I have two UEFI systems. For one of them, there's a "boot" page (r maybe it is called "startup". And there's a line there for secure-boot. On the other, there is a "security" page, and the secure-boot setting is there. Both also have CSM settings on the boot/startup page. Turning on secure-boot automatically disables CSM.

    You may have to do some exploring of your BIOS settings page to find where to set.

    Note that there was an update yesterday that fixed these secure-boot problems. But you need to be able to boot your system first, and install all updates. Then you can turn secure-boot back on.

    There is another menu to 'clear secure boot keys' but since I could not save these to a USB drive, I did not want to take the risk to delete them.
    That's a different setting. I suggest you avoid using it.

    How would you advise me to install the driver?
    My advice would be:

    Use: Yast Software repositories
    select "Add"
    select "community repositories"
    select "nvidia" (or similar name)

    After adding that repository, use
    Yast Software Manager
    Search for "nvidia"
    Install the G04 drivers. There are several packages. You will need the one with "kmp" in its name. Selecting that should automatically select other required packages.

    By the way, I'm getting "G04" from the name of the install software you had planned to use (with 352.xx).

    If you install directly the way that you wanted, you will have to reinstall for every kernel update. If you install from the repos, then that should be handled automatically.
    openSUSE Leap 15.1; KDE Plasma 5;

  7. #17

    Default Re: Looping login to OpenSuse Leap and booting to Windows 10 notworking after installation of Leap

    On 2016-01-07, yanfri <yanfri@no-mx.forums.microfocus.com> wrote:
    > I have downloaded the NVIDIA driver to a USB stick in Windows and will
    > try to install it from the USB stick through the console.
    > How would you advise me to install the driver?
    > What I have in mind is:
    >
    > Code:
    > --------------------
    >
    > fdisk -1
    > mount device /mnt/usb
    > NVIDIA-Linux-x86_64352.63.run
    >
    > --------------------


    If you have the NVIDIA driver installer copied to /root/Downloads/, you can install it in a virtual console thus:

    Code:
    sh-4.2$ su -
    sh-4.2# zypper in gcc make kernel-devel
    sh-4.2# telinit 3
    sh-4.2# cd /root/Downloads/
    sh-4.2# sh NVIDIA<tab>
    sh-4.2# nvidia-xconfig
    sh-4.2# telinit 5
    sh-4.2# exit
    The NVIDIA propretiary driver prevents the nouveau driver (with which it conflicts) from loading and in my experience
    does so successfully. But if you have any problems, you might want to refer to: https://en.opensuse.org/SDB:NVIDIA_the_hard_way




  8. #18

    Default Re: Looping login to OpenSuse Leap and booting to Windows 10 not working after installation of Leap

    Problem solved: Use YAST in a console session to install the NVIDIA driver from the NVIDIA repo.

    Thank you all for your help!!!

    I used nrickert's advise to use YAST in a console session to install the NVIDIA driver from the NVIDIA repo. YAST solved it all for me

    I had started to remove the nouveau driver manually/the hard way but did not manage to install the NVIDIA driver over the nouveau.

    So now I have a running system with a dual boot to Windows 10 and Linux OpenSUSE Leap 42.1 on two drives (SSD and HDD).

    Thanks again

  9. #19
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,645

    Default Re: Looping login to OpenSuse Leap and booting to Windows 10 not working after installation of Leap

    You should NOT remove nouveau it will be blacklisted by the NVIDIA install.

  10. #20
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,345
    Blog Entries
    3

    Default Re: Looping login to OpenSuse Leap and booting to Windows 10 not working after installation of Leap

    Quote Originally Posted by yanfri View Post
    Problem solved: Use YAST in a console session to install the NVIDIA driver from the NVIDIA repo.
    I'm glad all is working.

    That ncurses interface (command line interface) is one of the greatest features of Yast. It is awkward to use. But when you really need it, you really appreciate it.
    openSUSE Leap 15.1; KDE Plasma 5;

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •