Results 1 to 2 of 2

Thread: dolphin don't works in KDE4 using LEAP42.1 with wolfi repos

  1. #1

    Default dolphin don't works in KDE4 using LEAP42.1 with wolfi repos

    on my PC=Dell latitude E6510, RAM=8Gb, GPU=GT218 NVS 3100M, CPU=i7 Q 720 @ 1.60GHz
    I upgraded my opensuse 13.2 to leap 42.1 using wolfi repos as in this thread installing these repos:
    Code:
    suseST-pla:/home/pla # zypper lr -d
    #  | Alias                               | Name                                                           | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                                      | Service
    ---+-------------------------------------+----------------------------------------------------------------+---------+-----------+---------+----------+--------+----------------------------------------------------------------------------------------------------------+--------
     1 | KDE:/Frameworks5/openSUSE_Leap_42.1 | KDE:/Frameworks5/openSUSE_Leap_42.1                            | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_Leap_42.1/                           |        
     2 | KDE:/Qt5/openSUSE_Leap_42.1         | KDE:/Qt5/openSUSE_Leap_42.1                                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_Leap_42.1/                                   |        
     3 | download.nvidia.com-leap            | nVidia Graphics Drivers                                        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.nvidia.com/opensuse/leap/42.1                                                            |        
     4 | ftp.gwdg.de-suse                    | Packman Repository                                             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_Leap_42.1/                                            |        
     5 | openSUSE-42.1-0                     | openSUSE-42.1-0                                                | No      | ----      | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-MATSHITA_DVD+_-RW_UJ892_HH24_397581                                   |        
     6 | opensuse-guide.org-repo             | Libdvdcss Repository                                           | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_42.1/                                                       |        
     7 | repo-debug                          | openSUSE-Leap-42.1-Debug                                       | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.1/repo/oss/                                      |        
     8 | repo-debug-non-oss                  | openSUSE-Leap-42.1-Debug-Non-Oss                               | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.1/repo/non-oss/                                  |        
     9 | repo-debug-update                   | openSUSE-Leap-42.1-Update-Debug                                | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.1/oss                                                  |        
    10 | repo-debug-update-non-oss           | openSUSE-Leap-42.1-Update-Debug-Non-Oss                        | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.1/non-oss/                                             |        
    11 | repo-non-oss                        | openSUSE-Leap-42.1-Non-Oss                                     | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/                                        |        
    12 | repo-oss                            | openSUSE-Leap-42.1-Oss                                         | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.1/repo/oss/                                            |        
    13 | repo-source                         | openSUSE-Leap-42.1-Source                                      | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/42.1/repo/oss/                                     |        
    14 | repo-update                         | openSUSE-Leap-42.1-Update                                      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.1/oss/                                                       |        
    15 | repo-update-non-oss                 | openSUSE-Leap-42.1-Update-Non-Oss                              | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.1/non-oss/                                                   |        
    16 | wolfi_repo_for_leap_42.1_with_KDE4  | wolfi repo for leap 42.1 with KDE4 (to have KDE4 in leap 42.1) | Yes     | (r ) Yes  | Yes     |   90     | rpm-md | http://download.opensuse.org/repositories/home:/wolfi323:/branches:/KDE:/Frameworks5/openSUSE_Leap_42.1/ |        
    suseST-pla:/home/pla #
    then I ran:
    Code:
    zypper dup --from 1 --from 2 --from 16 --from 4
    during zypper dup --from 16
    Code:
    2 Problems:
    Problem: dolphin-15.08.3-4.2.x86_64 requires dolphin-part = 15.08.3-4.2, but this requirement cannot be provided
    Problem: kfilemetadata5-lang-5.17.0-104.1.noarch requires kfilemetadata5 = 5.17.0, but this requirement cannot be provided
    
    Problem: dolphin-15.08.3-4.2.x86_64 requires dolphin-part = 15.08.3-4.2, but this requirement cannot be provided
      uninstallable providers: dolphin-part-15.08.3-4.2.x86_64[repo-update]
     Solution 1: keep kfilemetadata5-5.17.0-81.2.x86_64
     Solution 2: do not install dolphin-15.08.3-4.2.x86_64
     Solution 3: break dolphin-15.08.3-4.2.x86_64 by ignoring some of its dependencies
    I selected 1
    and then
    Code:
    Problem: kfilemetadata5-lang-5.17.0-104.1.noarch requires kfilemetadata5 = 5.17.0, but this requirement cannot be provided
      uninstallable providers: kfilemetadata5-5.17.0-104.1.x86_64[wolfi_repo_for_leap_42.1_with_KDE4]
     Solution 1: deinstallation of kfilemetadata5-lang-5.17.0-81.2.noarch
     Solution 2: keep obsolete kfilemetadata5-5.17.0-81.2.x86_64
     Solution 3: break kfilemetadata5-lang-5.17.0-104.1.noarch by ignoring some of its dependencies
    I selected 2

    I don't know if it is related but in plasma5 dolphin works well but in KDE4 dolphin doesn't start and launched from konsole it gives this error
    Code:
    pla@suseST-pla:~> dolphin
    dolphin: error while loading shared libraries: libKF5BalooWidgets.so.5: cannot open shared object file: No such file or directory
    pla@suseST-pla:~>
    dolphin works well in plasma5, how can I have a working dolphin also in KDE4 ???
    manythanks, :-) ciao :-) pier

  2. #2
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: dolphin don't works in KDE4 using LEAP42.1 with wolfi repos

    I think the problem is that the regular "dolphin" under leap is a kf5 application, maybe you should install kde4's dolphin (they can coexist with wolfi's repo)
    Code:
    zypper in dolphin4
    maybe wolfi can be of more help?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •