Results 1 to 6 of 6

Thread: X server crashes when starting libreoffice 5

  1. #1

    Default X server crashes when starting libreoffice 5

    I'm having this problem, not only with openSUSE, not only with LibreOffice and not only with KDE 5 (tried GNOME, Xfce, LXDE, IceWM, MATE, KDE 4).
    I had the same problem with Arch and Fedora.
    The problem is pretty simple: when I start LibreOffice, the mouse pointer stops and the whole X server crashes, showing me SDDM (or GDM). LibreOffice outputs nothing. The problem only appears when starting Writer, Impress & co. both from the DE menu or LibreOffice main window.
    The same thing happens when the DE is under stress (this only happened once when I was browsing an heavy website with Firefox). I tried the following:
    • Alt+F2 then
      kdesu libreoffice
      gksu libreoffice
      depending on the environment (same with terminal); selecting Writer, Calc, Impress & co. causes X server crash;
    • Alt+F2 then
      libreoffice > ~/libreoffice.log
      Selecting Writer, Calc, Impress & co. causes X server crash; a libreoffice.log file is created in my home with no content;

    I am using an AMD Radeon R7 graphics card with xf86-video-ati as driver, on a Lenovo Z50-75.
    This terminal session may be useful (contains /var/log/Xorg.0.log)
    Also, when I re-login to the environment, a xmessage window is shown: Couldn't start ksmserver. Check your installation.
    When I click on okay, X crashes again, but on the next re-login the window does not appear. Obviously this happens only with KDE. The Xorg version is the latest on the main Leap repository:
    altermetax@linux-0pix:~> Xorg -version
    X.Org X Server 1.17.2
    Release Date: 2015-06-16
    X Protocol Version 11, Revision 0
    Build Operating System: openSUSE SUSE LINUX
    Current Operating System: Linux linux-0pix.suse 4.1.13-5-default #1 SMP PREEMPT Thu Nov 26 16:35:17 UTC 2015 (49475c3) x86_64
    Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.1.13-5-default root=UUID=4b751cef-55d0-4dd7-b93c-d76fcbd17f7c ro resume=/dev/disk/by-uuid/bac83ca3-1bd2-48e4-800e-d91bf74637dd splash=silent quiet showopts
    Build Date: 26 November 2015  04:36:11PM
    Current version of pixman: 0.32.6
            Before reporting problems, check
            to make sure that you have the latest version.
    I know LibreOffice has some Java code, so the Java version may be useful:
    altermetax@linux-0pix:~> java -version
    openjdk version "1.8.0_60"
    OpenJDK Runtime Environment (build 1.8.0_60-b27)
    OpenJDK 64-Bit Server VM (build 25.60-b23, mixed mode)
    Everything worked with openSUSE 13.2 KDE 4.
    If I disable desktop effects from the KDE system settings, when I reproduce the problem, on SDDM a window without borders appears with a segfault from kdeinit5 caused by ksmserver; I can't copy-paste the backtrace because I am out of the X session there and so I can't do it.

    Please help me! At the moment I am using Calligra, but I prefer LibreOffice...

  2. #2

    Default Re: X server crashes when starting libreoffice 5

    I've been having a similar problem for several weeks. When I first installed leap (clean install except for /home) libreoffice worked. Sometime in late Nov or early Dec I started having kwin crashes in libreoffice. Search this forum for kwin_x11 for some suggestions although ultimately they didn't solve my problem I did get more understanding for troubleshooting.

    I have Radeon HD7570 card and have tried both with & without flgrx driver. My next step is to try with a different card although that does not make sense to me because I have no problem if using icewm.

    Currently, I can use liberoffice if I logout of Plasma and login using icewm. Since it works for me in icewm I suppose the problem must be in KDE.

    i am unable to get a usuable crash dump because downloading required debugging info pkgs fail with no reason or log file to check.

    I know this isn't an answer for you but I wanted you to know you are not the only one with a libreoffice problem.


  3. #3

    Default Re: X server crashes when starting libreoffice 5

    To me, the whole KDE crashes (kdeinit5) not only kwin. IMO the problem may be the opensource radeon driver (at least here) because X crashes with every desktop. I tried installing FGLRX, but a strange thing happens: the repository doesn't work on my machine (I can't even connect via browser) but it works with a web proxy like Do you know any well-updated AMD FGLRX repositories to use as an alternatives?

  4. #4

    Default Re: X server crashes when starting libreoffice 5

    I cannot connect to the flgrx repository unless I open the firewall on my lan gateway machine. I never fully understood why that was a problem at some sites, I noticed that syn packets were not being acknowledged.

  5. #5

    Default Re: X server crashes when starting libreoffice 5

    Ok, that's strange... my gateway firewall was already disabled. Yesterday the repo didn't work, now works. I didn't edit anything... I'll install fglrx.

  6. #6

    Default Re: X server crashes when starting libreoffice 5

    Mhh... yes, LibreOffice now works, but the performance isn't very good with fglrx...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts