Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: Full screen issue with VLC 2.2.1

  1. #1

    Default Full screen issue with VLC 2.2.1

    Hi guys.

    I have a problem with my VLC 2.2.1, and i cannot see videos full screened mode,
    This is what happens when i double the size or full screen them:

    small size:

    double size:

    full screen:


    PS: i don't have any problem if i uncheck integrate video in interface. But other settings don't fix the issue.
    Also VLC 3 beta doesn't have such an issue for me.

    Thanks
    Last edited by lightblue; 04-Jan-2016 at 08:08. Reason: vlc

  2. #2
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Full screen issue with VLC 2.2.1

    what rep9 is vlc from, that looks like wolfi's test build
    what does
    Code:
    zypper se -si vlc
    say?
    that's the old qt 5.5 bug that was fixed in qt 5.5.1
    if that is vlc from packman a simple qt update should fix it
    Code:
    zypper up

  3. #3

    Default Re: Full screen issue with VLC 2.2.1

    At least, video embedded into main interface. I've two separate windows for video and main interface

  4. #4
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Full screen issue with VLC 2.2.1

    Quote Originally Posted by z1trus View Post
    At least, video embedded into main interface. I've two separate windows for video and main interface
    that was fixed, where did you get vlc from?
    Code:
    zypper se -si vlc
    do an update
    Code:
    zypper up

  5. #5

    Default Re: Full screen issue with VLC 2.2.1

    Quote Originally Posted by I_A View Post
    what rep9 is vlc from, that looks like wolfi's test build
    what does
    Code:
    zypper se -si vlc
    say?
    that's the old qt 5.5 bug that was fixed in qt 5.5.1
    if that is vlc from packman a simple qt update should fix it
    Code:
    zypper up
    Hi I_A and thanks for your great solution
    First, this is the output
    Code:
    mhm@linux-n7s2:~> zypper se -si vlc
    Loading repository data...
    Reading installed packages...
    
    S | Name                   | Type    | Version            | Arch   | Repository            
    --+------------------------+---------+--------------------+--------+-----------------------
    i | libvlc5                | package | 2.2.1-194.1        | x86_64 | SuSE                  
    i | libvlc6                | package | 3.0.0+git5462-3.12 | x86_64 | Packman Repository    
    i | libvlccore8            | package | 2.2.1-194.1        | x86_64 | SuSE                  
    i | libvlccore9            | package | 3.0.0+git5462-3.12 | x86_64 | Packman Repository    
    i | phonon-backend-vlc     | package | 0.8.2-1.2          | x86_64 | openSUSE-Leap-42.1-Oss
    i | phonon4qt5-backend-vlc | package | 0.8.2-2.3          | x86_64 | openSUSE-Leap-42.1-Oss
    i | vlc                    | package | 2.2.1-194.1        | x86_64 | SuSE                  
    i | vlc-codecs             | package | 2.2.1-130.1        | x86_64 | Packman Repository    
    i | vlc-noX                | package | 2.2.1-194.1        | x86_64 | SuSE                  
    i | vlc-noX-lang           | package | 2.2.1-194.1        | noarch | SuSE                  
    i | vlc-qt                 | package | 2.2.1-194.1        | x86_64 | SuSE

    And second, your solution for a simple qt update (zypper up)fixed that issue
    thanks a lot amigo

  6. #6

    Default Re: Full screen issue with VLC 2.2.1

    Quote Originally Posted by z1trus View Post
    At least, video embedded into main interface. I've two separate windows for video and main interface

    Quote Originally Posted by I_A View Post
    that was fixed, where did you get vlc from?
    Code:
    zypper se -si vlc
    do an update
    Code:
    zypper up
    Hi z1trus,
    I_A is right, doing an update will (hopefully) fix the issue

  7. #7
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Full screen issue with VLC 2.2.1

    Hi I_A and thanks for your great solution
    First, this is the output
    Code:
    mhm@linux-n7s2:~> zypper se -si vlc
    Loading repository data...
    Reading installed packages...


    S | Name | Type | Version | Arch | Repository
    --+------------------------+---------+--------------------+--------+-----------------------
    i | libvlc5 | package | 2.2.1-194.1 | x86_64 | SuSE
    i | libvlc6 | package | 3.0.0+git5462-3.12 | x86_64 | Packman Repository
    i | libvlccore8 | package | 2.2.1-194.1 | x86_64 | SuSE
    i | libvlccore9 | package | 3.0.0+git5462-3.12 | x86_64 | Packman Repository
    i | phonon-backend-vlc | package | 0.8.2-1.2 | x86_64 | openSUSE-Leap-42.1-Oss
    i | phonon4qt5-backend-vlc | package | 0.8.2-2.3 | x86_64 | openSUSE-Leap-42.1-Oss
    i | vlc | package | 2.2.1-194.1 | x86_64 | SuSE
    i | vlc-codecs | package | 2.2.1-130.1 | x86_64 | Packman Repository
    i | vlc-noX | package | 2.2.1-194.1 | x86_64 | SuSE
    i | vlc-noX-lang | package | 2.2.1-194.1 | noarch | SuSE
    i | vlc-qt | package | 2.2.1-194.1 | x86_64 | SuSE
    your vlc packages seam to come from a few different reposetories you might want to do a zypper dup with packman to get them all from the packman repo
    you also seam to have vlc 3.0 beta packages from packman (the blue above) you might need to remove them.
    Code:
    zypper lr -d
    see packmans repo number
    Code:
    zypper dup --from <insert packman's repo number>
    or post the output of
    Code:
    zypper lr -d
    ps. you have phonon-backend-vlc phonon4qt5-backend-vlc and those are a bit flaky especially with amarok, you're better off removing them and using phonon-backend-gstreamer phonon4qt5-backend-gstreamer
    Code:
    zypper rm phonon-backend-vlc phonon4qt5-backend-vlc
    zypper in phonon-backend-gstreamer phonon4qt5-backend-gstreamer

  8. #8

    Default Re: Full screen issue with VLC 2.2.1

    Quote Originally Posted by I_A View Post
    your vlc packages seam to come from a few different reposetories you might want to do a zypper dup with packman to get them all from the packman repo
    you also seam to have vlc 3.0 beta packages from packman (the blue above) you might need to remove them.
    Code:
    zypper lr -d
    see packmans repo number
    Code:
    zypper dup --from <insert packman's repo number>
    or post the output of
    Code:
    zypper lr -d
    ps. you have phonon-backend-vlc phonon4qt5-backend-vlc and those are a bit flaky especially with amarok, you're better off removing them and using phonon-backend-gstreamer phonon4qt5-backend-gstreamer
    Code:
    zypper rm phonon-backend-vlc phonon4qt5-backend-vlc
    zypper in phonon-backend-gstreamer phonon4qt5-backend-gstreamer

    Hi I_A and thanks a lot for your complete answers,

    I removed VLC 3.0 betta packages, and this is the output:
    Code:
    mhm@linux-n7s2:~> zypper lr -d
    #  | Alias                               | Name                                    | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                     | Service
    ---+-------------------------------------+-----------------------------------------+---------+-----------+---------+----------+--------+-------------------------------------------------------------------------+--------
     1 | download.nvidia.com-leap            | nVidia Graphics Drivers                 | No      | ----      | Yes     |   99     | rpm-md | http://download.nvidia.com/opensuse/leap/42.1                           |        
     2 | ftp.gwdg.de-suse                    | Packman Repository                      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_Leap_42.1/           |        
     3 | http-download.opensuse.org-5797bb66 | network                                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/network/openSUSE_Leap_42.1/   |        
     4 | http-download.opensuse.org-76c21bae | openSUSE:Leap:42.1:NonFree              | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/       |        
     5 | http-download.videolan.org-f3c764bb | SuSE                                    | No      | ----      | No      |   99     | rpm-md | http://download.videolan.org/SuSE/Leap_42.1/                            |        
     6 | repo-debug                          | openSUSE-Leap-42.1-Debug                | No      | ----      | No      |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.1/repo/oss/     |        
     7 | repo-debug-non-oss                  | openSUSE-Leap-42.1-Debug-Non-Oss        | No      | ----      | No      |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.1/repo/non-oss/ |        
     8 | repo-debug-update                   | openSUSE-Leap-42.1-Update-Debug         | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.1/oss                 |        
     9 | repo-debug-update-non-oss           | openSUSE-Leap-42.1-Update-Debug-Non-Oss | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.1/non-oss/            |        
    10 | repo-non-oss                        | openSUSE-Leap-42.1-Non-Oss              | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/       |        
    11 | repo-oss                            | openSUSE-Leap-42.1-Oss                  | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.1/repo/oss/           |        
    12 | repo-source                         | openSUSE-Leap-42.1-Source               | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/source/distribution/leap/42.1/repo/oss/    |        
    13 | repo-update                         | openSUSE-Leap-42.1-Update               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.1/oss/                      |        
    14 | repo-update-non-oss                 | openSUSE-Leap-42.1-Update-Non-Oss       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.1/non-oss/
    what should i do about them?

    Also i didn't understand what to do with this :
    Code:
    zypper dup --from <insert packman's repo number>
    And what does it mean to do a zypper dup with packman? you mean disabling other repositories and try to do a zypper dup?

    thanks a lot dear amigo

  9. #9
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Full screen issue with VLC 2.2.1

    Quote Originally Posted by lightblue View Post
    Hi I_A and thanks a lot for your complete answers,

    I removed VLC 3.0 betta packages, and this is the output:
    Code:
    mhm@linux-n7s2:~> zypper lr -d
    #  | Alias                               | Name                                    | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                     | Service
    ---+-------------------------------------+-----------------------------------------+---------+-----------+---------+----------+--------+-------------------------------------------------------------------------+--------
     1 | download.nvidia.com-leap            | nVidia Graphics Drivers                 | No      | ----      | Yes     |   99     | rpm-md | http://download.nvidia.com/opensuse/leap/42.1                           |        
     2 | ftp.gwdg.de-suse                    | Packman Repository                      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_Leap_42.1/           |        
     3 | http-download.opensuse.org-5797bb66 | network                                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/network/openSUSE_Leap_42.1/   |        
     4 | http-download.opensuse.org-76c21bae | openSUSE:Leap:42.1:NonFree              | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/       |        
     5 | http-download.videolan.org-f3c764bb | SuSE                                    | No      | ----      | No      |   99     | rpm-md | http://download.videolan.org/SuSE/Leap_42.1/                            |        
     6 | repo-debug                          | openSUSE-Leap-42.1-Debug                | No      | ----      | No      |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.1/repo/oss/     |        
     7 | repo-debug-non-oss                  | openSUSE-Leap-42.1-Debug-Non-Oss        | No      | ----      | No      |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.1/repo/non-oss/ |        
     8 | repo-debug-update                   | openSUSE-Leap-42.1-Update-Debug         | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.1/oss                 |        
     9 | repo-debug-update-non-oss           | openSUSE-Leap-42.1-Update-Debug-Non-Oss | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.1/non-oss/            |        
    10 | repo-non-oss                        | openSUSE-Leap-42.1-Non-Oss              | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/       |        
    11 | repo-oss                            | openSUSE-Leap-42.1-Oss                  | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.1/repo/oss/           |        
    12 | repo-source                         | openSUSE-Leap-42.1-Source               | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/source/distribution/leap/42.1/repo/oss/    |        
    13 | repo-update                         | openSUSE-Leap-42.1-Update               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.1/oss/                      |        
    14 | repo-update-non-oss                 | openSUSE-Leap-42.1-Update-Non-Oss       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.1/non-oss/
    what should i do about them?

    Also i didn't understand what to do with this :
    Code:
    zypper dup --from <insert packman's repo number>
    And what does it mean to do a zypper dup with packman? you mean disabling other repositories and try to do a zypper dup?

    thanks a lot dear amigo
    you should install all openSUSE patches tp get Qt 5.5.1 so do
    Code:
    zypper patch
    according to your list packman's repo number is 2 to do a full vendor change with packman execute
    Code:
    zypper dup --from 2

  10. #10

    Default Re: Full screen issue with VLC 2.2.1

    Quote Originally Posted by I_A View Post
    you should install all openSUSE patches tp get Qt 5.5.1 so do
    Code:
    zypper patch
    according to your list packman's repo number is 2 to do a full vendor change with packman execute
    Code:
    zypper dup --from 2
    Many many thanks for your guide I_A
    Just a question about Gstream as you mentioned before,
    I can only play M4A with VLC and not with Amarok, is it because i removed phonon-backend-vlc and started using gstream instead?

    thanks amigo

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •