Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Intermittent Boot Failure On 13.2 With Windows 10

  1. #1

    Default Intermittent Boot Failure On 13.2 With Windows 10

    I'm finding every now and then that I can't get into the opensuse GUI, i.e. I get an emergency recovery command line prompt.

    This is the feed from the suggested command, which outputs the systemlogs:

    http://pastebin.com/S5XDYvh2

    Some errors:

    Code:
    Jan 04 10:08:05 pegasus lvm[545]: WARNING: lvmetad is running but disabled. Restart lvmetad before enabling it!
    
    Jan 04 10:08:06 pegasus mount[524]: Windows is hibernated, refused to mount.

    I have my Windows partition mounted in opensuse, and towards the end of the system log there are some complaints about the Windows partition having gone into hibernation and that therefore it could not be mounted.

    This has happened a few times. I haven't been able to do anything to fix the problem yet, but it seems to resolve itself of its' own accord after booting into Windows a few times.

    Should I remove the Windows partition from fstab or is there some other way to fix this?
    "In the future, everything will work."

    Schwa

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    22,047

    Default Re: Intermittent Boot Failure On 13.2 With Windows 10

    Well, it says that you did not shutdown your Windows OS properly (thus leaving your file system in an unproper state). The first question is thus: did you shutdown your Windows system completly and correct?

    The message is clear enough IMHO, but you do not address it at all.
    Henk van Velden

  3. #3

    Default Re: Intermittent Boot Failure On 13.2 With Windows 10

    Quote Originally Posted by hcvv View Post
    Well, it says that you did not shutdown your Windows OS properly (thus leaving your file system in an unproper state). The first question is thus: did you shutdown your Windows system completly and correct?

    The message is clear enough IMHO, but you do not address it at all.
    Yes I should have said, I always shut down Windows cleanly. If it hibernates I will always wake it up before shutting down, so I honestly don't know what's going on here.
    "In the future, everything will work."

    Schwa

  4. #4

    Default Re: Intermittent Boot Failure On 13.2 With Windows 10

    On 2016-01-04, Wild Goose <Wild_Goose@no-mx.forums.microfocus.com> wrote:
    > Yes I should have said, I -always- shut down Windows cleanly. If it
    > hibernates I will always wake it up before shutting down, so I honestly
    > don't know what's going on here.


    Try booting into Windows. Then select `Restart' rather than `Shutdown'. Upon reboot, select openSUSE from GRUB2 to load:
    do you still get an emergency prompt?

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    22,047

    Default Re: Intermittent Boot Failure On 13.2 With Windows 10

    I think I read here on the forums that some newer version of Windows does in fact not shutdown, but sort of hybernate. I remember also that you could set something somewhere in Windows to configure that.

    Sorry about my vagueness, but I know next to nothing about Windows and feel no urge to improve that.

    HTH
    Henk van Velden

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    9,164
    Blog Entries
    3

    Default Re: Intermittent Boot Failure On 13.2 With Windows 10

    Quote Originally Posted by Wild_Goose View Post
    Jan 04 10:08:06 pegasus mount[524]: Windows is hibernated, refused to mount.
    You need to login to Windows, and turn off fast-boot. You can probably find tutorials on how to do that (use google or other search engine). I've avoided Windows 10, but I managed to find where to turn off fast-boot in Windows 8. It wasn't obvious, but it wasn't too hard to find.

    With "fast-boot", Windows hibernates leaving the file system in an unstable state.

    From Windows, if you "restart" instead of "shutdown", that is supposed to not do this hibernation thingy.

    On Windows 8.1, I can right click at the bottom left corner of the screen and shutdown from there. It is supposed to not do the hibernation/fast-boot thingy if I shutdown that way, though I have never tested that (because I have fast-boot turned off anyway).
    opensuse Leap 42.3; KDE Plasma 5;
    opensuse tumbleweed; KDE Plasma 5 (test system);

  7. #7

    Default Re: Intermittent Boot Failure On 13.2 With Windows 10

    Quote Originally Posted by nrickert View Post
    You need to login to Windows, and turn off fast-boot. You can probably find tutorials on how to do that (use google or other search engine). I've avoided Windows 10, but I managed to find where to turn off fast-boot in Windows 8. It wasn't obvious, but it wasn't too hard to find.

    With "fast-boot", Windows hibernates leaving the file system in an unstable state.

    From Windows, if you "restart" instead of "shutdown", that is supposed to not do this hibernation thingy.

    On Windows 8.1, I can right click at the bottom left corner of the screen and shutdown from there. It is supposed to not do the hibernation/fast-boot thingy if I shutdown that way, though I have never tested that (because I have fast-boot turned off anyway).
    Thanks, I will try that.

    I've just seen another error in the log relating to ACPI which may be relevant, I don't know:

    Code:
    Jan 04 10:07:59 pegasus kernel: ACPI Warning: SystemIO range 0x0000000000000428-0x000000000000042f conflicts with OpRegion 0x0000000000000400-0x000000000000047f (\PMIO) (20140424/utaddress-258)
    
    Jan 04 10:07:59 pegasus kernel: ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
    "In the future, everything will work."

    Schwa

  8. #8

    Default Re: Intermittent Boot Failure On 13.2 With Windows 10

    On 2016-01-04, Wild Goose <Wild_Goose@no-mx.forums.microfocus.com> wrote:
    > I've just seen another error in the log relating to ACPI which may be
    > relevant, I don't know:


    Sorry, I can't see how an ACPI Warning is pertinent to an lvmetad error. Did you try the Windows restart test I
    suggested?

  9. #9
    Join Date
    Nov 2009
    Location
    West Virginia Sector 9
    Posts
    14,591

    Default Re: Intermittent Boot Failure On 13.2 With Windows 10

    If Win 8 or higher you must turn off fast boot. it in essence is the same as hibernate

  10. #10

    Default Re: Intermittent Boot Failure On 13.2 With Windows 10

    Quote Originally Posted by flymail View Post
    On 2016-01-04, Wild Goose <Wild_Goose@no-mx.forums.microfocus.com> wrote:
    > I've just seen another error in the log relating to ACPI which may be
    > relevant, I don't know:


    Sorry, I can't see how an ACPI Warning is pertinent to an lvmetad error. Did you try the Windows restart test I
    suggested?
    Well I just thought if there was an ACPI warning there might be a power management issue and that may affect hibernation issues, but that was just a stab in the dark.

    I followed these instructions on disabling fast boot in Windows 10:

    http://www.tenforums.com/tutorials/4...dows-10-a.html

    I then fully shut down Windows, started it, shut it down again, started it again, then restarted from Windows into opensuse with no problems, so hopefully that has sorted it. Thanks for all your help.
    "In the future, everything will work."

    Schwa

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •