Results 1 to 4 of 4

Thread: Window Manager not managing Activities

  1. #1
    Join Date
    Apr 2013
    Location
    Sydney, AU
    Posts
    243

    Default Window Manager not managing Activities

    Can somebody else plse confirm this as well:

    (RH click window title bar)

    More Actions
    Window Manager Settings
    Window Rules
    Modify or New
    Size & Position
    Activate
    Activity => stuck on 'ALL ACTIVITIES"

    ... but when you set the window's ACTIVITY under

    More Actions
    Special Applications/Window Settings
    Size & Position
    Activate
    Select the Activity

    ... it still does not appear in the Window Manager as cited above.


    Thnx

    42.1
    openSUSE Leap 15.1 | KDE Plasma 5.12.8 | Frameworks 5.55.0 | Qt 5.9.7 | Kernel 4.12.14-lp151.27-default | Procs 4 x i5-2500 CPU @ 3.3.GHz | 15.6 GiB RAM | 4 Monitors

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,621
    Blog Entries
    3

    Default Re: Window Manager not managing Activities

    My experience is that if I try to set to a different activity than the current one, it instead goes to "all activities". But if I then switch my session to use the intended activity, I am then able to switch the window to that particular activity.

    It seems that a window can only be set to "all activities" or to the current activity.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: Window Manager not managing Activities

    I suppose that is another example of how Activities are "better" than virtual desktops.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  4. #4
    Join Date
    Apr 2013
    Location
    Sydney, AU
    Posts
    243

    Default Re: Window Manager not managing Activities

    Quote Originally Posted by Fraser_Bell View Post
    I suppose that is another example of how Activities are "better" than virtual desktops.


    ... "better" maybe ... but if not a bug then bad design for sure!!


    doing the same with the 'Window Manager Settings' dialog under Mint 17.1 (.kde not .kde4) all the 'Activities' are presented in the combo box for selection .. whereas here (OpenSUSE / .kde4) the combo box for setting the 'Activity' that an application should belong to is frozen on 'ALL ACTIVITES' (using Window Manager Settings).... albeit the same interface when exposed through either the 'Special Window / Application Settings ...' menu option allows the user to choose which Activity the application (or window??) should belong to.

    ... but this is not where the bug ends!!! ... as the 'frozen' ALL APPLICATIONS value from the Window Manager populates the same data field when editing previously assigned window/application settings via the 'Special Window / Applications ...' menu option, overwriting what one might have chosen before!! ..and then of course if not noticed, when saving those settings the assignment is returned to 'All Activities'.

    AND THEN .. to make matters worse (or more confusing) each time one 'edits the Special Window / Applications Settings using the menu option of the same name, a separate Window Rule is written to the system (see under Window Manager Settings > Window Rules tab) ... ... instead of updating the Window Rule that already exists!! .. Hence the system must (and does) get confused (or is it just me ) which Window Rule to use when the application is loaded again ... OR maybe this is the way it is designed?? Either way most confusing to understand and to configure.

    So 'Better' you say??? *ahah*
    openSUSE Leap 15.1 | KDE Plasma 5.12.8 | Frameworks 5.55.0 | Qt 5.9.7 | Kernel 4.12.14-lp151.27-default | Procs 4 x i5-2500 CPU @ 3.3.GHz | 15.6 GiB RAM | 4 Monitors

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •