Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: Time Format

  1. #1

    Default Time Format

    How do I change the time format? I want 21:30, not 9:30 PM.

  2. #2

    Default Re: Time Format

    Where? Are you in KDE, Gnome, or something else? Are you seeing this
    time format from something on the command line?

    I use 24-hour time on my laptop in KDE and I'm sure I changed it by
    right-clicking on the click and then choosing 'Digital Clock Settings'.

    --
    Good luck.

    If you find this post helpful and are logged into the web interface,
    show your appreciation and click on the star below...

  3. #3

    Default Re: Time Format

    Where? Are you in KDE, Gnome, or something else? Are you seeing this
    time format from something on the command line?

    I use 24-hour time on my laptop in KDE and I'm sure I changed it by
    right-clicking on the click and then choosing 'Digital Clock Settings'.

    --
    Good luck.

    If you find this post helpful and are logged into the web interface,
    show your appreciation and click on the star below...

  4. #4
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: Time Format

    Quote Originally Posted by KenHolloway View Post
    How do I change the time format? I want 21:30, not 9:30 PM.
    Which Desktop might help.

    In KDE4, Configure Settings=>Locale
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  5. #5
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,547

    Default Re: Time Format

    in plasma 5 the setting is initially set by your locale selection (as it was in KDE 4 I think).
    If you want to change it simply right click on the clock and choose "digital clock settings" and uncheck or check "use 24 hour clock"

    this is assuming you mean the taskbar clock

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,153

    Default Re: Time Format

    Quote Originally Posted by farcusnz View Post
    this is assuming you mean the taskbar clock
    Yes, assumptions, assumptions.

    I am always amazed by the answers based on assumptions (because the OP fails to explain much).

    While this shows the willingness of people here to help (very laudable), OTOH I am not sure if this contributes to understandable threads.
    Henk van Velden

  7. #7

    Default Re: Time Format

    I am using openSUSE Leap 42.1, with KDE.

    In older version (like openSUSE 13.1), you can change the time format in Configure Desktop > Locale > Date & Time.

    In 42.1, I do not see any way to change the Time Format. The closest thing I found is in Configure Desktop > Regional Settings > Date & Time - but all you can do is pick a pre-defined Time Zone.


    I do see that you can change the Digital Clock Settings for the taskbar clock (Use 24-hour Clock), but I can not find a more global setting for "everything else"....

  8. #8
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,744

    Default Re: Time Format

    Desktop setting are only for the current user global system settings are in yast.

    Be sure you are running systemsettings5 otherwise you maybe running the older KDE4 version

  9. #9

    Default Re: Time Format

    I meant global, as in every application I run; not global, as in every user.

    Yes, when I run Settings > Configure Desktop, it is running systemsettings5.

    Also, when I change the Digital Clock Settings to "Use 24-hour Clock", it displays the time as "7:30" - it should be (and has been in past versions) "07:30". Is there any way to fix this?

    Thanks,
    Ken

  10. #10

    Default Re: Time Format

    KDE, Using 24 hrs works for me but I have not found a setting that displays the leading 0 nor a way to get rid of the ':' between hh:mm. I.E., I can get 7:30 but not 0730.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •