Results 1 to 6 of 6

Thread: Odd problem with (kde) kate following the 20151229 TW snapshot.

  1. #1
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,297

    Default Odd problem with (kde) kate following the 20151229 TW snapshot.

    I'm encountering a rather odd problem with kate following the 20151229 TW snapshot (which included the kde-frameworks-5.17.0 update).

    Kate 15.08.3
    KDE Frameworks 5.17.0
    Qt 5.5.1 (built against 5.5.1)

    Problem is...

    Open Dolphin and navigate to a text file. Either left click or use context menu 'open with' (kate). Kate then opens and loads the file. So far nothing wrong.

    Now, close kate and repeat the process. This time the busy cursor is displayed but kate does not open. In fact, from now on kate can not be launced from within Dolphin.

    If I log out/in then kate will again work correctly... but only the once.

    Affects all users, including a new test user, I see the same if instead of using Dolphin I launch kate from Krusader.

    After the second (failed) attempt to open a text file the following is appended to "xsession-errors-:0"

    Code:
    kdeinit5: Got EXT_EXEC '/usr/bin/kate' from launcher.
    kdeinit5: preparing to launch '/usr/bin/kate'
    QXcbConnection: XCB error: 3 (BadWindow), sequence: 43505, resource id: 92274689, major code: 18 (ChangeProperty), minor code: 0
    kate: openURL
    I'm afraid I don't know the significance of the "XCB" error. The only other thing that looks vaguely suspicious is the "kate: openURL" with nothing specified; (should that perhaps be the filename?). Although I don't see it anywhere earlier in "xsession-errors-:0" (ie, from the first, working, open).
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191109) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,778
    Blog Entries
    3

    Default Re: Odd problem with (kde) kate following the 20151229 TW snapshot.

    Just a guess.

    I would guess that kate has not shutdown properly. Maybe try: ps -ef | grep kate
    If it is still running, try the "kill" command from a terminal.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,297

    Default Re: Odd problem with (kde) kate following the 20151229 TW snapshot.

    Quote Originally Posted by nrickert View Post
    ... I would guess that kate has not shutdown properly. ...
    Code:
    paul@Orion-Tumble:~$ ps -ef | grep kate
    paul      1845  1451  0 14:04 ?        00:00:00 /usr/bin/kate -b /home/paul/Temporary/bug-report.txt
    paul      1890  1866  0 14:06 pts/0    00:00:00 grep --color=auto kate
    paul@Orion-Tumble:~$
    A swift "kill 1845" and kate then lauches OK from within Dolphin ... again, just the once.

    Spot on... Many thanks.

    So I guess the question now is "why isn't kate shutting down correctly"?

    A little more playing around and I've found that if I use "File -> Quit" instead of the "Close" button, kate terminates correctly.

    I guess a bug report is probably in order.
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191109) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,987
    Blog Entries
    14

    Default Re: Odd problem with (kde) kate following the 20151229 TW snapshot.

    Quote Originally Posted by tannington View Post
    Code:
    paul@Orion-Tumble:~$ ps -ef | grep kate
    paul      1845  1451  0 14:04 ?        00:00:00 /usr/bin/kate -b /home/paul/Temporary/bug-report.txt
    paul      1890  1866  0 14:06 pts/0    00:00:00 grep --color=auto kate
    paul@Orion-Tumble:~$
    A swift "kill 1845" and kate then lauches OK from within Dolphin ... again, just the once.

    Spot on... Many thanks.

    So I guess the question now is "why isn't kate shutting down correctly"?

    A little more playing around and I've found that if I use "File -> Quit" instead of the "Close" button, kate terminates correctly.

    I guess a bug report is probably in order.
    One moment. Do you have the "Kate-sessions" option checked in the systemtray's settings? If so, uncheck it and see if the problem persists.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,297

    Default Re: Odd problem with (kde) kate following the 20151229 TW snapshot.

    Quote Originally Posted by Knurpht View Post
    One moment. Do you have the "Kate-sessions" option checked in the systemtray's settings? If so, uncheck it and see if the problem persists.
    No, that is currently unchecked. Just to be certain, I've tried enabling it, log out/in, then disabled it again, log out/in. Still seeing the same behaviour.

    Another thing I've just found is:

    If kate is simply lauched from the application menu and "terminated" by using the "close" button, (where it does start on each occasion); for each launch/close there is a kate process left behind. Following example is after three launch/close.

    Code:
    paul@Orion-Tumble:~$ ps -ef | grep kate
    paul      1573  1451  2 15:10 ?        00:00:00 /usr/bin/kate -b
    paul      1605  1451  4 15:11 ?        00:00:00 /usr/bin/kate -b
    paul      1610  1451 13 15:11 ?        00:00:00 /usr/bin/kate -b
    paul      1616  1580  0 15:11 pts/0    00:00:00 grep --color=auto kate
    paul@Orion-Tumble:~$
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191109) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  6. #6
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,297

    Default Re: Odd problem with (kde) kate following the 20151229 TW snapshot.

    Updated a second PC to 20160101 and seeing the same behaviour.

    Bug report:

    https://bugs.kde.org/show_bug.cgi?id=357523

    Edit: where it has just been confirmed by another user.
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191109) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •