Results 1 to 6 of 6

Thread: Gajim: ImportError: could not import gst

  1. #1

    Default Gajim: ImportError: could not import gst

    Hello. Help please, I'm see this old problem on the startup Gajim... -

    ImportError: could not import gst

    and I don't know, how to solve this problem?
    The similar problem in Fedora 23: https://bugzilla.redhat.com/show_bug.cgi?id=1279047


    Code:
    > LC_ALL=C zypper info gajim 
    Loading repository data...
    Reading installed packages...
    
    
    Information for package gajim:
    ------------------------------
    Repository: repo-oss
    Name: gajim
    Version: 0.16.4-1.1
    Arch: noarch
    Vendor: openSUSE
    Installed: Yes
    Status: up-to-date
    Installed Size: 9.1 MiB
    Summary: Full-featured XMPP client written in Python and Gtk2
    Description: 
    
    

  2. #2

    Default Re: Gajim: ImportError: could not import gst

    Code:
    (gajim:9175): GLib-GObject-CRITICAL **: g_object_set_qdata: assertion 'G_IS_OBJECT (object)' failed
    
    (gajim:9175): GLib-GObject-CRITICAL **: g_object_set_qdata: assertion 'G_IS_OBJECT (object)' failed
    
    
    (gajim:9175): GLib-GObject-CRITICAL **: g_object_set_qdata: assertion 'G_IS_OBJECT (object)' failed
    
    
    (gajim:9175): GLib-GObject-CRITICAL **: g_object_set_qdata: assertion 'G_IS_OBJECT (object)' failed
    
    
    (gajim:9175): GLib-GObject-CRITICAL **: g_object_set_qdata: assertion 'G_IS_OBJECT (object)' failed
    
    
    (gajim:9175): GLib-GObject-CRITICAL **: g_object_set_qdata: assertion 'G_IS_OBJECT (object)' failed
    
    
    (gajim:9175): GLib-GObject-CRITICAL **: g_object_set_qdata: assertion 'G_IS_OBJECT (object)' fail

  3. #3

    Default Re : Gajim: ImportError: could not import gst

    Hello,

    Install python-gstreamer-0_10.

    Regards

  4. #4

    Default Re: Re : Gajim: ImportError: could not import gst

    Quote Originally Posted by 1Antoine1 View Post
    Install python-gstreamer-0_10.
    Done.


    Code:
    ~> gajim
    ** Message: pygobject_register_sinkfunc is deprecated (GstObject)
    Traceback (most recent call last):
      File "gajim.py", line 492, in <module>
        from gui_interface import Interface
      File "/usr/lib/python2.7/site-packages/gajim/common/demandimport.py", line 114, in _demandimport
        mod = _origimport(name, globals, locals)
      File "/usr/lib/python2.7/site-packages/gajim/gui_interface.py", line 85, in <module>
        from common.connection import Connection
      File "/usr/lib/python2.7/site-packages/gajim/common/demandimport.py", line 114, in _demandimport
        mod = _origimport(name, globals, locals)
      File "/usr/lib/python2.7/site-packages/gajim/common/connection.py", line 62, in <module>
        from connection_handlers import *
      File "/usr/lib/python2.7/site-packages/gajim/common/demandimport.py", line 95, in _demandimport
        return _import(name, globals, locals, fromlist, level)
      File "/usr/lib/python2.7/site-packages/gajim/common/connection_handlers.py", line 1
         
        ^
    SyntaxError: invalid syntax
    
    

  5. #5

    Default Re: Gajim: ImportError: could not import gst

    Sorry. It's no Gajim. Whats happened?

    ~> LC_ALL=C sudo zypper up
    sudo: error in /etc/sudo.conf, line 0 while loading plugin `sudoers_policy'
    sudo: unable to load /usr/lib/sudo/sudoers.so: /usr/lib64/libsasl2.so.3: invalid ELF header
    sudo: fatal error, unable to load plugins
    ~> kwrite
    kwrite: error while loading shared libraries: /usr/lib64/libsasl2.so.3: invalid ELF header


  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,703

    Default Re: Gajim: ImportError: could not import gst

    Check you drive

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •