Results 1 to 5 of 5

Thread: Leap 42.1 "compositing not active" under Plasmashell 5.5.2 with NVidia 304.131 drivers (7950 GTX)

  1. #1

    Default Leap 42.1 "compositing not active" under Plasmashell 5.5.2 with NVidia 304.131 drivers (7950 GTX)

    Hi guys.

    Fresh 42.1 setup with NVidia Geforce Go 7950 GTX (Dell XPS M1710):

    With default Plasma 5.4.2 I run into trouble with desktop compositing. Finally I can't set compositing to active under OpenGL2 backend. XRender seems to work but is not an option. Too slow.

    Some infos:
    I installed the latest official NVidia 304.131 driver from the NVidia repo. Then I blacklisted the nouveau driver in /etc/modprobe.d and I put nomodeset string in the kernel cmdline. After restart I verified that the nouveau driver wasn't loaded and that the NVidia driver worked properly.

    In Plasma Systemsettings->Display and Monitor->Compositor-> OpenGL2.0 and GLX is selected.

    Shell output from "qdbus org.kde.KWin /KWin supportInformation"
    KWin version: 5.5.2
    Qt Version: 5.5.1
    Qt compile version: 5.5.1
    XCB compile version: 1.11.1
    Operation Mode: X11 only
    Build Options
    HAVE_INPUT: yes
    HAVE_DRM: yes
    HAVE_GBM: yes
    HAVE_X11_XCB: yes
    Vendor: The X.Org Foundation
    Vendor Release: 11702000
    Protocol Version/Revision: 11/0
    SHAPE: yes; Version: 0x11
    RANDR: yes; Version: 0x14
    DAMAGE: yes; Version: 0x11
    Composite: yes; Version: 0x4
    RENDER: yes; Version: 0xb
    XFIXES: yes; Version: 0x50
    SYNC: yes; Version: 0x31
    GLX: yes; Version: 0x0
    Plugin: org.kde.breeze
    Blur: 0
    onAllDesktopsAvailable: true
    alphaChannelSupported: false
    closeOnDoubleClickOnMenu: false
    decorationButtonsLeft: 0, 2
    decorationButtonsRight: 6, 3, 4, 5
    borderSize: 3
    gridUnit: 14
    font: Noto Sans,10,-1,0,50,0,0,0,0,0
    smallSpacing: 3
    largeSpacing: 14
    focusPolicy: 0
    nextFocusPrefersMouse: false
    clickRaise: true
    autoRaise: false
    autoRaiseInterval: 0
    delayFocusInterval: 0
    shadeHover: false
    shadeHoverInterval: 250
    separateScreenFocus: false
    placement: 4
    focusPolicyIsReasonable: true
    borderSnapZone: 10
    windowSnapZone: 10
    centerSnapZone: 0
    snapOnlyWhenOverlapping: false
    rollOverDesktops: true
    focusStealingPreventionLevel: 1
    legacyFullscreenSupport: false
    operationTitlebarDblClick: 5000
    operationMaxButtonLeftClick: 5000
    operationMaxButtonMiddleClick: 5015
    operationMaxButtonRightClick: 5014
    commandActiveTitlebar1: 0
    commandActiveTitlebar2: 30
    commandActiveTitlebar3: 2
    commandInactiveTitlebar1: 4
    commandInactiveTitlebar2: 30
    commandInactiveTitlebar3: 2
    commandWindow1: 7
    commandWindow2: 8
    commandWindow3: 8
    commandWindowWheel: 31
    commandAll1: 10
    commandAll2: 3
    commandAll3: 14
    keyCmdAllModKey: 16777251
    showGeometryTip: false
    condensedTitle: false
    electricBorderMaximize: true
    electricBorderTiling: true
    electricBorderCornerRatio: 0.25
    borderlessMaximizedWindows: false
    killPingTimeout: 5000
    hideUtilityWindowsForInactive: true
    inactiveTabsSkipTaskbar: false
    autogroupSimilarWindows: false
    autogroupInForeground: true
    compositingMode: 1
    useCompositing: true
    compositingInitialized: true
    hiddenPreviews: 1
    unredirectFullscreen: false
    glSmoothScale: 2
    colorCorrected: false
    xrenderSmoothScale: false
    maxFpsInterval: 16666666
    refreshRate: 0
    vBlankTime: 6000000
    glStrictBinding: false
    glStrictBindingFollowsDriver: true
    glCoreProfile: false
    glPreferBufferSwap: 99
    glPlatformInterface: 1
    Screen Edges
    desktopSwitching: false
    desktopSwitchingMovingClients: false
    cursorPushBackDistance: 1x1
    timeThreshold: 150
    reActivateThreshold: 350
    actionTopLeft: 0
    actionTop: 0
    actionTopRight: 0
    actionRight: 0
    actionBottomRight: 0
    actionBottom: 0
    actionBottomLeft: 0
    actionLeft: 0
    Multi-Head: no
    Active screen follows mouse:  no
    Number of Screens: 1
    Screen 0:
    Name: LVDS-0
    Geometry: 0,0,1920x1200
    Refresh Rate: 59.9687
    Compositing is not active
    This shows compositing is not active and I cant get it to run with OpenGL2. No idea how. No matter what I try.

    Shell output from "glxinfo | grep OpenGL"
    OpenGL vendor string: NVIDIA Corporation
    OpenGL renderer string: GeForce Go 7950 GTX/PCIe/SSE2
    OpenGL version string: 2.1.2 NVIDIA 304.131
    OpenGL shading language version string: 1.20 NVIDIA via Cg compiler
    OpenGL extensions:
    OpenGL ES profile version string: OpenGL ES 2.0 NVIDIA 304.131 304.131
    OpenGL ES profile shading language version string: OpenGL ES GLSL ES 1.00
    OpenGL ES profile extensions:
    Shell output from "glxinfo | grep glx"
    server glx vendor string: NVIDIA Corporation
    server glx version string: 1.4
    server glx extensions:
    client glx vendor string: NVIDIA Corporation
    client glx version string: 1.4
    client glx extensions:
    Shell output from "cat /var/log/XOrg.0.log":

    So after testing around I decided to add repo and make a zypper dup (I know diff between up and dup) to update to Plasma 5.5.2 and Frameworks. Then I removed the NVidia repo and the G02 driver. After that I manually installed the driver from the cmdline. The compilation and installation worked without any errors and after a restart the driver runs without any problems.

    Everything seems to work but still no desktop effects because compositing is still not active, even under Plasma 5.5.2. The last thing I did was to add the X11Org repo for up to date mesa stuff and I switched to Kernel 4.1.15. But that also doesn't take any effect on activating compositing under plasmashell. I dont know where to start troubleshooting. So what you mean, is this a Plasma or NVidia issue, or what? Any help or workaround possible?

    Thx, Kai

  2. #2
    Join Date
    Nov 2009
    West Virginia Sector 13

    Default Re: Leap 42.1 "compositing not active" under Plasmashell 5.5.2 with NVidia 304.131 drivers (7950 GTX

    NVIDIA driver uses it own mesa stuff. so installing a repo mesa will break NVIDIA or at least slow it.

  3. #3
    Join Date
    Aug 2010
    Chicago suburbs
    Blog Entries

    Default Re: Leap 42.1 "compositing not active" under Plasmashell 5.5.2 with NVidia 304.131 drivers (7950 GTX

    I have an older box with Nvidia 6150LE, that uses the drivers. It doesn't work well with Plasma 5. I've had to switch to XRender for compositing.

    I also installed "Stellarium" on that box, and it complains about OpenGL2 support having problems. So I don't think it is just a KDE issue. It might be that the Nvidia drivers have not adequately kept up with other changes in Xorg.

    I also discovered that I cannot run Gnome on that box. It freezes just after startup. However, I currently have a test install of another distro, where Gnome 18.1 runs pretty well using nouveau drivers. Maybe it is time for me to consider giving up on nvidia drivers.
    openSUSE Leap 15.1; KDE Plasma 5;

  4. #4

    Default Re: Leap 42.1 "compositing not active" under Plasmashell 5.5.2 with NVidia 304.131 drivers (7950 GTX

    No ideas??

  5. #5

    Default Re: Leap 42.1 "compositing not active" under Plasmashell 5.5.2 with NVidia 304.131 drivers (7950 GTX

    Could be a case of an older gpu not being supported.
    I will look into my older laptop when I boot it, it is a 6 year old lappy dual core amd athlon x_64 witn nvidia card
    using and still capable of handling the plasma 5 compositing with openGL enabled.
    People who do not break things first will never learn to create anything

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts