Results 1 to 6 of 6

Thread: issues with firefox and Application restore after reboot

  1. #1

    Default issues with firefox and Application restore after reboot

    Hi

    I have 13.2 with KDE running very nicely with all current updates, my production environment. I am trying out Leap42.1 (with KDE) so as to upgrade once during 2016, hopefully.
    I have done the upgrade from a full copy of 13.2 on a separate computer as explained in the https://en.opensuse.org/SDB:System_upgrade. (Twice, second upgrade was much better!, Thank you).




    Issues with Leap42.1 seen so far:
    1) Restore of open applications (konsole, dolphin) after reboot is not done, but in KDE is activated.

    2) Using Icons "oxygen", not the new ones. works ok with dolphin, but firefox uses the new ones.

    3) firefox has a very bad font (not sharp!), I have set under KDE the liberation Fonts (ok in dolphin and konsole), but firefox does not use the icons and the fonts as chosen in KDE. This font problem is most annoying.

    4) In KDE under 13.2, the audio mixer allows sliders vertically, which is quite natural, under Leap42.1 only horizontal and the sliders seem not to be sensitive to the mouse wheel (under 13.2 each an every slider is easily adjusted by mouse wheel). The old way is great.

    I will try update once in a while and see, if the issues are gone...

    Comments are wellcome.

    Wippi

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,363
    Blog Entries
    3

    Default Re: issues with firefox and Application restore after reboot

    Quote Originally Posted by flexwippi View Post
    3) firefox has a very bad font (not sharp!), I have set under KDE the liberation Fonts (ok in dolphin and konsole), but firefox does not use the icons and the fonts as chosen in KDE. This font problem is most annoying.
    I think that was the google-roboto-fonts. You could try uninstalling, and then blacklisting so that it won't be reinstalled.

    4) In KDE under 13.2, the audio mixer allows sliders vertically, which is quite natural, under Leap42.1 only horizontal and the sliders seem not to be sensitive to the mouse wheel (under 13.2 each an every slider is easily adjusted by mouse wheel). The old way is great.
    I'm trying to live with the new way. But you can disable the audio applet in tray settings, and run Kwin instead. That should give back some of the old behavior.
    openSUSE Leap 15.1; KDE Plasma 5;

  3. #3

    Default Re: issues with firefox and Application restore after reboot

    Quote Originally Posted by nrickert View Post
    I think that was the google-roboto-fonts. You could try uninstalling, and then blacklisting so that it won't be reinstalled..
    Hi

    Thank you for the quick reply.
    As second test, I am using a "clean (not upgrade from 13.2)" Leap42.1-Installation in a VirtualBox on my Suse13.2, so I can try things.
    According to your recommendation, I have removed ALL Google-fonts for test. That gives some problems with Qt5-Packages, but anyway.
    Then I removed Firefox and reinstalled it again. Now, the firefox has a much better font. I also tried, to remove only the google-roboto-package, but that is not sufficient: after Reinstall of firefox, the font looks ugly again. So, there must be another googlefont. Which one?

    But the basic problem remains, that Firefox does not use my selected Fonts and Icons under KDE.

    Quote Originally Posted by nrickert View Post
    I'm trying to live with the new way. But you can disable the audio applet in tray settings, and run Kwin instead. That should give back some of the old behavior.
    Removal of the "systemabschnitt", then install of kwin. Gives the following error:

    kwin: unable to claim manager selection, another wm running? (try using --replace)
    It is a pity, that newer software does throw away good things!

    BTW, I have seen, that the basic install of 42.1 gives a total more than 9140 fonts when listing under X11. Why install ALL in the first place?

    The problem with the restoration of programs of the session after reboot remains also a problem!

    The only positive thing so far, is, that the upgrade from 13.2 to 42.1 seems to work. Most installed things from 13.2 survive the upgrade!
    It seems, that I have to wait for better times.

    wippi

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,363
    Blog Entries
    3

    Default Re: issues with firefox and Application restore after reboot

    Quote Originally Posted by flexwippi View Post
    Removal of the "systemabschnitt", then install of kwin.
    Oops. Bad typo by me. It should have been "Kmix", not "Kwin". And it is probably installed already.
    openSUSE Leap 15.1; KDE Plasma 5;

  5. #5

    Default Re: issues with firefox and Application restore after reboot

    Quote Originally Posted by nrickert View Post
    Oops. Bad typo by me. It should have been "Kmix", not "Kwin". And it is probably installed already.
    Hi nrickert

    Thank you for the correction. I could have thought about Kwin as possibly a Window Manager...

    I have made a fully new installation of leap42.1 in VirtualBox. Then I removed firefox, all google-Fonts and reinstalled firefox.

    Unfortunately, the quality of the font remains very ugly. I do not understand the font settings for firefox. But since ffx is very important for my daily work, I can not accept this bad quality. I made a jpeg-screenshot of both ffx (13.2 host, 42.1 guest), but I don't know, how to send this attachment.

    I have also switched to "KDE Plasma Workspace" instead of "Plasma 5", but the app restore does not work here also.

    Leap is not yet ready for my work. Is there a chance, that these problems will be solved in the next few months?

    wippi

  6. #6

    Default Re: issues with firefox and Application restore after reboot

    Hi nickert

    I have looked into the preferences of firefox: there is a Entry named "content", where one can select a font and a size!!!

    So, I was able to change the font to Liberation sans. Now, I am quite happy. The other issues are less annoying.

    Thanks for your help

    wippi

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •