Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Internet not working, KDE, motherboard ethernet

  1. #1

    Default Internet not working, KDE, motherboard ethernet

    The Opensuse Leap 42.1 DVD - 'update install' option asks me to setup a network card. I change 'static ip' to 'dynamic ip' and the update downloads work. FYI, the system freeze in opensuse was fixed in an update install.

    When I boot to opensuse, the internet doesn't work. I've tried using Yast - Network Setup, no effect. This is the this link to my motherboard. I have a net pci card that can use to test internet (not plugged in).

    http://www.msi.com/product/motherboa...#hero-overview

    Need help

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,319
    Blog Entries
    15

    Default Re: Internet not working, KDE, motherboard ethernet

    Hi
    Run the following command and post back the output;
    Code:
    /sbin/lspci -nnk | grep -A3 Ethernet
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Internet not working, KDE, motherboard ethernet

    06:00.0 Ethernet controller [0200]: Qualcomm Atheros Killer E220x Gigabit Ethernet Controller [1969:e091] (rev 13)
    Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:7693]
    Kernel driver in use: alx
    Kernel modules: alx

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,319
    Blog Entries
    15

    Default Re: Internet not working, KDE, motherboard ethernet

    Hi
    OK, so it's not driver related.

    So are you using network manager or wicked?

    If you check the entries in /etc/resolv.conf they are showing DNS entries?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5

    Default Re: Internet not working, KDE, motherboard ethernet

    Quote Originally Posted by lord_valarian View Post
    06:00.0 Ethernet controller [0200]: Qualcomm Atheros Killer E220x Gigabit Ethernet Controller [1969:e091] (rev 13)
    Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:7693]
    Kernel driver in use: alx
    Kernel modules: alx
    There is a bug in newer kernel for the qualcomm atheros gigabit ethernet controller.
    Google around and you will see what I mean.
    People who do not break things first will never learn to create anything

  6. #6

    Default Re: Internet not working, KDE, motherboard ethernet

    Quote Originally Posted by malcolmlewis View Post
    Hi
    OK, so it's not driver related.

    So are you using network manager or wicked?

    If you check the entries in /etc/resolv.conf they are showing DNS entries?

    /etc/resolv.conf

    ### /etc/resolv.conf file autogenerated by netconfig!
    #
    # Before you change this file manually, consider to define the
    # static DNS configuration using the following variables in the
    # /etc/sysconfig/network/config file:
    # NETCONFIG_DNS_STATIC_SEARCHLIST
    # NETCONFIG_DNS_STATIC_SERVERS
    # NETCONFIG_DNS_FORWARDER
    # or disable DNS configuration updates via netconfig by setting:
    # NETCONFIG_DNS_POLICY=''
    #
    # See also the netconfig(8) manual page and other documentation.
    #
    # Note: Manual change of this file disables netconfig too, but
    # may get lost when this file contains comments or empty lines
    # only, the netconfig settings are same with settings in this
    # file and in case of a "netconfig update -f" call.
    #
    ### Please remove (at least) this line when you modify the file!
    nameserver 2001:558:feed::1
    nameserver 2001:558:feed::2
    nameserver 75.75.75.75



    /etc/resolv.conf.netconfig

    ### /etc/resolv.conf file autogenerated by netconfig!
    #
    # Before you change this file manually, consider to define the
    # static DNS configuration using the following variables in the
    # /etc/sysconfig/network/config file:
    # NETCONFIG_DNS_STATIC_SEARCHLIST
    # NETCONFIG_DNS_STATIC_SERVERS
    # NETCONFIG_DNS_FORWARDER
    # or disable DNS configuration updates via netconfig by setting:
    # NETCONFIG_DNS_POLICY=''
    #
    # See also the netconfig(8) manual page and other documentation.
    #
    # Note: Manual change of this file disables netconfig too, but
    # may get lost when this file contains comments or empty lines
    # only, the netconfig settings are same with settings in this
    # file and in case of a "netconfig update -f" call.
    #
    ### Please remove (at least) this line when you modify the file!
    search gateway.2wire.net
    nameserver 192.168.1.254



    There is a bug in newer kernel for the qualcomm atheros gigabit ethernet controller.
    Google around and you will see what I mean.
    I'm looking. What do I do to fix it?

  7. #7

    Default Re: Internet not working, KDE, motherboard ethernet

    Code:
    So are you using network manager or wicked?
    It's opensuse leap 42.1 standard. So, network manager?

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,319
    Blog Entries
    15

    Default Re: Internet not working, KDE, motherboard ethernet

    Quote Originally Posted by lord_valarian View Post
    Code:
    So are you using network manager or wicked?
    It's opensuse leap 42.1 standard. So, network manager?
    Hi
    So I see it's using ipv6 and ipv4, are you using both? If only ipv4, then disable ipv6 in YaST Network Settings General page (and maybe even in your router).
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  9. #9

    Default Re: Internet not working, KDE, motherboard ethernet

    Quote Originally Posted by lord_valarian View Post

    I'm looking. What do I do to fix it?
    Here is a link I found:
    https://bugzilla.kernel.org/show_bug.cgi?id=70761
    http://cwang.me/blog/2015/05/30/how-...rnet-in-linux/

    People who do not break things first will never learn to create anything

  10. #10

    Default Re: Internet not working, KDE, motherboard ethernet

    There is a bug in newer kernel for the qualcomm atheros gigabit ethernet controller.
    Didn't work.

    I plugged in my net pc card and it didn't work either.

    So are you using network manager or wicked?
    I found the networking settings for that. I changed from 'wicked networking' to 'network manager'. I plugged in the cable into my network card and it worked. So, I unplugged from my network card into my motherboard internet and it worked!

    It seems 'wicked networking' has a bug in it. Now, I have an system update error.

    Thanks to all for the help.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •