Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: KDE 4 desktop

  1. #1

    Default KDE 4 desktop

    I would like to set up KDE 4 desktop in openSUSE Leap 42.1.
    So far I can get some almost satisfactory result by modifying installation with KDE Plasma 5 (with KDE Frameworks 5):
    • remove: plasma5-* plasma-nm5*
    • install: kdebase4-session kdebase4-workspace kdebase4-runtime kdelibs4support kscreen kate4-parts konsole4-part kdm
    • configure to use KDM login manager instead of SDDM
    • install plasma-nm (and plasma-nm-*) from http://download.opensuse.org/reposit...SUSE_Leap_42.1 repository (it seems better not to keep this repo enabled to avoid unexpected behavior and mixture of package, but it is useful to manually grab some packages, that are not in default repositories).


    If you do this in KDE Plasma 5, make sure to remove its cache before logout, otherwise you will see purely white screen instead of KDE 4. E.g.:
    rm -f -r /tmp/*
    rm -f -r /var/tmp/*
    reboot
    Known issues:
    • if I use dolphin as file manager, network services not work in it, terminal view in dolphin has not monospace font;
    • if I use dolphin4 as file manager, baloo search engine works with baloo-*, not with baloo5-*.


    Some video about this:

  2. #2

    Default Re: KDE 4 desktop

    Some notes:
    Quote Originally Posted by embar- View Post
    remove: plasma5-* plasma-nm5*
    You don't have to remove them, if you switch all packages to my repo (which you are using anyway), you can keep both Plasma5 and KDE4.
    But you'd

    install: kdebase4-session kdebase4-workspace kdebase4-runtime kdelibs4support kscreen kate4-parts konsole4-part kdm
    I'd recommend to install dolphin and kate from my repo as well, that are the KDE4 versions. If you want to use the KF5 versions too, they are called kate5 and konsole5 in my repo and don't replace the KDE4 versions.
    kdebase4-runtime should be installed by default anyway, kdelibs4support is not necessary, it is a KDE Frameworks5 library.

    configure to use KDM login manager instead of SDDM
    You can use whatever DM you want.
    The only thing in KDE4 that requires KDM is the "Restart" menu that let's you select a boot menu entry to boot. Otherwise it doesn't matter at all.

    install plasma-nm (and plasma-nm-*) from http://download.opensuse.org/reposit...SUSE_Leap_42.1 repository (it seems better not to keep this repo enabled to avoid unexpected behavior and mixture of package, but it is useful to manually grab some packages, that are not in default repositories).
    It should be safe to keep this repo, in particular for KDE4. I added those that are no longer part of the distribution because they got replaced with their KF5 version or failed to build.

    If you want to use the KF5/Plasma5 part as well, you should also add KDE:Frameworks5 though.

    In this case, I'd actually recommend to do a full switch to my repo, you can then switch between KDE4 ("KDE Plasma Workspace") and Plasma5 at the login screen.

    If you do this in KDE Plasma 5, make sure to remove its cache before logout, otherwise you will see purely white screen instead of KDE 4.
    ???
    Plasma5 uses a completely different cache as KDE4...
    And I'm using both KDE4 and Plasma5 here interchangeably, never had such a problem.

    if I use dolphin as file manager, network services not work in it, terminal view in dolphin has not monospace font;
    You are using the KF5 based Konsole here. KF5 has Oxygen Mono as default monospace font, if that isn't installed you get some random font (likely not monospaced).
    So to fix this, either install kde-oxygen-fonts, or explicitly configure a different font, either in Konsole or in systemsettings5.

    if I use dolphin4 as file manager, baloo search engine works with baloo-*, not with baloo5-*.
    Yes.
    They are not compatible.
    But with my repo you can have both.

  3. #3

    Default Re: KDE 4 desktop

    Thanks, wolfi323, for your repo and explanations!

  4. #4

    Default Re: KDE 4 desktop

    Maybe someone using KDE 4 in oS Leap 42.1 knows, how to use KDE-like file-open dialogs (e.g. in KF5 based Kate) and not primitive Qt-like dialog?

  5. #5

    Default Re: KDE 4 desktop

    Quote Originally Posted by embar- View Post
    Maybe someone using KDE 4 in oS Leap 42.1 knows, how to use KDE-like file-open dialogs (e.g. in KF5 based Kate) and not primitive Qt-like dialog?
    KF5 applications should use the KDE file dialog by default when running inside KDE (4 or 5), and actually *all* Qt5 applications too.

    For this to work, you need to have libKF5Style5 installed (KF5's Qt platform plugin), and the environment variable $XDG_CURRENT_DESKTOP has to be set to "KDE", but that should be done by the login manager when you login to KDE4.

    One thing though: if you also have libqt5-qtct installed, this will override the KDE plugin. So this might be the reason that the standard Qt dialog is used.

  6. #6

    Default Re: KDE 4 desktop

    I checked: libqt5-qtct not installed; libKF5Style5 installed; Firefox, LibreOffice use KDE-like file-open dialogs; but KF5-based applications don't.

  7. #7

    Default Re: KDE 4 desktop

    ...and even inside Kate opened terminal shows
    > echo $XDG_CURRENT_DESKTOP
    KDE

  8. #8

    Default Re: KDE 4 desktop

    There is prepared openSUSE Leap 42.1 based appliance with KDE 4 desktop in SUSE Studio:
    https://susestudio.com/a/CttYWz/liet...ance-downloads

  9. #9
    Ferenginar NNTP User

    Default Re: KDE 4 desktop

    On Wed, 23 Dec 2015 12:06:01 GMT wolfi323 wrote:

    > One thing though: if you also have libqt5-qtct installed, this will
    > override the KDE plugin. So this might be the reason that the standard
    > Qt dialog is used.


    And how do i set the default style, fonts and icon theme for qt5 apps
    if qt5ct is not installed? Is this managed from libKF5Style5 too inside
    of kde4?

  10. #10

    Default Re: KDE 4 desktop

    Quote Originally Posted by embar- View Post
    I checked: libqt5-qtct not installed; libKF5Style5 installed; Firefox, LibreOffice use KDE-like file-open dialogs; but KF5-based applications don't.
    Sorry, it's frameworkintegration-plugin actually (I always confuse the two). You probably do not have that installed, it is only required by plasma5-desktop.

    If I remove that here, KF5 applications do indeed use the standard Qt5 file dialog.

    Quote Originally Posted by Ferenginar View Post
    And how do i set the default style, fonts and icon theme for qt5 apps
    if qt5ct is not installed? Is this managed from libKF5Style5 too inside
    of kde4?
    Yes.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •