Results 1 to 4 of 4

Thread: Leap Software Managment Crashes [kde]

  1. #1

    Default Leap Software Managment Crashes [kde]

    Hello, thanks for reading

    Leap (fresh install with KDE) software management crashes.

    what I have done: installed per
    http://opensuse-guide.org/codecs.php

    Noticed video not playing correctly in vlc (either small screen or no video) so wanted to check repositories and software, it crashed so I opened in konsole:

    linux-bq89:/home/KIlbert # yast2
    Run command: /sbin/yast2 sw_single &
    YaST got signal 11 at file /usr/share/YaST2/modules/PackagesUI.rb:312
    sender PID: -1436734043
    /sbin/yast2: line 440: 17311 Segmentation fault $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS
    Run command: /sbin/yast2 repositories &
    Run command: /sbin/yast2 sw_single &
    YaST got signal 11 at file /usr/share/YaST2/modules/PackagesUI.rb:312
    sender PID: -1436734043
    /sbin/yast2: line 440: 23471 Segmentation fault $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS


    KIlbert@linux-bq89:~> zypper lr -d
    # | Alias | Name | Enabled | GPG Check | Refresh | Priority | Type | URI | Service
    ---+-------------------------------------+-----------------------------------------+---------+-----------+---------+----------+--------+-------------------------------------------------------------------------------------+--------
    1 | PlexRepo | PlexRepo | No | ---- | No | 99 | NONE | http://plex.r.worldssl.net/PlexMedia...elease/x86_64/ |
    2 | ftp.gwdg.de-suse | Packman Repository | Yes | (r ) Yes | Yes | 99 | rpm-md | http://ftp.gwdg.de/pub/linux/packman...USE_Leap_42.1/ |
    3 | http-download.opensuse.org-49565f5d | KDE:Extra | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...USE_Leap_42.1/ |
    4 | openSUSE-42.1-0 | openSUSE-42.1-0 | No | ---- | No | 99 | yast2 | cd:///?devices=/dev/disk/by-id/usb-TSSTcorp_CDDVDW_SE-S084C_SATASLIM0000000fa3d-0:0 |
    5 | opensuse-guide.org-repo | Libdvdcss Repository | Yes | (r ) Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_42.1/ |
    6 | repo-debug | openSUSE-Leap-42.1-Debug | No | ---- | Yes | 99 | NONE | http://download.opensuse.org/debug/d...42.1/repo/oss/ |
    7 | repo-debug-non-oss | openSUSE-Leap-42.1-Debug-Non-Oss | No | ---- | Yes | 99 | NONE | http://download.opensuse.org/debug/d.../repo/non-oss/ |
    8 | repo-debug-update | openSUSE-Leap-42.1-Update-Debug | No | ---- | Yes | 99 | NONE | http://download.opensuse.org/debug/update/leap/42.1/oss |
    9 | repo-debug-update-non-oss | openSUSE-Leap-42.1-Update-Debug-Non-Oss | No | ---- | Yes | 99 | NONE | http://download.opensuse.org/debug/u.../42.1/non-oss/ |
    10 | repo-non-oss | openSUSE-Leap-42.1-Non-Oss | No | ---- | Yes | 99 | NONE | http://download.opensuse.org/distrib.../repo/non-oss/ |
    11 | repo-oss | openSUSE-Leap-42.1-Oss | Yes | (r ) Yes | Yes | 99 | yast2 | http://download.opensuse.org/distrib...42.1/repo/oss/ |
    12 | repo-source | openSUSE-Leap-42.1-Source | No | ---- | Yes | 99 | NONE | http://download.opensuse.org/source/...42.1/repo/oss/ |
    13 | repo-update | openSUSE-Leap-42.1-Update | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/leap/42.1/oss/ |
    14 | repo-update-non-oss | openSUSE-Leap-42.1-Update-Non-Oss | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/leap/42.1/non-oss/ |

    Not sure what to do to make it work
    thanks for the help
    John Kilbert

  2. #2

    Default Re: Leap Software Managment Crashes [kde]

    Quote Originally Posted by kilbert View Post
    Noticed video not playing correctly in vlc (either small screen or no video)
    That's a bug in Qt 5.5.
    An update to fix this is on the way for Leap 42.1.

    As a workaround you could disable "Integrate video in interface" or enable "Use custom skin" in VLC's settings until the update arrives.

    so wanted to check repositories and software, it crashed so I opened in konsole:

    linux-bq89:/home/KIlbert # yast2
    Run command: /sbin/yast2 sw_single &
    YaST got signal 11 at file /usr/share/YaST2/modules/PackagesUI.rb:312
    sender PID: -1436734043
    /sbin/yast2: line 440: 17311 Segmentation fault $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS
    Run command: /sbin/yast2 repositories &
    Run command: /sbin/yast2 sw_single &
    YaST got signal 11 at file /usr/share/YaST2/modules/PackagesUI.rb:312
    sender PID: -1436734043
    /sbin/yast2: line 440: 23471 Segmentation fault $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS
    Doesn't tell much unfortunately.

    Can you please post the last lines of /var/log/YaST2/y2log?

    Also, do you have multiple monitors? There are known problems in Qt5 that can make YaST crash when running on the secondary display.

    Does the text mode interface work? I.e. run "yast" instead of "yast2".

  3. #3

    Default Re: Leap Software Managment Crashes [kde][solved]

    Thanks For the help, this also helped another issue with PLEX Media server not working properly on the secondary display.


    Quote Originally Posted by wolfi323 View Post
    That's a bug in Qt 5.5.
    An update to fix this is on the way for Leap 42.1.

    As a workaround you could disable "Integrate video in interface" or enable "Use custom skin" in VLC's settings until the update arrives.


    That worked.



    Doesn't tell much unfortunately.

    Can you please post the last lines of /var/log/YaST2/y2log?

    Also, do you have multiple monitors? There are known problems in Qt5 that can make YaST crash when running on the secondary display.


    Yes, 2 monitors. Works fine on display 1.

    Does the text mode interface work? I.e. run "yast" instead of "yast2".

    Yes. I will learn that in the interim.

  4. #4

    Default Re: Leap Software Managment Crashes [kde]


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •