Results 1 to 8 of 8

Thread: yast apps not working

  1. #1
    Join Date
    Jul 2011
    Location
    Poland
    Posts
    107

    Default yast apps not working

    Hi!

    I can't open any Yast application. No matter if I try from terminal or in window mode.
    I can see this messages:

    Code:
    linux-pdu7:/home/kamil # yast -i
    DEPRECATED. Use sw_single directly: /sbin/yast sw_single
    /usr/lib/YaST2/bin/y2base: symbol lookup error: ui/usr/lib64/YaST2/plugin/libpy2UI.so.2: undefined symbol: _Z16should_be_loggediRKSs
    linux-pdu7:/home/kamil # /sbin/yast sw_single
    /usr/lib/YaST2/bin/y2base: symbol lookup error: /usr/lib64/YaST2/plugin/libpy2UI.so.2: undefined symbol: _Z16should_be_loggediRKSs
    linux-pdu7:/home/kamil # 
    linux-pdu7:/home/kamil # 
    linux-pdu7:/home/kamil # yast2
    Run command: /sbin/yast2 sw_single &
    /usr/lib/YaST2/bin/y2base: symbol lookup error: /usr/lib64/YaST2/plugin/libpy2UI.so.2: undefined symbol: _Z16should_be_loggediRKSs
    Run command: /sbin/yast2 snapper &
    /usr/lib/YaST2/bin/y2base: symbol lookup error: /usr/lib64/YaST2/plugin/libpy2UI.so.2: undefined symbol: _Z16should_be_loggediRKSs
    Run command: /sbin/yast2 repositories &
    /usr/lib/YaST2/bin/y2base: symbol lookup error: /usr/lib64/YaST2/plugin/libpy2UI.so.2: undefined symbol: _Z16should_be_loggediRKSs
    linux-pdu7:/home/kamil #
    Zypper is working, so I can try to reinstall anything.
    This is fresh Thumbleweed installation. I discovered this because I see messages about Baloo File Indexing Daemon crash and I wanted to install KDE debuging package to report it.
    I tried zypper up and dup but didn't help.

  2. #2
    Join Date
    Jul 2011
    Location
    Poland
    Posts
    107

    Default Re: yast apps not working

    I have this repos:
    Code:
    linux-pdu7:/home/kamil # zypper lr
    # | Alias                               | Nazwa                       | Włączono | Sprawdzaj GPG | Odśwież
    --+-------------------------------------+-----------------------------+----------+---------------+--------
    1 | http-download.opensuse.org-4682016c | openSUSE:Leap:42.1          | Tak      | (r ) Tak      | Tak    
    2 | openSUSE-20151201-0                 | openSUSE-20151201-0         | Tak      | (r ) Tak      | Tak    
    3 | repo-debug                          | openSUSE-Tumbleweed-Debug   | Nie      | ----          | Tak    
    4 | repo-non-oss                        | openSUSE-Tumbleweed-Non-Oss | Tak      | (r ) Tak      | Tak    
    5 | repo-source                         | openSUSE-Tumbleweed-Source  | Nie      | ----          | Tak    
    6 | repo-update                         | openSUSE-Tumbleweed-Update  | Tak      | (r ) Tak      | Tak
    Repo 42.1 is because I installed dropbox. Should I remove it?

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,982

    Default Re: yast apps not working

    You should not mix repos from different openSUSE version.
    Henk van Velden

  4. #4
    Join Date
    Jul 2011
    Location
    Poland
    Posts
    107

    Default Re: yast apps not working

    OK, repo removed -> zypper dup -> working! :-)
    Dropbox is still installed... ???

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,982

    Default Re: yast apps not working

    Quote Originally Posted by rysic View Post
    OK, repo removed -> zypper dup -> working! :-)
    Dropbox is still installed... ???
    When you did not de-install it, it will still be there. Either a version from the Tumbleweed repos you still have, or, when there is no version on those Tumbleweed versions, it is still the version from Leap 42.1 In the latter case it is orphanised and will be shown in red in your YaST > Software > Software Management listings.

    If it functions or not, I do not know. Just try it.

    But it may be better to search for it on https://software.opensuse.org/search
    There might be a Tumbleweed version available.
    Henk van Velden

  6. #6
    Join Date
    Jul 2011
    Location
    Poland
    Posts
    107

    Default Re: yast apps not working

    Quote Originally Posted by hcvv View Post
    You should not mix repos from different openSUSE version.
    Yes, I know but when I'm trying to install Dropbox from Thumbleweed 1Click (https://software.opensuse.org/package/dropbox)
    then I got error that repo can not be determined:


  7. #7
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,982

    Default Re: yast apps not working

    Quote Originally Posted by rysic View Post
    Yes, I know but when I'm trying to install Dropbox from Thumbleweed 1Click (https://software.opensuse.org/package/dropbox)
    then I got error that repo can not be determined:

    Maybe then start a new thread about that problem. With a title that draws the attention of people that might know more.

    Better then installing from a non Tumbleweed repo and hoping your system will not break down
    Henk van Velden

  8. #8
    Join Date
    Jul 2011
    Location
    Poland
    Posts
    107

    Default Re: yast apps not working

    Quote Originally Posted by hcvv View Post
    Maybe then start a new thread about that problem. With a title that draws the attention of people that might know more.
    Good idea! :-) I will!
    Thanks for help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •