Results 1 to 3 of 3

Thread: How to disable Plasma 5 animations.

  1. #1
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,254

    Default How to disable Plasma 5 animations.

    Now, I know you won't want to do this... because you all just love animations.

    ... but I'm a grumpy old <expletive deleted> and animations are the last thing I want to see.

    Lately, it seems, there are more animations creeping into Plasma 5 that can't be controlled by either the 'Desktop Effects' or 'Window Decoration' settings.

    For the moment adding this:
    Code:
    [Units]
    longDuration=0
    to "~/.config/plasmarc" will 'disable' the animations, well, actually it just makes them 'instant'... but that's good enough I suppose...



    Argh!

    Errors
    The following errors occurred with your submission
    You must select a thread prefix.

    Bother! Prefixed with "Tumbleweed" as that's what I'm using... but it could equally have been, 13.2, or Leap, or...
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191011) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,841
    Blog Entries
    14

    Default Re: How to disable Plasma 5 animations.

    I think you're missing something. There are no animations creeping up in Plasma5. If you turn off compositing, there will be no animations.
    But .... you may have KDE4 applications that might trigger animations. To control those, you need systemsettings, next to systemsettings5.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,254

    Default Re: How to disable Plasma 5 animations.

    Quote Originally Posted by Knurpht View Post
    I think you're missing something. There are no animations creeping up in Plasma5. If you turn off compositing, there will be no animations.
    Erm... No... these animations are independent of the compositor

    Examples: (First suspend compositing using shift alt F12)

    "System Tray Settings" - select one of the options in the left panel, 'Keyboard Shortcuts' for example; when the right hand panel changes it now has a "slide" animation effect.

    "Calendar" - Navigate to a different month or year, when the calendar display changes it uses a 'fade/zoom' type animation.

    Taking the calendar as an example, this is a section of the code that does the animation.

    Code:
            delegate: StackViewDelegate {
                pushTransition: StackViewTransition {
                    NumberAnimation {
                        target: exitItem
                        duration: units.longDuration
                        property: "opacity"
                        from: 1
                        to: 0
                    }
                    NumberAnimation {
                        target: enterItem
                        duration: units.longDuration
                        property: "opacity"
                        from: 0
                        to: 1
                    }
                    NumberAnimation {
                        target: enterItem
                        duration: units.longDuration
                        property: "transformScale"
                        from: 1.5
                        to: 1
                    }
                }
                popTransition: StackViewTransition {
                    NumberAnimation {
                        target: exitItem
                        duration: units.longDuration
                        property: "opacity"
                        from: 1
                        to: 0
                    }
                    NumberAnimation {
                        target: exitItem
                        duration: units.longDuration
                        property: "transformScale"
                        // so no matter how much you scaled, it would still fly towards you
                        to: exitItem.transformScale * 1.5
                    }
                    NumberAnimation {
                        target: enterItem
                        duration: units.longDuration
                        property: "opacity"
                        from: 0
                        to: 1
                    }
                }
            }
    I really think there should be a global setting for animation on/off, or it should follow the kwin animation setting. At the moment it seems there is no easy way to disable it.
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191011) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •