Results 1 to 9 of 9

Thread: Cannot start plasma after update

  1. #1
    Join Date
    May 2015
    Location
    Italy
    Posts
    377

    Unhappy Cannot start plasma after update

    Hi all,
    yesterday I worked on my desktop PC without problems. I did a zypper dup just before going to bed, and it updated a lot of packages (a bit more than 300 IIRC).

    Today I boot my desktop PC and I am presented only with two choices: "IceWM" and "IceWM Session". No way to start my KDE plasma dekstop.

    This morning I've been working on my laptop without problems. Just before going to lunch, I did a zypper dup on the laptop too (I didn't yet know that the desktop was not working anymore).

    If I now try to boot my laptop, I cannot access my KDE plasma desktop. Though I still have the choice in the login screen, whatever I choose (besides "IceWM" or "IceWM Session") just puts me back to the login screen.

    I cannot find obvious errors in the system log.

    I am quite surprised seeing that nobody has posted anything here, since I have both my PCs running OpenSUSE Tumbleweed showing the same symptoms.

    I have just lost an hour trying to figure out what's happening here... could you suggest me some steps to properly debug my situation?
    Thank you in advance.

    Cris

  2. #2
    Join Date
    May 2015
    Location
    Italy
    Posts
    377

    Default Re: Cannot start plasma after update

    Update - If I enter this at the command line, KDE5 starts up correctly:

    /opt/kf5/bin/startkde

    But I still cannot use it from the login screen.
    Also, when I try to run some command from the cli (e.g. kwin_x11) I get this error:
    Code:
    kwin_x11: error while loading shared libraries: libKF5Activities.so.5: cannot open shared object file: No such file or directory
    But that library does exists. It is in /opt/kf5/lib64.
    So I am starting to think something corrupted my environment variables, on both my PCs. Weird.

    Now I'm going to try to understand how to solve the problem.

    Cris

  3. #3

    Default Re: Cannot start plasma after update

    Quote Originally Posted by Cris70 View Post
    Update - If I enter this at the command line, KDE5 starts up correctly:

    /opt/kf5/bin/startkde
    You are using *my* packages. Is this on purpose?
    Do a full switch to my repo then.

    But I still cannot use it from the login screen.
    Also, when I try to run some command from the cli (e.g. kwin_x11) I get this error:
    Code:
    kwin_x11: error while loading shared libraries: libKF5Activities.so.5: cannot open shared object file: No such file or directory
    But that library does exists. It is in /opt/kf5/lib64.
    /opt/kf5/lib64 is normally not searched for libraries. My packages should find them there too though, so maybe you have some mixture.
    Try running /opt/kf5/bin/startkf5 instead, that should add /opt/kf5/lib64 to the linker search path.

  4. #4
    Join Date
    May 2015
    Location
    Italy
    Posts
    377

    Default Re: Cannot start plasma after update

    Quote Originally Posted by wolfi323 View Post
    You are using *my* packages. Is this on purpose?
    Do a full switch to my repo then.
    Yes, this is on purpose.
    I thought I was already fully on your repo.
    How do I check? And how do I do a full switch, if it's not already so?

    Quote Originally Posted by wolfi323 View Post
    /opt/kf5/lib64 is normally not searched for libraries. My packages should find them there too though, so maybe you have some mixture.
    Try running /opt/kf5/bin/startkf5 instead, that should add /opt/kf5/lib64 to the linker search path.
    mmm, I do not have startkf5 there. I only have "startkde" and "startplasmacompositor".

    Cris

  5. #5

    Default Re: Cannot start plasma after update

    Quote Originally Posted by Cris70 View Post
    Yes, this is on purpose.
    I thought I was already fully on your repo.
    How do I check?
    Just do a full switch and you'll see...

    And how do I do a full switch, if it's not already so?
    https://en.opensuse.org/SDB:Vendor_c..._Vendor_change

    If you need help, please post your repo list:
    Code:
    zypper lr -d
    Btw, it might be a good idea to give my repo a higher priority (lower priority number) than the standard ones...

    mmm, I do not have startkf5 there. I only have "startkde" and "startplasmacompositor".
    Then you don't have my plasma5-session package installed, which explains why my Plasma5 packages don't work.
    startkf5 sets up the environment to look for stuff in /opt/kf5/.

  6. #6
    Join Date
    May 2015
    Location
    Italy
    Posts
    377

    Default Re: Cannot start plasma after update

    Wolfi, unfortunately the screenshot on the page with instructions to do a full switch are quite dated, I haven't been able to find the "Switch system packages" button that's shown there.

    Fortunately there was also a cli command: "zypper dup --from <repository>". I did this... not much of a change however, only a few packages.
    Oh, I almost forgot to say: I already had your repo with higher priority (lower value).

    I was however surprised by seeing plasma5-session actually being removed. Probably it was the version in the main repo, not yours.
    But now I'm a strange position: I cannot install your plasma5-session because of a missing dependency.
    Code:
    Problem: nothing provides libkscreen2-plugin >= 5.5.0 needed by plasma5-session-5.5.0-135.1.noarch
     Solution 1: do not install plasma5-session-5.5.0-135.1.noarch
     Solution 2: break plasma5-session-5.5.0-135.1.noarch by ignoring some of its dependencies
    Here is the situation of the libkscreen2-plugin package:
    Code:
    cris@PolariSuse:~> zypper se -s --provides libkscreen2-plugin
    Loading repository data...
    Reading installed packages...
    
    S | Name                               | Type    | Version   | Arch   | Repository               
    --+------------------------------------+---------+-----------+--------+--------------------------
    i | libkscreen2-plugin                 | package | 5.4.3-1.1 | x86_64 | Main Repository (OSS)    
    v | libkscreen2-plugin                 | package | 5.4.3-1.1 | i586   | Main Repository (OSS)    
      | libkscreen2-plugin-32bit           | package | 5.4.3-1.1 | x86_64 | Main Repository (OSS)    
      | libkscreen2-plugin-debuginfo       | package | 5.4.3-1.1 | x86_64 | openSUSE-Tumbleweed-Debug
      | libkscreen2-plugin-debuginfo       | package | 5.4.3-1.1 | i586   | openSUSE-Tumbleweed-Debug
      | libkscreen2-plugin-debuginfo-32bit | package | 5.4.3-1.1 | x86_64 | openSUSE-Tumbleweed-Debug
    And here is my repo list:
    Code:
    #  | Alias                            | Name                       | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                                       | Service
    ---+----------------------------------+----------------------------+---------+-----------+---------+----------+--------+-----------------------------------------------------------------------------------------------------------+--------
     1 | File_Commander                   | File Commander             | Yes     | ( p) Yes  | Yes     |   99     | rpm-md | http://silk.apana.org.au/rpm                                                                              |        
     2 | Gambas3                          | Gambas3                    | Yes     | (r ) Yes  | Yes     |  100     | rpm-md | http://download.opensuse.org/repositories/home:/munix9/openSUSE_Tumbleweed/                               |        
     3 | Insync                           | Insync                     | Yes     | ( p) Yes  | Yes     |   99     | rpm-md | http://yum.insynchq.com/fedora/21/                                                                        |        
     4 | Wolfie-TW-KDE-FW5                | Wolfie-TW-KDE-FW5          | Yes     | (r ) Yes  | Yes     |   98     | rpm-md | http://download.opensuse.org/repositories/home:/wolfi323:/branches:/KDE:/Frameworks5/openSUSE_Tumbleweed/ |        
     5 | download.opensuse.org-non-oss    | Main Repository (NON-OSS)  | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/tumbleweed/repo/non-oss/                                                     |        
     6 | download.opensuse.org-oss        | Main Repository (OSS)      | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/tumbleweed/repo/oss/                                                         |        
     7 | download.opensuse.org-tumbleweed | Main Update Repository     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/tumbleweed/                                                           |        
     8 | google-earth                     | google-earth               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://dl.google.com/linux/earth/rpm/stable/x86_64                                                        |        
     9 | google-musicmanager              | google-musicmanager        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://dl.google.com/linux/musicmanager/rpm/stable/x86_64                                                 |        
    10 | google-talkplugin                | google-talkplugin          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://dl.google.com/linux/talkplugin/rpm/stable/x86_64                                                   |        
    11 | http-ftp.gwdg.de-b92af08f        | Packman Repository         | Yes     | (r ) Yes  | Yes     |   98     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_Tumbleweed/                                            |        
    12 | http-opensuse-guide.org-bb959197 | libdvdcss repository       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Tumbleweed/                                                       |        
    13 | openSUSE-20151118-0              | openSUSE-20151118-0        | No      | ----      | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-PHILIPS_DVDR1660P1_DL100614069754                                      |        
    14 | packman-essentials               | packman-essentials         | No      | ----      | No      |   98     | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/Essentials/                            |        
    15 | repo-debug                       | openSUSE-Tumbleweed-Debug  | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/debug/tumbleweed/repo/oss/                                                   |        
    16 | repo-source                      | openSUSE-Tumbleweed-Source | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/source/tumbleweed/repo/oss/                                                  |
    How do I solve this problem?
    Last edited by Cris70; 17-Dec-2015 at 14:55. Reason: add more infos

  7. #7

    Default Re: Cannot start plasma after update

    Quote Originally Posted by Cris70 View Post
    Wolfi, unfortunately the screenshot on the page with instructions to do a full switch are quite dated,
    Maybe, but YaST hasn't changed at all regarding this.

    I haven't been able to find the "Switch system packages" button that's shown there.
    Click on the "View" button, choose "Repositories", select the corresponding repo on the left list, then click on "Switch system packages..." above the package list on the right, like you see on that screenshot.


    I was however surprised by seeing plasma5-session actually being removed. Probably it was the version in the main repo, not yours.
    There is only one, or rather the packages have the same name in both repos. If it is going to be removed, you won't have it installed at all afterwards.

    But now I'm a strange position: I cannot install your plasma5-session because of a missing dependency.
    Code:
    Problem: nothing provides libkscreen2-plugin >= 5.5.0 needed by plasma5-session-5.5.0-135.1.noarch
     Solution 1: do not install plasma5-session-5.5.0-135.1.noarch
     Solution 2: break plasma5-session-5.5.0-135.1.noarch by ignoring some of its dependencies
    Ok, apparently version 5.5.0 switched through by mistake to my repo for Tumbleweed.
    Sorry, haven't noticed as I don't use it myself (nor Tumbleweed).

    I'll fix it.

    But in this case you could also just choose to ignore the dependency. plasma5-session doesn't really require a specific version, that dependency is just there to make sure all packages are the same version. Although, KInfocenter takes the version from plasma5-session, so it would incorrectly display that you have Plasma 5.5.0 installed... That's just cosmetical though.
    Last edited by wolfi323; 18-Dec-2015 at 04:20.

  8. #8

    Default Re: Cannot start plasma after update

    Ok, plasma5-session is reverted to 5.4.3 now in my repo for Tumbleweed, so try to install it again.

    Apparently I published the package for Tumbleweed as well by mistake when I fixed the (new in 5.5) wayland session file a few days ago...
    Sorry.

  9. #9
    Join Date
    May 2015
    Location
    Italy
    Posts
    377

    Default Re: Cannot start plasma after update

    Quote Originally Posted by wolfi323 View Post
    Ok, plasma5-session is reverted to 5.4.3 now in my repo for Tumbleweed, so try to install it again.

    Apparently I published the package for Tumbleweed as well by mistake when I fixed the (new in 5.5) wayland session file a few days ago...
    Sorry.
    No problem Wolfie. Rather I have to thank you, because by following your instructions I got my plasma5 desktop back!

    Cris

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •