Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 43

Thread: KDE - Amarok not playing ogg files

  1. #21

    Default Re: KDE - Amarok not playing ogg files

    Opensuse leap 42.1 - KDE


    Try installing ffmpeg on your system.
    Installed.

    Code:
    sudo zypper dup --from packman
    Did that, installed many files.

    Don't use Plasma's search bar, use the search bar in systemsettings5 ("Configure Desktop").
    The module is called "Multimedia" btw (searching for "phonon" does find it though), and is to be found in the Hardware section.
    settings->configure desktop->audio volume. Searching for "phonon" gets me here.

    Phonon is there, but no settings. It has set audio device and speaker testing. Both audio devices have no sound with speaker testing.

  2. #22
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: KDE - Amarok not playing ogg files

    try a new user

  3. #23

    Default Re: KDE - Amarok not playing ogg files

    Quote Originally Posted by lord_valarian View Post
    settings->configure desktop->audio volume. Searching for "phonon" gets me here.
    Hm?
    There is no "Audio Volume" in KDE's "Configure Desktop", it should be named "Audio and Video".

    If it is really called "Audio Volume" on your system, try explicitly running "systemsettings5" in Konsole or the Alt+F2 dialog to make sure you use the right thing.

    Phonon is there, but no settings. It has set audio device and speaker testing. Both audio devices have no sound with speaker testing.
    No settings? And what's that what you are seeing?

    Which two audio devices are there? Try moving the other one to the top and test the sound again.

    Do you have a "Hardware Settings" tab? If not, PulseAudio is not running, which might actually be the problem.

    Also, what backend are you using now? Switch to the "Backend" tab to see.

  4. #24

    Default Re: KDE - Amarok not playing ogg files

    Quote Originally Posted by wolfi323 View Post
    Hm?
    There is no "Audio Volume" in KDE's "Configure Desktop", it should be named "Audio and Video".

    If it is really called "Audio Volume" on your system, try explicitly running "systemsettings5" in Konsole or the Alt+F2 dialog to make sure you use the right thing.


    No settings? And what's that what you are seeing?

    Which two audio devices are there? Try moving the other one to the top and test the sound again.

    Do you have a "Hardware Settings" tab? If not, PulseAudio is not running, which might actually be the problem.

    Also, what backend are you using now? Switch to the "Backend" tab to see.

    System Settings-->Multimedia-->

    left pane:
    Audio Volume (highlighted)

    Audio and Video


    Tabs
    Applications : recording : output devices: input devices: configuration

    applications: vlc 78% speaker icon is red. Clicking that icon does nothing.

    Output Devices: SB Recon 3D -- port: analog output


    configuration: GF114 off
    SB Recon 3D: Analog Stereo output



    PAV running showing sound output.




    Backend:

    Phonon backend. Need to reboot.

  5. #25

    Default Re: KDE - Amarok not playing ogg files

    Quote Originally Posted by lord_valarian View Post
    System Settings-->Multimedia-->

    left pane:
    Audio Volume (highlighted)

    Audio and Video


    Tabs
    Applications : recording : output devices: input devices: configuration

    applications: vlc 78% speaker icon is red. Clicking that icon does nothing.
    So VLC is not giving sound either?
    Then it's obviously not an Amarok or KDE problem.

    Does the "Test sound" button in YaST work?

    Try to select a different output device in VLC itself (menu Audio->Audio Device), does that help?

    PAV running showing sound output.
    What's PAV?

    Backend:

    Phonon backend. Need to reboot.
    Yeah, but which backend is in use?
    I.e. which one is listed at the top of the list?

    And again: is there no "Hardware Devices" tab? Then PulseAudio doesn't seem to run properly which might explain your problem.

    Try to add your user to the group "audio" as a test. Maybe it's a permission issue.

  6. #26

    Default Re: KDE - Amarok not playing ogg files

    Quote Originally Posted by wolfi323 View Post
    So VLC is not giving sound either?
    Then it's obviously not an Amarok or KDE problem.
    I'v tried VLC and youtube(firefox), silence.


    Does the "Test sound" button in YaST work?
    Silence.

    Try to select a different output device in VLC itself (menu Audio->Audio Device), does that help?
    The sound card has another digital port, but I don't have digital speakers. I now have a monitor with internal speakers that mswin can change to (HDMI jacks).

    What's PAV?
    Pulse Audio Volume, someone asked me to install it. I have the speaker icons in the system tray. I can run it from the start menu.


    Yeah, but which backend is in use?
    I.e. which one is listed at the top of the list?
    From vlc, it said "phonon". I'm typing from public computers. I should have access to my computer for a few hours.

    And again: is there no "Hardware Devices" tab? Then PulseAudio doesn't seem to run properly which might explain your problem.
    It shows both analog and digital ports on my sound card hardware. Analog on: digital off


    Try to add your user to the group "audio" as a test. Maybe it's a permission issue.
    I will do that and post. I'v reading "Linux Music & Sound" by Dave Phillips. It says I can send a music file directly to the sound driver. Can send I send ogg files directly to the driver?

    Code:
    cat soundfile1.wav > dev/snd/

  7. #27

    Default Re: KDE - Amarok not playing ogg files

    Quote Originally Posted by lord_valarian View Post
    Pulse Audio Volume, someone asked me to install it. I have the speaker icons in the system tray. I can run it from the start menu.
    You mean pavucontrol?
    Well, kmix should offer the same.

    From vlc, it said "phonon".
    Not from vlc, what does KDE's systemsettings (Configure Desktop) say what Phonon backend is in use.

    But that shouldn't matter anyway, according to your other information, this is definitely not a KDE or Phonon problem.
    VLC doesn't even support/use Phonon (but Phonon can use VLC for playing multimedia files).

    I'v reading "Linux Music & Sound" by Dave Phillips. It says I can send a music file directly to the sound driver. Can send I send ogg files directly to the driver?

    Code:
    cat soundfile1.wav > dev/snd/
    No. The "sound driver" cannot decode ogg files, it can only play raw sound data.
    And that line is nonsense anyway, /dev/snd/ is a directory, not a device.

    You can try the command line player ogg123 though.

    I would rather suggest to disable "PulseAudio" as a test though (if adding your user to the video group doesn't help).
    YaST->Hardware->Sound->Other->PulseAudio Configuration (logout at least afterwards)

    But then, if YaST's "Test Sound" button doesn't give sound, it's a lower-level problem, i.e. either the hardware or the driver (or the driver's configuration).

  8. #28

    Default Re: KDE - Amarok not playing ogg files

    http://askubuntu.com/questions/560684/creative-sound-blaster-z-not-working-under-ubuntu-14-10

    http://forums.linuxmint.com/viewtopi...62539&p=836410

    https://bugzilla.kernel.org/show_bug.cgi?id=55541


    The bugzillza report and one webpage mention something about 32bit working with sound blaster, and 64bit not working. "local.rc". I'v tried yast-sound and installed pulse audio volume. I'm still reading over all the messages in two posts. I missed anything.

  9. #29

    Default Re: KDE - Amarok not playing ogg files

    monitor with hdmi cable to video card

    Doing update install, removed all the repos but main and update. update unconditionally or uninstalled then reinstalled:
    All pulse audio
    ffmpeg
    all alsa software
    all other volume controls.
    reinstall nvidia drivers(unable)
    all vlc


    Yast-sound --> set main sound to HDMI output (GF114 HDMI)

    configure desktop->Multimedia->audio volume->configuration tab-> configure audio volume->


    SB Recon 3D --> off

    GF114 HDMI -> HDMI 2

    Monitor HDMI port display: HDMI1 connected


    The monitor says I'm connected to HDMI1. The configure audio menu - sound is coming from HDMI2. I tried all the settings in CFG sound, until I got working. SOUND AT LAST!

    Looks like a bug in the menu, driver, or sound swapping HDMI1 and HDMI2 outputs. Sound through video card HDMI output, but not though sound card.


    Thanks to all for the help. I'll have to see if he sound card bug gets fixed later

  10. #30

    Default Re: KDE - Amarok not playing ogg files

    Quote Originally Posted by lord_valarian View Post
    The monitor says I'm connected to HDMI1. The configure audio menu - sound is coming from HDMI2.
    Don't mix up things here.

    The monitor only knows on which of its inputs something is connected. That's apparently the HDMI1 port *on your monitor*.

    The configure audio menu talks about the *output* of your computer system/graphics card where the sound should be sent to.

    It seems you connected the HDMI2 output port on your graphics card to the HDMI1 input port on your monitor.

    I don't see a bug here.
    Last edited by wolfi323; 11-Feb-2016 at 07:05.

Page 3 of 5 FirstFirst 12345 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •