Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Leap doesn't boot with Mageia and Win 8.1

  1. #1

    Default Leap doesn't boot with Mageia and Win 8.1

    Hi folks,

    I'm working with Mageia 5 and Windows 8.1 (in a legacy-bios).
    After installing opensuse leap, it doesn't appear in my Grub 2 bootloader and Grub2 only shows my Mageia and Windows,
    I reinstalled it over and over with some changes in my partitioning, but non of them resolved the issue.

    I saw some threads about having the same issue, but non of the workarounds solved my problem.
    I think the source of this issue would be my legacy bios.
    Any help greatly appreciated

    Thanks

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,479
    Blog Entries
    3

    Default Re: Leap doesn't boot with Mageia and Win 8.1

    During install, was there an error with installing booting?

    I do have Leap 42.1 installed on an older computer with Legacy BIOS. And I also have Mageia on that computer. It is all working fine. However, I used "ext4" for the root file system. I'm guessing that you used "btrfs" and you might have run into a "btrfs" limitation.

    On my system, Mageia is using legacy grub, rather than grub2. I'm guessing that you are really seeing the legacy grub menu from Mageia.

    Where did you install grub? And can you provide the output from
    Code:
    # fdisk -l
    I'm not a "btrfs" expert, so I might have this wrong. My understanding is that if your install uses a logical partition (partition 5 or higher), then grub2 needs to be installed in the MBR. However, on older computers the gap between the MBR and the first partition was usually 63 sectors, and that is too small for grub2 when using "btrfs".

    You should be able to add a boot entry for Leap to your Mageia boot menu ("/boot/grub/menu.lst" on your Mageia system). The other alternative is to reinstall, but use "ext4" (or "ext3" or "xfs") for the root file system.

    FIrst step is for you to provide that "fdisk" output, and let us know if you used "btrfs". If you can also tell us which partition(s) you used for Leap, we might be able to suggest what to add to "menu.lst" on Mageia.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Sep 2012
    Posts
    5,011

    Default Re: Leap doesn't boot with Mageia and Win 8.1

    Quote Originally Posted by lightblue View Post
    After installing opensuse leap, it doesn't appear in my Grub 2 bootloader and Grub2 only shows my Mageia and Windows,
    So you are apparently using bootloader from Mageia. In this case it knows nothing about newly installed openSUSE; you need to boot Mageia and reconfigure bootloader; but you really need to ask on Mageia forums how to do it. You may need to enable probing for other OSes there.

  4. #4

    Default Re: Leap doesn't boot with Mageia and Win 8.1

    Quote Originally Posted by nrickert View Post
    During install, was there an error with installing booting?

    I do have Leap 42.1 installed on an older computer with Legacy BIOS. And I also have Mageia on that computer. It is all working fine. However, I used "ext4" for the root file system. I'm guessing that you used "btrfs" and you might have run into a "btrfs" limitation.

    On my system, Mageia is using legacy grub, rather than grub2. I'm guessing that you are really seeing the legacy grub menu from Mageia.

    Where did you install grub? And can you provide the output from
    Code:
    # fdisk -l
    I'm not a "btrfs" expert, so I might have this wrong. My understanding is that if your install uses a logical partition (partition 5 or higher), then grub2 needs to be installed in the MBR. However, on older computers the gap between the MBR and the first partition was usually 63 sectors, and that is too small for grub2 when using "btrfs".

    You should be able to add a boot entry for Leap to your Mageia boot menu ("/boot/grub/menu.lst" on your Mageia system). The other alternative is to reinstall, but use "ext4" (or "ext3" or "xfs") for the root file system.

    FIrst step is for you to provide that "fdisk" output, and let us know if you used "btrfs". If you can also tell us which partition(s) you used for Leap, we might be able to suggest what to add to "menu.lst" on Mageia.
    Hi and thanks nrickert,

    As you said, I reinstalled Leap with ext4 (for root and home) and again it's not appearing in my Grub2 bootloader,
    at the moment the output of my fdisk -l is:

    Code:
    Device     Boot     Start        End    Sectors   Size Id Type
    /dev/sda1  *         2048     718847     716800   350M  7 HPFS/NTFS/exFAT
    /dev/sda2          718848  103119371  102400524  48.8G  7 HPFS/NTFS/exFAT
    /dev/sda3       103119513 1953520064 1850400552 882.3G  f W95 Ext'd (LBA)
    /dev/sda5       103119576 1953520064 1850400489 882.3G  7 HPFS/NTFS/exFAT
    
    Disk /dev/sdb: 111.8 GiB, 120034123776 bytes, 234441648 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: dos
    Disk identifier: 0x1c00112d
    
    Device     Boot     Start       End   Sectors  Size Id Type
    /dev/sdb1            2048 117221375 117219328 55.9G  7 HPFS/NTFS/exFAT
    /dev/sdb2  *    117223422 234436544 117213123 55.9G  f W95 Ext'd (LBA)
    /dev/sdb5       117223424 192493567  75270144 35.9G 83 Linux
    /dev/sdb6       192495616 215564287  23068672   11G 82 Linux swap / Solaris
    /dev/sdb7       215566336 234434559  18868224    9G 83 Linux
    
    Disk /dev/sdc: 465.8 GiB, 500107862016 bytes, 976773168 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: dos
    Disk identifier: 0x055b055a
    
    Device     Boot     Start       End   Sectors   Size Id Type
    /dev/sdc1       882563072 920252415  37689344    18G 83 Linux
    /dev/sdc2  *    920252416 976773119  56520704    27G 83 Linux
    /dev/sdc3           16069 882562904 882546836 420.9G  f W95 Ext'd (LBA)
    /dev/sdc5           16132 841581089 841564958 401.3G  7 HPFS/NTFS/exFAT
    /dev/sdc6       841584640 882561023  40976384  19.6G  7 HPFS/NTFS/exFAT
    The bold ones are my installed partitions for Leap.

  5. #5

    Default Re: Leap doesn't boot with Mageia and Win 8.1

    Quote Originally Posted by arvidjaar View Post
    So you are apparently using bootloader from Mageia. In this case it knows nothing about newly installed openSUSE; you need to boot Mageia and reconfigure bootloader; but you really need to ask on Mageia forums how to do it. You may need to enable probing for other OSes there.
    Hi and thanks arvidjaar,
    Ok, then I will ask there for some clue, and also will post the result here if I found any answer

  6. #6

    Default Re: Leap doesn't boot with Mageia and Win 8.1

    Also one thing,
    In the last part of the installation, the boot setting has the followings:
    • Don't install bootcode into MBR,
    • Install bootcode into "/" partition


    Should i change something here?

    thanks

  7. #7
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,695

    Default Re: Leap doesn't boot with Mageia and Win 8.1

    No if you use generic boot code in the MBR. Generic requires a boot flag.

    Note also the Mageia may use an odd bot method. seems like I have seen other try this in the past do a search for magaie I'm sure you will uncover some threads

  8. #8
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,479
    Blog Entries
    3

    Default Re: Leap doesn't boot with Mageia and Win 8.1

    Quote Originally Posted by lightblue View Post
    Also one thing,
    In the last part of the installation, the boot setting has the followings:
    • Don't install bootcode into MBR,
    • Install bootcode into "/" partition


    Should i change something here?

    thanks
    That could be okay, depending on how you are using it.

    Does your BIOS have an option to set the disk boot order? If you set it to boot "/dev/sdc" (the third disk), does that work? What is in "/boot/grub2/device.map" on your Leap system?

    What is not clear, is how you are actually booting. You talk of a "grub2" menu. As far as I know, Mageia uses Legacy grub (sometimes called "grub1"). Leap uses Grub2, but you cannot be using the Leap boot menu if you are not seeing an entry for Leap.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  9. #9

    Default Re: Leap doesn't boot with Mageia and Win 8.1

    Quote Originally Posted by gogalthorp View Post
    No if you use generic boot code in the MBR. Generic requires a boot flag.

    Note also the Mageia may use an odd bot method. seems like I have seen other try this in the past do a search for magaie I'm sure you will uncover some threads
    Hi and thanks gogalthorp,

    I'm not sure if i got all you mean,
    But I only found some old threads about installing Mageia alongside Opensuse, but their resolutions didn't solve my issue.

    Also I did install Opensuse thumbleweed easily and without any issue alongside my other OSs (Mageia and Windows), and here the issue is only with Leap

  10. #10

    Default Re: Leap doesn't boot with Mageia and Win 8.1

    Quote Originally Posted by nrickert View Post
    That could be okay, depending on how you are using it.

    Does your BIOS have an option to set the disk boot order? If you set it to boot "/dev/sdc" (the third disk), does that work? What is in "/boot/grub2/device.map" on your Leap system?

    What is not clear, is how you are actually booting. You talk of a "grub2" menu. As far as I know, Mageia uses Legacy grub (sometimes called "grub1"). Leap uses Grub2, but you cannot be using the Leap boot menu if you are not seeing an entry for Leap.
    Yes it does, thus i'm changing it and let you know the result in a moment.
    Actually Mageia 5 (as well as Mageia 4) has the option to use Grub 2 and 1, and i'm using Grub 2 graphical boot loader.


    the contains of /boot/grub2/device.map are:

    (hd3) /dev/sdd
    (hd0) /dev/sdc
    (hd2) /dev/sdb
    (hd1) /dev/sda
    i think sdd is incorrect, as it is my USB installation drive

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •