Results 1 to 9 of 9

Thread: screen recorder not working

  1. #1

    Default screen recorder not working

    I need to use a screen recorder for class, so i need this by Monday (hopefully sooner.) When I record all I get is a glitch y video of my mouse moving, whatever I had open in the background so for sure the application, and nothing changes. I have tried simplescreenrecorder, recordmydesktop, and vlc, all had the same problem. I will attach a video of me opening firefox, browsing to openSUSE, closing firefox, opening yast, closing yast, and stopping the recording. I don't have any clue what this could be, and I really need this to work.https://youtu.be/9GxpxLBcQqw

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,256
    Blog Entries
    2

    Default Re: screen recorder not working

    Quote Originally Posted by Arodd2000 View Post
    I need to use a screen recorder for class, so i need this by Monday (hopefully sooner.) When I record all I get is a glitch y video of my mouse moving, whatever I had open in the background so for sure the application, and nothing changes. I have tried simplescreenrecorder, recordmydesktop, and vlc, all had the same problem. I will attach a video of me opening firefox, browsing to openSUSE, closing firefox, opening yast, closing yast, and stopping the recording. I don't have any clue what this could be, and I really need this to work.https://youtu.be/9GxpxLBcQqw
    Try enabling/disabling hardware acceleration for you GPU.

    Another screencasting app you can try
    Kazam
    http://software.opensuse.org/package...rch_term=kazam

    Although not packaged for openSUSE, Vokoscreen was highly recommended by a member of my local Linux UG. Its source is posted on github and the install requirements look to be easily provided by the OSS
    https://github.com/vkohaupt/vokoscreen


    You can also try reducing the frame rate for you capture.
    Rule of thumbs are
    29fps will almost always guarantee seamless, jitter-free video but can require substantial resources if there is a lot of detail
    24fps is on the edge of when you might not have jitter-free video
    Decrease your screen resolution so less data needs to be captured and encoded.
    If you have multiple machines, you can encode on a machine different than the capturing.
    Decrease your audio capture quality as much as possible. In fact at my local Linux UG presentation, audio was captured on a separate, dedicated device and was used as a replacement track for the one captured by the computer.

    HTH,
    TSU

  3. #3

    Default Re: screen recorder not working

    how would I go about turning off hardware acceleration in gnome 3

  4. #4

    Default Re: screen recorder not working

    Just for the heck of it, I tried using recordmydesktop in icewm (because I already had it installed) and it worked. I don't know why. I don't know why GNOME would be a problem.

  5. #5

    Default Re: screen recorder not working

    I still need this to work on GNOME.

  6. #6
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,908

    Default Re: screen recorder not working

    Quote Originally Posted by Arodd2000 View Post
    I still need this to work on GNOME.
    Then try Tsu's recommendations.

    It may be because Gnome requires a lot more resources than Icewm. I'd start with hardware acceleration.

  7. #7

    Default Re: screen recorder not working

    So how do I disable hardware acceleration?

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,800
    Blog Entries
    15

    Default Re: screen recorder not working

    On Wed 16 Dec 2015 02:16:03 AM CST, Arodd2000 wrote:

    Just for the heck of it, I tried using recordmydesktop in icewm (because
    I already had it installed) and it worked. I don't know why. I don't
    know why GNOME would be a problem.


    Hi
    By default GNOME shell has built in recording for webm (saved to
    ~/Videos), just press ctrl+alt+shift+r to start and same to stop
    recording.

    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 12 | GNOME 3.10.1 | 3.12.51-52.31-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  9. #9

    Default Re: screen recorder not working

    Thank you, the ctrl+alt+shift+r worked perfectly!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •