Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: YaST/Oxygen — Same problem two years later.

  1. #1
    Join Date
    Nov 2015
    Posts
    13

    Default YaST/Oxygen — Same problem two years later.

    I cannot update Leap because YaST2 freezes while downloading oxygen5-icon-theme.


    This happens while updating a brand-new install on a Mac mini under Virtualbox, but the same thing happens on my Athlon II X4 machine as well -- the update gets to this point, then YaST2 freezes up solid, abort won’t function, and y2base goes to 99% CPU.


    The DVD was verified with Media Check.


    Is this an isolated incident, on two widely different machines? No. This same thing happened two years ago with an earlier version of openSUSE, on both a 64bit and a 32bit install. See https://forums.opensuse.org/showthre...ghlight=oxygen. The post is under a different name because I forgot my password. The problem remained unresolved, so I’ve been with Fedora for the past couple of years. I'd like to come back, but can't live with a system that won't update.





  2. #2
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: YaST/Oxygen — Same problem two years later.

    a freeze could be a busy background operation, what DE are you using as plasma 5 has an update applet that works?
    You should try and update from a console by running
    Code:
    zypper up

  3. #3
    Join Date
    Nov 2015
    Posts
    13

    Default Re: YaST/Oxygen — Same problem two years later.

    Quote Originally Posted by I_A View Post
    a freeze could be a busy background operation, what DE are you using as plasma 5 has an update applet that works?
    You should try and update from a console by running
    Code:
    zypper up
    This is the plain-vanilla YaST Online Update that everyone runs first thing after installing that is failing.

    zypper up halts at 97% of oxygen5-icon-theme-5.16.0-2.1.noarch.rpm, the same as YaST, above. System load is light under zypper, but still halts at the same place.

    What is DE, and update applet? I have plenty of power on this machine, and no other demanding tasks. I even let this run overnight with no luck. This is four very different machines, and three different versions, two years apart, of openSUSE that do this same thing. Puzzling!

  4. #4
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: YaST/Oxygen — Same problem two years later.

    DE is Desktop Environment ie Plasma 5 (was KDE) or Gnome or LXDE or ..., Plasma has an update applet that updates on it's own.
    There are 2 possibilities
    #1 the mirror you are using is having issues, try getting/installing it directly from a working mirror
    Code:
    zypper in ftp://gd.tuwien.ac.at/opsys/linux/opensuse/update/leap/42.1/oss/noarch/oxygen5-icon-theme-5.16.0-2.1.noarch.rpm
    or just download this and then install it with rpm or zypper

    #2 when it looked like it was frozen yast was working and you broke it, in that case you might need to rebuild the rpm database

  5. #5
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: YaST/Oxygen — Same problem two years later.

    your cache might also be courted, you should clean your rpm cache and re-apply the updates
    Code:
    sudo zypper clean
    sudo zypper ref
    sudo zypper up

  6. #6
    Join Date
    Nov 2015
    Posts
    13

    Default Re: YaST/Oxygen — Same problem two years later.

    Quote Originally Posted by I_A View Post
    DE is Desktop Environment ie Plasma 5 (was KDE) or Gnome or LXDE or ..., Plasma has an update applet that updates on it's own.
    There are 2 possibilities
    #1 the mirror you are using is having issues, try getting/installing it directly from a working mirror
    Code:
    zypper in ftp://gd.tuwien.ac.at/opsys/linux/opensuse/update/leap/42.1/oss/noarch/oxygen5-icon-theme-5.16.0-2.1.noarch.rpm
    or just download this and then install it with rpm or zypper

    #2 when it looked like it was frozen yast was working and you broke it, in that case you might need to rebuild the rpm database
    I gave yast plenty of time to complete the operation, overnight. Plus, it didn't respond to the abort button. It was broken already.

    Anyway, this instruction got us to 99%, a new record, before it packed up.

  7. #7
    Join Date
    Nov 2015
    Posts
    13

    Default Re: YaST/Oxygen — Same problem two years later.

    Quote Originally Posted by I_A View Post
    your cache might also be courted, you should clean your rpm cache and re-apply the updates
    Code:
    sudo zypper clean
    sudo zypper ref
    sudo zypper up
    Things proceeded normally until it got to this point:

    Retrieving: oxygen5-icon-theme-5.16.0-2.1.noarch.rpm ................................................[error (49.7 KiB/s)]
    Timeout exceeded when accessing 'http://download.opensuse.org/update/leap/42.1/oss/noarch/oxygen5-icon-theme-5.16.0-2.1.noarch.rpm'.

    Abort, retry, ignore? [a/r/i] (r):
    Trying again...
    Retrieving: oxygen5-icon-theme-5.16.0-2.1.noarch.rpm ..........................................................<97%>==[|]

  8. #8
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: YaST/Oxygen — Same problem two years later.

    modify your update repo to point to ftp://gd.tuwien.ac.at/opsys/linux/op...leap/42.1/oss/
    or another mirror close to you
    http://mirrors.opensuse.org/list/42.1.html

    also check and see if ip6 is off, it really shouldn't affect this but some people have been having trouble connecting to mirrors if ip6 was on
    yast->network settings->global options
    I have it on and I have no issues but again other people do.

  9. #9
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: YaST/Oxygen — Same problem two years later.

    are you using btrfs maybe your root partition is full, delete a few snapshots

  10. #10
    Join Date
    Nov 2015
    Posts
    13

    Default Re: YaST/Oxygen — Same problem two years later.

    Quote Originally Posted by I_A View Post
    modify your update repo to point to ftp://gd.tuwien.ac.at/opsys/linux/op...leap/42.1/oss/
    or another mirror close to you
    http://mirrors.opensuse.org/list/42.1.html

    also check and see if ip6 is off, it really shouldn't affect this but some people have been having trouble connecting to mirrors if ip6 was on
    yast->network settings->global options
    I have it on and I have no issues but again other people do.
    IPv6 default was on, so I unchecked it.

    Tried

    zypper clean
    zypper ref
    zypper up


    as above, and it failed. Tried

    zypper in ftp://gd.tuwien.ac.at/opsys/linux/op...2.1.noarch.rpm

    as above and it failed again too.


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •