Results 1 to 5 of 5

Thread: Systray freeze silliness

  1. #1

    Default Systray freeze silliness

    After each reboot the printer applet loads into the systray widget and stays there and the entire widget freezes. Right clicking does nothing etc. I have to unlock widgets and drag the thing out before I can remove it with the X, then I have to put a new one in before it works properly again.

    Could be a cache thing but where is it in Plasma 5?

    Thanks.
    .
    ✶ PC: P55 - i5 760 ✶ W7 / Leap 42.1 Dual Boot ✶/ (ext4). /home (ext4) ✶ KF5 & Plasma 5 Repo - Plasma 5.8.x Qt 5.7 ✶

  2. #2

    Default Re: Systray freeze silliness

    Quote Originally Posted by david_banner View Post
    After each reboot the printer applet loads into the systray widget and stays there and the entire widget freezes. Right clicking does nothing etc.
    Never seen anything like this.
    Which printer applet are you talking about?
    You might try to uninstall it, or disable it in the system tray settings.

    I have to unlock widgets and drag the thing out before I can remove it with the X, then I have to put a new one in before it works properly again.
    You mean you remove the whole system tray applet?
    And it doesn't freeze when you add a new one back?

    Could be a cache thing but where is it in Plasma 5?
    Definitely not.

    If it is indeed the printer applet that's causing this, it might be because some (network) printers are not reachable.
    Although actually this problem should be fixed since years (well, it froze the whole desktop anyway)...
    Last edited by wolfi323; 12-Dec-2015 at 07:13.

  3. #3

    Default Re: Systray freeze silliness

    The entire systray widget I have to remove and slot a new one in.

    Although at the moment I've got big gaps in the panel where other icons should be:




    See that printer icon? that loads first into the panel bit first usually (and it shouldn't because it's set to Auto and no printer is plugged in) and shortly after the freeze happens. And it's just specific to the systray widget.
    .
    ✶ PC: P55 - i5 760 ✶ W7 / Leap 42.1 Dual Boot ✶/ (ext4). /home (ext4) ✶ KF5 & Plasma 5 Repo - Plasma 5.8.x Qt 5.7 ✶

  4. #4

    Default Re: Systray freeze silliness

    Quote Originally Posted by david_banner View Post
    The entire systray widget I have to remove and slot a new one in.

    Although at the moment I've got big gaps in the panel where other icons should be:
    That's probably a different problem.
    Are those old-style XEmbed icons? There's a problem at the moment that those are transparent with certain video drivers.
    They should be fully functional otherwise though, i.e. you should be able to click on them.

    See here for more details and fixed packages:
    https://bugzilla.opensuse.org/show_bug.cgi?id=953954

    Try to install that, maybe it will also help with the freeze.

    OTOH, as you don't use the default desktop theme apparently, it might just be that the theme misses the corresponding icons...

    See that printer icon?
    You mean the one labelled "Printers"?

    (and it shouldn't because it's set to Auto and no printer is plugged in)
    "Auto" doesn't influence whether the applet is loaded, it only affects whether it is shown or hidden.

    Untick the checkbox in the "System Tray Settings" (in Display) to prevent it from being loaded, that would also tell whether it is indeed the culprit.
    Last edited by wolfi323; 12-Dec-2015 at 07:49.

  5. #5

    Default Re: Systray freeze silliness

    That's probably a different problem.
    Are those old-style XEmbed icons? There's a problem at the moment that those are transparent with certain video drivers.
    They should be fully functional otherwise though, i.e. you should be able to click on them.
    No, can't click on anything. I just went to the plasma 5.5 repo and did dup, if that's any use.

    See here for more details and fixed packages:
    https://bugzilla.opensuse.org/show_bug.cgi?id=953954

    Try to install that, maybe it will also help with the freeze.
    Will try.

    OTOH, as you don't use the default desktop theme apparently, it might just be that the theme misses the corresponding icons...
    It's Thin Air 2, it's updated often enough, as far as I can tell the only thing that is a bit off is krunner doesn't match the same transparency every time.

    You mean the one labelled "Printers"?
    yeah, that loads first and it never has before, after that the freeze happens.

    "Auto" doesn't influence whether the applet is loaded, it only affects whether it is shown or hidden.

    Untick the checkbox in the "System Tray Settings" (in Display) to prevent it from being loaded, that would also tell whether it is indeed the culprit.
    I did and it does seem to be the problem. I don't print every day so I'll keep if off till I install that patch above. Thanks.
    .
    ✶ PC: P55 - i5 760 ✶ W7 / Leap 42.1 Dual Boot ✶/ (ext4). /home (ext4) ✶ KF5 & Plasma 5 Repo - Plasma 5.8.x Qt 5.7 ✶

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •