Results 1 to 6 of 6

Thread: not working peazip

  1. #1
    Join Date
    Apr 2015
    Location
    The Earth
    Posts
    496

    Default not working peazip

    Hi
    i installed application peazip in the repo "home:ecsos" not work. and test other repo re-download repo "home:xdf:hfs" but not running .
    do not run in the opensuse 42.1?
    Dual-boot openSUSE and win10
    OpenSUSE Tumbleweed ; Plasma 5.15.x:" LVM encrypted"
    My Partition: GPT and UEFI system
    Hp ProBook 450 G1

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,822
    Blog Entries
    1

    Default Re: not working peazip

    Use the package from this repo, the command installs the Pascal repository.
    Code:
    zypper ar -f http://download.opensuse.org/repositories/devel:/languages:/pascal/openSUSE_Leap_42.1/ lang:Pascal_421
    When you use a package from a "home" repo, it's some individual's work.
    If you use a package from a non-home repo, it's the work of a community of individuals.

    TSU

  3. #3
    Join Date
    Apr 2015
    Location
    The Earth
    Posts
    496

    Default Re: not working peazip

    Quote Originally Posted by tsu2 View Post
    Use the package from this repo, the command installs the Pascal repository.
    Code:
    zypper ar -f http://download.opensuse.org/repositories/devel:/languages:/pascal/openSUSE_Leap_42.1/ lang:Pascal_421
    When you use a package from a "home" repo, it's some individual's work.
    If you use a package from a non-home repo, it's the work of a community of individuals.

    TSU
    Ok
    Thanks
    I test and install repo pascal not work
    when running with terminl
    show error
    Code:
    :~> peazip
    peazip: symbol lookup error: peazip: undefined symbol: QApplication_hook_hook_commitDataRequest
    
    Dual-boot openSUSE and win10
    OpenSUSE Tumbleweed ; Plasma 5.15.x:" LVM encrypted"
    My Partition: GPT and UEFI system
    Hp ProBook 450 G1

  4. #4
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: not working peazip

    this is one of those rare occasions when it's packman's fault,
    packman carries a problematic version of libQt4Pas5
    http://packman.links2linux.org/package/qt4pas-devel
    I use doublecmd and if I use packman's version of libQt4Pas5 I get the same error, the solution is simple force install of libQt4Pas5 from the pascal repo
    Code:
    zypper in -f http://download.opensuse.org/repositories/devel:/languages:/pascal/openSUSE_Leap_42.1/x86_64/libQt4Pas5-2.5-1.1.x86_64.rpm

  5. #5
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: not working peazip

    Quote Originally Posted by I_A View Post
    this is one of those rare occasions when it's packman's fault,
    packman carries a problematic version of libQt4Pas5
    http://packman.links2linux.org/package/qt4pas-devel
    I use doublecmd and if I use packman's version of libQt4Pas5 I get the same error, the solution is simple force install of libQt4Pas5 from the pascal repo
    Code:
    zypper in -f http://download.opensuse.org/repositories/devel:/languages:/pascal/openSUSE_Leap_42.1/x86_64/libQt4Pas5-2.5-1.1.x86_64.rpm
    It's not necessarily a problematic but an old library libQt4Pas5
    from packman 2.1
    from pascal 2.5
    I'm not sure how does one ask packman to update or even remove a library as I don't see the need for libQt4Pas5 to be hosted by packman, maybe a 3rd party application from packman needs that old version of libQt4Pas5.
    ps you can update to peazip from home:ecsos as the only reason for your issue was not related to the repository.

  6. #6
    Join Date
    Apr 2015
    Location
    The Earth
    Posts
    496

    Default Re: not working peazip

    Quote Originally Posted by I_A View Post
    It's not necessarily a problematic but an old library libQt4Pas5 from packman 2.1from pascal 2.5I'm not sure how does one ask packman to update or even remove a library as I don't see the need for libQt4Pas5 to be hosted by packman, maybe a 3rd party application from packman needs that old version of libQt4Pas5.ps you can update to peazip from home:ecsos as the only reason for your issue was not related to the repository.
    after libQt4Pas5 update from packman 2.1 to pascal 2.5
    now running and very good works
    Thank you.
    Dual-boot openSUSE and win10
    OpenSUSE Tumbleweed ; Plasma 5.15.x:" LVM encrypted"
    My Partition: GPT and UEFI system
    Hp ProBook 450 G1

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •