Results 1 to 3 of 3

Thread: Unable to use either Yast Software management or zypper due to bad key

  1. #1
    Join Date
    Aug 2008
    Location
    Little Exuma, Bahamas
    Posts
    699

    Default Unable to use either Yast Software management or zypper due to bad key

    This is a recent upgrade to Leap.
    Code:
    # uname -a
    Linux linux-nx75.site 4.1.13-5-default #1 SMP PREEMPT Thu Nov 26 16:35:17 UTC 2015 (49475c3) x86_64 x86_64 x86_64 GNU/Linux
    All was running well until I added new repositories using Yast>Software Repositories. All appeared to go well until I then went to Software Management and it would not load. The error message that was displayed said:
    An error occurred during repository initialization./etc/zypp/repos.d/Vitualization

    .repo: Section []: Line 1 contains garbage (no '=' or ',|/\' in key)
    I then tried the following:
    Code:
    linux-nx75:~ # zypper lr
    Unexpected exception.
    /etc/zypp/repos.d/Vitualization
    .repo: Section []: Line 1 contains garbage (no '=' or ',|/\' in key)
    Please file a bug report about this.
    See http://en.opensuse.org/Zypper/Troubleshooting for instructions.
    Code:
    linux-nx75:~ # zypper rr Vitualization
    Unexpected exception.
    /etc/zypp/repos.d/Vitualization
    .repo: Section []: Line 1 contains garbage (no '=' or ',|/\' in key)
    Please file a bug report about this.
    See http://en.opensuse.org/Zypper/Troubleshooting for instructions.
    Code:
    linux-nx75:~ # zypper clean
    Unexpected exception.
    /etc/zypp/repos.d/Vitualization
    .repo: Section []: Line 1 contains garbage (no '=' or ',|/\' in key)
    Please file a bug report about this.
    See http://en.opensuse.org/Zypper/Troubleshooting for instructions.
    Any suggestions?

    I have followed the link provided and found no help there. I am willing to submit a bug report, but at this point I can't provide any detail other than what's in this post.
    MS user 1988-2008, Linux user 1998-present, openSUSE user since 2004
    (The first computer I used had a punch card reader)

  2. #2
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,728
    Blog Entries
    2

    Default Re: Unable to use either Yast Software management or zypper due to bad key

    I would be flying blind, but I would look in the file Virtualization.repo. It's located in the folder /etc/zypp/repos.d/

    1: look inside the file /etc/zypp/repos.d/Virtualization.repo and if it does indeed contain junk in a line, delete the file then reinstall the repo again
    OR
    2: I would delete the repo named "Vitualization" and then see if zypper started to work again. And then create/add-back-in the repo again and see if the problem has gone.



    [those two might actually be the same thing done different ways]
    Last edited by swerdna; 10-Dec-2015 at 14:00.
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  3. #3
    Join Date
    Aug 2008
    Location
    Little Exuma, Bahamas
    Posts
    699

    Default Re: Unable to use either Yast Software management or zypper due to bad key

    Quote Originally Posted by swerdna View Post
    1: look inside the file /etc/zypp/repos.d/Virtualization.repo and if it does indeed contain junk in a line, delete the file then reinstall the repo again
    Good call, thanx
    MS user 1988-2008, Linux user 1998-present, openSUSE user since 2004
    (The first computer I used had a punch card reader)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •