Results 1 to 7 of 7

Thread: So I used YaST to get Plasma 5.5...(Quick question)

  1. #1

    Default So I used YaST to get Plasma 5.5...(Quick question)

    Quick question:

    I added the http://download.opensuse.org/reposit...nSUSE_Factory/ (KF5) repository and proceeded to update to Plasma 5.5 by clicking "switch system packages to the versions in this repository." I did this, and then got trigger happy/OCD with the other repos (the 3 "Main" repos), as well as one at the bottom that I am not sure about. After the update(s), I checked my Plasma version and it was still at 5.4, and Qt was 5.5. I went back into YaST and re-updated from the KF5 repo, and the update was successful and I now have Plasma 5.5 and Qt 5.5.

    My assumption is that the other ("Main") repos I "updated" from after my initial update from KF5 wrote over the KF5 updates, and in doing so reverted Plasma back to 5.4 from 5.5. Apparently YaST doesn't care if I'm downgrading packages to earlier versions? And if so, where did those "old" packages go (did YaST delete them, or are they now taking up space as rubbish?)

    Thanks!

    -Erik

  2. #2
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: So I used YaST to get Plasma 5.5...(Quick question)

    I added the http://download.opensuse.org/reposit...nSUSE_Factory/ (KF5) repository and proceeded to update to Plasma 5.5 by clicking "switch system packages to the versions in this repository." I did this, and then got trigger happy/OCD with the other repos (the 3 "Main" repos), as well as one at the bottom that I am not sure about.
    yes you ended up with mixed packages, actually first you upgraded to 5.5 then downgraded to 5.4 as the "main" repossesses do not have plasma 5.5.

    Apparently YaST doesn't care if I'm downgrading packages to earlier versions?
    yast does what you tell it to do, it's not skynet it does not have a mind of it's own, and some people do want the option to downgrade.


    And if so, where did those "old" packages go (did YaST delete them, or are they now taking up space as rubbish?)
    after installing a downloaded rpm file, yast does delete them, there is an option to keep them but that is off by default.

    imo the best way to upgrade to plasma 5.5 and then downgrade (if you want to) is by using zypper and the command line.
    as you did play with system repositories it might be a good idea to re-dup to packman and/or the main or the KDE:/Frameworks5 repo.
    But seeing you are on tw you really don't need to add the extra repo to get plasma 5.5 it will get published in the regular oss repo in a few days or a week two tops.

  3. #3

    Default Re: So I used YaST to get Plasma 5.5...(Quick question)

    Quote Originally Posted by I_A View Post
    yes you ended up with mixed packages, actually first you upgraded to 5.5 then downgraded to 5.4 as the "main" repossesses do not have plasma 5.5.


    yast does what you tell it to do, it's not skynet it does not have a mind of it's own, and some people do want the option to downgrade.



    after installing a downloaded rpm file, yast does delete them, there is an option to keep them but that is off by default.

    imo the best way to upgrade to plasma 5.5 and then downgrade (if you want to) is by using zypper and the command line.
    as you did play with system repositories it might be a good idea to re-dup to packman and/or the main or the KDE:/Frameworks5 repo.
    But seeing you are on tw you really don't need to add the extra repo to get plasma 5.5 it will get published in the regular oss repo in a few days or a week two tops.
    LOL skynet...

    Thanks for your help. I am most definitely new to this. I re-dup'd (I think) to the KF5 repo, again in Yast, and it immediately closed out of software management which suggests to me that there is "nothing to do." I like to use the command line too, but Yast seems to be quite robust in its own right. Is there anything inherently wrong with using Yast for "major" changes like this?

  4. #4
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: So I used YaST to get Plasma 5.5...(Quick question)

    yast is great, but you can use zypper with the --from switch to do a dup (distribution upgrade) with more then 1 repository, for example I just upgraded to plasma 5.5 and did a dup with 2 repo's just to keep packman working if I used yast after setting the KDE:/Frameworks5 as the system repo I'd have to do that for packman or multimedia would not work, with zypper it's easier, for me it was
    zypper dup --from 2 --from 12
    and that was it.

  5. #5

    Default Re: So I used YaST to get Plasma 5.5...(Quick question)

    I see...is this different from adding repos in Yast and then dup'ing from multiple repos simultaneously in softman?

  6. #6
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: So I used YaST to get Plasma 5.5...(Quick question)

    Quote Originally Posted by erikp View Post
    I see...is this different from adding repos in Yast and then dup'ing from multiple repos simultaneously in softman?
    not that different if you don't already have the repo you need to add if first with the zypper ar (add repo) command, for example adding the repo KDE:/Frameworks5 for TW I'd need to do
    Code:
    zypper ar -f http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_Factory/KDE:Frameworks5.repo
    the -f means auto refresh and the above single link is possible because KDE:/Frameworks5 has a repo file
    http://download.opensuse.org/reposit...ameworks5.repo
    if it didn't have a repo file I'd use a different command (I can use this command anyway but it takes an extra variable the repo name)

    Code:
    zypper ar -f http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_Factory/ KDE_Frameworks5
    after I've added the repo I'd execute
    Code:
    zypper lr
    list repositories and I would see the aliases and repository number for all my repositories, then I'd execute
    Code:
    zypper dup --from <insert KDE:Frameworks number> --from <insert packman number>

  7. #7

    Default Re: So I used YaST to get Plasma 5.5...(Quick question)

    Perfect, thanks. I forgot to add that I added the KF5 repo using zypper.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •