I could fix my boot issue. Thanks to the answers in this thread, I understood that my ESP partition was not mounted, which it is necessary to boot a system in EFI mode. I think the issue occurred because I had set my BIOS to provide Legacy booting support, because my USB flash is recognized by the BIOS if this option is enabled; so when I installed my new OS from the LiveUSB, it was installed in BIOS/CSM-mode. But as it said avidjaar in this thread, it was quite unlikely according to my partition setup after installation. Just, for some reason that I do not understand yet, my ESP partition was not mounted. So, I followed the avidjaar's advice and I tried mount the ESP on /boot/efi, but that did not worke either for me.

I had to read many forums and blogs about this topic, fortunately I encountered the Rod Smith web page (http://www.rodsbooks.com/), and I had to read many of his posts to understand better how managing EFI Bootloaders for Linux works. Specially the articles, http://www.rodsbooks.com/linux-uefi/, http://www.rodsbooks.com/efi-bootloaders/index.html, were very helpfully, but still, nothing could fix my issue. So I tried again the avidjaar's advice, and I boot from a LiveCD. That's what I did, I installed my new opensuse from a LiveCD, and that works. Now, my system boots up successfully from EFI mode, the ESP partition is now mounted, and the issue is resolved, at least for me. It was a silly mistake but annoying, but it helped me to understand better this topic.

I appreciate if someone can explain to me why when I installed from the LiveUSB, the ESP was not mounted if the LiveUSB containing that partition, as seen in post # 1 of this thread. Thank you.