Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Configuring Conky

  1. #1
    Join Date
    Jan 2011
    Location
    Guadalajara
    Posts
    173

    Default Configuring Conky

    Leap 42.1 is the most responsive and stable openSUSE ever. I installed the Xfce DE but after many days without rebooting the system slowed down. In order to determine what was eating up my RAM I installed Conky and as a result closed one of the four web browsers that was in use.

    However: Conky opened in a window with a black background. I would like to configure it to have a transparent background and assume more control over what text and how much is shown.

    I also installed conky-doc but have not been able to open it. (cnf conky-doc produces no results, and geany conky-doc opens a blank page).

    Any suggestions will be appreciated.

    Thanks in advance.

  2. #2
    Join Date
    Jan 2011
    Location
    Guadalajara
    Posts
    173

    Default Re: Configuring Conky

    I found a few tutorials but for some reason conkyrc does not appear to be in the usual place and searching for it with SpaceFM File Search doesn't locate it either.

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,890
    Blog Entries
    15

    Default Re: Configuring Conky

    On Sun 06 Dec 2015 10:46:01 PM CST, d hinds wrote:

    I found a few tutorials but for some reason conkyrc does not appear to
    be in the usual place and searching for it with SpaceFM File Search
    doesn't locate it either.


    Hi
    If you don't have a ~/.conkyrc or use the -c option then by default it
    will use /etc/conky/conky.conf.

    Now, with version 1.10.x the configuration file is different since it's
    move to lua type scripts/configuration. I prefer to use the 1.9.x
    series at the moment....

    So if you copy the default one to ~/.conkyrc and then tweak that to
    your liking.

    Have a look at;
    http://conky.sourceforge.net/config_settings.html
    http://conky.sourceforge.net/variables.html

    If you search online for configs, just make sure the 1.10 versions you
    try.

    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 12 | GNOME 3.10.1 | 3.12.48-52.27-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  4. #4
    Join Date
    Jan 2011
    Location
    Guadalajara
    Posts
    173

    Default Re: Configuring Conky

    Quote Originally Posted by malcolmlewis View Post
    Hi
    If you don't have a ~/.conkyrc or use the -c option then by default it
    will use /etc/conky/conky.conf.

    Now, with version 1.10.x the configuration file is different since it's
    move to lua type scripts/configuration. I prefer to use the 1.9.x
    series at the moment....
    The YaST Package Manager lists 3 versions, all of which are 1.10x.
    /etc/conky/conky.conf. is where it is, alright. But Thunar doesn't show it. A SpaceFM File Search did, though.

    As you mention, conky's home is on sourceforge and http://archive09.linux.com/feature/136147 has conky info, also.

    Quote Originally Posted by malcolmlewis View Post
    So if you copy the default one to ~/.conkyrc and then tweak that to
    your liking.

    Have a look at;
    http://conky.sourceforge.net/config_settings.html
    http://conky.sourceforge.net/variables.html

    If you search online for configs, just make sure the 1.10 versions you
    try.

    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 12 | GNOME 3.10.1 | 3.12.48-52.27-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!
    Sure - I'll do that now. And thanks Malcolm, for the orientation.

  5. #5

    Default Re: Configuring Conky

    I installed conky from the packman repo via yast and then when i tried to start it from terminal i get this 'segmentation fault'
    Code:
    conky
    conky: desktop window (1a00044) is subwindow of root window (25b)
    conky: window type - desktop
    conky: drawing to created window (0x4800001)
    Segmentation fault
    any idea on what to do ?

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,890
    Blog Entries
    15

    Default Re: Configuring Conky

    On Sun 13 Dec 2015 12:06:02 PM CST, knightsu wrote:

    I installed conky from the packman repo via yast and then when i tried
    to start it from terminal i get this 'segmentation fault'

    Code:
    --------------------

    conky
    conky: desktop window (1a00044) is subwindow of root window (25b)
    conky: window type - desktop
    conky: drawing to created window (0x4800001)
    Segmentation fault

    --------------------

    any idea on what to do ?


    Hi
    Install the openSUSE version, it has most things configured by default.

    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 12 | GNOME 3.10.1 | 3.12.51-52.31-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  7. #7

    Default Re: Configuring Conky

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Install the openSUSE version, it has most things configured by default.

    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 12 | GNOME 3.10.1 | 3.12.51-52.31-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!
    I am getting the same error from openSUSE version too. Tried from both openSUSE-Leap-42.1-Update , openSUSE-Leap-42.1-OSS, both gives the same error.

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,890
    Blog Entries
    15

    Default Re: Configuring Conky

    On Sun 13 Dec 2015 03:26:02 PM CST, knightsu wrote:

    malcolmlewis;2742638 Wrote:
    > Hi
    > Install the openSUSE version, it has most things configured by
    > default.
    >
    > --
    > Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter
    > #276890)
    > SUSE Linux Enterprise Desktop 12 | GNOME 3.10.1 |
    > 3.12.51-52.31-default If you find this post helpful and are logged
    > into the web interface, please show your appreciation and click on
    > the star below... Thanks!


    I am getting the same error from openSUSE version too. Tried from both
    openSUSE-Leap-42.1-Update , openSUSE-Leap-42.1-OSS, both gives the same
    error.


    Hi
    So was it an existing conkyrc you are using as in <= 1.9 version? If
    so, you need to convert for the 1.10 version.

    Else if you run the default config, does it error out;
    Code:
    conky -c /etc/conky/conky.conf

    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 12 | GNOME 3.10.1 | 3.12.51-52.31-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  9. #9

    Default Re: Configuring Conky

    Quote Originally Posted by malcolmlewis View Post
    Hi
    So was it an existing conkyrc you are using as in <= 1.9 version? If
    so, you need to convert for the 1.10 version.

    Else if you run the default config, does it error out;
    Code:
    conky -c /etc/conky/conky.conf
    No i am not using any existing conkyrc or which is <1.9version. yes
    Code:
    conky -c /etc/conky/conky.conf
    Also errors out.

  10. #10
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,890
    Blog Entries
    15

    Default Re: Configuring Conky

    Hi
    Just tested here with Leap 42.1 and the GNOME DE, all works fine with the default config.

    Aside from conky, did/are the following packages get installed;
    Code:
    imlib2-loaders libImlib2-1 libid3tag0 libmicrohttpd10 libmysqlclient18 lua51
    What DE (Desktop Environment) are you using?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •