Results 1 to 5 of 5

Thread: 13.1/42.1 rtp-stream funktioniert nicht

  1. #1

    Default 13.1/42.1 rtp-stream funktioniert nicht

    Zuerst ausprobiert auf 13.1, noch mal getestet mit 42.1

    Ich versuche einen Stream mit VLC abzuspielen. In einer Datei steht die Adresse.
    Beispiel:

    #EXTM3U
    #EXTINF:-1,(01) Das Erste
    rtp://@239.35.10.4:10000

    Erstellt habe ich die Datei mit der Funktion "Live-TV" einer Fritzbox.

    Es passiert fast nichts. VLC zeigt nur eine Playlist an. Kaffeine startet zwar, aber zeigt nur ein schwarzes Fenster. Andere Player starten noch nicht einmal.
    Mein erster Gedanke war, die Firewall abzuschalten. Änderte aber nichts am Ergebnis.

    Das Abspielen von allen möglichen Mediendateien ist eigentlich kein Problem, entsprechende Codecs sind installiert.
    Auf einem Windows-Rechner funktionieren die Dateien: VLC startet und zeigt das TV-Programm an.

    Tante Google konnte mir nichts sagen. Das kann aber auch daran liegen, dass mir die richtigen Suchkriterien/Selektoren fehlen.

    Wo kann ich da anfangen zu suchen?

  2. #2

    Default Re: 13.1/42.1 rtp-stream funktioniert nicht

    Quote Originally Posted by kungel View Post
    Es passiert fast nichts. VLC zeigt nur eine Playlist an. Kaffeine startet zwar, aber zeigt nur ein schwarzes Fenster. Andere Player starten noch nicht einmal.
    Also andere Dateien funktionieren? Was für andere Dateien hast du genau probiert (Format/Codec)?

    Ich gehe mal davon aus, dass vlc-codecs und libxine2-codecs installiert sind, nach deiner Beschreibung.
    Probier aber mal einen kompletten Wechsel aller Pakete nach Packman, um mögliche Paket-Inkompatibilitäten auszuschließen.
    (Ansicht->Repositories in YaST, das Packman Repo auswählen, dann auf "Wechsel aller Systempakete..." über der Paket-Liste rechts anlicken)

    Es könnte auch helfen das Paket libvdpau_va_gl1 zu deinstallieren falls es installiert ist. Das dient dazu, VDPAU (also nvidia's Hardware Decodierung) auf intel Systemen zu ermöglichen, kann aber Probleme verursachen. Notwendig ists sowieso nicht wirklich, da sowohl Xine als auch VLC intels VA-API direkt unterstützen.
    In 13.1 gibts das aber noch gar nicht...

    PS: die angegeben URL funktioniert bei mir (13.2) auch nicht.
    Sicher, dass die richtig ist?
    239.35.10.4 erreiche ich nicht mal über ping...
    Last edited by wolfi323; 30-Nov-2015 at 08:51.

  3. #3

    Default AW: 13.1/42.1 rtp-stream funktioniert nicht

    das ging aber schnell.

    vlc, vlc-codecs, libxine2-codecs sind von packman installiert.
    (vlc-codecs gibt es doch eh nur von da, oder?)

    libvdpau_va_gl1 kann ich nicht deinstallieren, da nicht installiert und in keinem Repository (13.1)
    Es gibt aber libvdpau1, libvdpau_r600 und libvdpau_radeonsi (aber von openSUSE, gibt es nicht von packman)
    Für 42.1 müsste ich erst den Rechner neu starten.

    Zur URL:
    Kann sein, dass man dafür einen Vertrag über Digital-TV von der Telekom braucht.
    Sie funktioniert: Über mein Notebook mit Windows 10 kann ich problemlos die TV-Sender erreichen.
    Mit genau den Dateien, die bei Opensuse nicht funktionieren.
    Gerade läuft die Tagesschau.

  4. #4

    Default Re: 13.1/42.1 rtp-stream funktioniert nicht

    Quote Originally Posted by kungel View Post
    vlc, vlc-codecs, libxine2-codecs sind von packman installiert.
    (vlc-codecs gibt es doch eh nur von da, oder?)
    Ja.

    libvdpau_va_gl1 kann ich nicht deinstallieren, da nicht installiert und in keinem Repository (13.1)
    Wie gesagt, in 13.1 gabs das noch nicht, kann also auch nicht das Problem sein.

    Es gibt aber libvdpau1, libvdpau_r600 und libvdpau_radeonsi (aber von openSUSE, gibt es nicht von packman)
    Das passt schon so, solltest du auch nicht deinstallieren.

    Dein Problem scheint aber im Nachhinein gesehen nicht an deiner Installation zu liegen.
    Sondern vielmehr an der Art wie du diese URL probierst aufzurufen.
    Leider kann ich da auch nicht wirklich weiterhelfen, ich kann nur sagen dass diese URL bei mir auch nicht funktioniert (kann jetzt aber verschiedene Gründe haben, z.B. bin ich in Österreich...).

    Ein Gedanke: evtl. brauchts da noch einen Benutzernamen/Passwort vor dem @?
    Probier vielleicht auch mal die URL in Firefox oder Chrome/Chromium aufzurufen...
    Last edited by wolfi323; 30-Nov-2015 at 09:28.

  5. #5

    Default AW: Re: 13.1/42.1 rtp-stream funktioniert nicht

    Quote Originally Posted by wolfi323 View Post
    Ein Gedanke: evtl. brauchts da noch einen Benutzernamen/Passwort vor dem @?
    wie beschrieben: mit dem Windows-Notebook funktioniert die Datei mit der URL
    (aufgerufen über eine SMB-Freigabe auf dem Suse-Rechner)
    Benutzername/Passwort da nicht notwendig (habe ich auch gar nicht), aber einen Vertrag mit der Telekom in D sollte da sein.

    Die URL hatte ich auch mit Firefox aufgerufen:
    FF wollte eine Anwendung, ich wählte Kaffeine und es passierte wieder nichts.

    Chromium habe ich jetzt mal ausprobiert, hat auch nicht funktioniert.
    Stattdessen wurde ich nach Google weitergeleitet. Hier aber ich dies gefunden:
    http://www.iptv-anbieter.info/iptv-s...-tv-am-pc.html

    Die Dateien sind demnach schon richtig. Informationen gibt es aber nur für Microsoft. Das funktioniert ja.
    Nicht schön, soll aber reichen.

    Danke für die Hilfe.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •