Results 1 to 3 of 3

Thread: phpMyAdmin Error The mbstring extension is missing.

  1. #1

    Default phpMyAdmin Error The mbstring extension is missing.

    Hello mates.

    Apache and PHP is working fine and MySQL too. But when I execute the browser with http://localhost/phpMyAdmin/, It shows this message:

    phpMyAdmin - Error

    The mbstring extension is missing. Please check your PHP configuration.


    I have installed the package php5-mbstring, the files are correctly installed and they are in their folders. In Yast->Network Services->HTTP Server don't appear the module mbstring neither in "add modules".

    How can I resolve this problem?.

    Greetings.

    Code:
    mysqlshow -u root -p
    Enter password: 
    +--------------------+
    |     Databases      |
    +--------------------+
    | information_schema |
    | mysql              |
    | performance_schema |
    +--------------------+
    zypper se -i  php5
    Loading repository data...
    Reading installed packages...
    
    S | Name             | Summary                    | Type   
    --+------------------+----------------------------+--------
    i | apache2-mod_php5 | PHP5 Module for Apache 2.0 | package
    i | php5             | PHP5 Core Files            | package
    i | php5-bz2         | PHP5 Extension Module      | package
    i | php5-ctype       | PHP5 Extension Module      | package
    i | php5-dom         | PHP5 Extension Module      | package
    i | php5-gd          | PHP5 Extension Module      | package
    i | php5-iconv       | PHP5 Extension Module      | package
    i | php5-json        | PHP5 Extension Module      | package
    i | php5-mbstring    | PHP5 Extension Module      | package
    i | php5-mcrypt      | PHP5 Extension Module      | package
    i | php5-mysql       | PHP5 Extension Module      | package
    i | php5-pdo         | PHP5 Extension Module      | package
    i | php5-sqlite      | PHP5 Extension Module      | package
    i | php5-tokenizer   | PHP5 Extension Module      | package
    i | php5-xmlreader   | PHP5 Extension Module      | package
    i | php5-xmlwriter   | PHP5 Extension Module      | package
    i | php5-zip         | PHP5 Extension Module      | package
    i | php5-zlib        | PHP5 Extension Module      | package
    rpm -ql php5-mbstring 
    /etc/php5/conf.d/mbstring.ini
    /usr/lib64/php5/extensions/mbstring.so
    cat  /etc/php5/cli/php.ini | grep mbstring
    ; encodings.  To use this feature, mbstring extension must be enabled.
    ;extension=php_mbstring.dll
    ;extension=php_exif.dll      ; Must be after mbstring as it depends on it
    [mbstring]
    ; http://php.net/mbstring.language
    ;mbstring.language = Japanese
    ; http://php.net/mbstring.internal-encoding
    ;mbstring.internal_encoding = UTF-8
    ; http://php.net/mbstring.http-input
    ;mbstring.http_input = UTF-8
    ; http://php.net/mbstring.http-output
    ;mbstring.http_output = pass
    ; mbstring.internal_encoding setting. Input chars are
    ; http://php.net/mbstring.encoding-translation
    ;mbstring.encoding_translation = Off
    ; http://php.net/mbstring.detect-order
    ;mbstring.detect_order = auto
    ; http://php.net/mbstring.substitute-character
    ;mbstring.substitute_character = none
    ; overload(replace) single byte functions by mbstring functions.
    ; http://php.net/mbstring.func-overload
    ;mbstring.func_overload = 0
    ;mbstring.strict_detection = On
    ; Default: mbstring.http_output_conv_mimetype=^(text/|application/xhtml\+xml)
    ;mbstring.http_output_conv_mimetype=
    ; With mbstring support this will automatically be converted into the encoding
    ; given by corresponding encode setting. When empty mbstring.internal_encoding

  2. #2

    Default Re: phpMyAdmin Error The mbstring extension is missing.

    Did you restart Apache after installing php5-mbstring?

    Also, how did you install phpMyAdmin? If you installed the package included in openSUSE, it should pull in everything that's necessary.
    So maybe install that anyway to get all necessary packages, you can remove it afterwards again if you installed phpMyAdmin manually.

    And yes, it is normal that this doesn't show up in YaST->HTTP Server, this is no Apache Module that can/has to be enabled.

  3. #3

    Default Re: phpMyAdmin Error The mbstring extension is missing.

    I did restart Apache sometimes and anything. phpMyAdmin was installed from the openSUSE OSS repository.

    But now phpMyAdmin is working fine because I remove the package php5-mbstring and I install again.

    This subject is solved.

    Greetings.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •