Results 1 to 9 of 9

Thread: Visual lag within plasma 5 and nvidia

  1. #1
    Join Date
    Oct 2014
    Location
    Lisboa
    Posts
    55

    Default Visual lag within plasma 5 and nvidia

    Since some updates ago, I have sporadic slow downs on my desktop where the cpu gets a spike of usage and all gets slow. This happens while playing on steam, just browsing on Firefox or opening the kick menu. I have an nvidia geforce 210 card with proprietary driver (go3)

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,743

    Default Re: Visual lag within plasma 5 and nvidia

    open a console and run top see if it shows the program eating CPU. it may or may not be a video driver issue

  3. #3
    Join Date
    Oct 2014
    Location
    Lisboa
    Posts
    55

    Default Re: Visual lag within plasma 5 and nvidia

    how can I keep track of that, while playing? for example, if I'm playing fullscreen how can I track the resource hog?

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,278
    Blog Entries
    2

    Default Re: Visual lag within plasma 5 and nvidia

    Quote Originally Posted by pdvrosado View Post
    how can I keep track of that, while playing? for example, if I'm playing fullscreen how can I track the resource hog?
    If you're running full screen, then you have an existential problem, you have no display space to view anything else in real time.
    The typical solution for this is to run your monitoring problem from another machine, in fact it can be highly recommended when you want to avoid the monitoring program's own usage muddying results. When a monitoring app runs on another machine, typically the sensors on your target machine use next to no resources.

    TSU

  5. #5
    -G- NNTP User

    Default Re: Visual lag within plasma 5 and nvidia

    Have you tried switching off the desktop effects?
    System Settings>Compositor>untick "Enable compositor on startup"

  6. #6
    Join Date
    Oct 2014
    Location
    Lisboa
    Posts
    55

    Default Re: Visual lag within plasma 5 and nvidia

    I may have found the issue. For some reason, I have more than 10 xembedsniproxy processes open in the background taking up 1gb of ram and another one called web, that everytime it pops up, my cpu usage reaches 100%. No idea how to solve this besides manually killing the task

  7. #7

    Default Re: Visual lag within plasma 5 and nvidia

    Quote Originally Posted by pdvrosado View Post
    No idea how to solve this besides manually killing the task
    For xembed-sni-proxy, install the latest version from the KDE:Frameworks5 repo, or even better install the testing package mentioned here and give feedback (after all you filed a bug report about missing tray icons yourself...):
    http://bugzilla.opensuse.org/show_bug.cgi?id=953954#c21

    I have no idea what "web" is though, it's definitely nothing by KDE/Plasma 5.
    But that seems to be your real problem...
    Try to hover over it in KDE's systemmonitor (Ctrl+ESC) to see the full path, and then run "rpm -qf filepath" to find out where it belongs to.
    Or switch to the tree view to see the parent process.

  8. #8
    Join Date
    Oct 2014
    Location
    Lisboa
    Posts
    55

    Default Re: Visual lag within plasma 5 and nvidia

    I will try to find from where comes web process, but regarding xembedsniproxy, I don't feel very confortable installing test packages on my leap. For my desktop I only use leap as the main OS and I don't want to screw up more than I've already did, I want it to be stable. All those xembedsnproxy processes were takng 1gb of my ram, and I just did a kill command to them all, ram usage decreased and nothing changed on the tray. Not even sure why this happened in the first place of from where they came from

    If it's really necessary I can install the packages, but it would be nice if I could nail down the source of lag. Even with the option to turn off composition while on fullscreen or either pressing alt+shft+f12 to manually disable it, I still get random cpu usage spikes while playng on steam (native) or Wow through wine (It used to work perfectly, not even the desktop would stutter. From a few updates til now, I get this. Not even sure if the lag is related to web or xembedsniproxy, because all my games run in fullscreen (I have an amd singlecore cpu, playing and opening ksysguard bogs everything down, running games on windowed mode is even worse)

  9. #9

    Default Re: Visual lag within plasma 5 and nvidia

    Quote Originally Posted by pdvrosado View Post
    I will try to find from where comes web process, but regarding xembedsniproxy, I don't feel very confortable installing test packages on my leap. For my desktop I only use leap as the main OS and I don't want to screw up more than I've already did, I want it to be stable.
    You cannot screw up much with xembed-sni-proxy, in the worst case old-style icons won't show up in the system tray.
    But the "testing" package contains the latest upstream version that's included in Tumbleweed since a month and will also be officially part of Plasma 5.5 (to be released in about a week), so it should actually be stable, and is in my experience.

    You could of course also disable the autostart of xembed-sni-proxy, by specifying it to be excluded from session management in Configure Desktop->Startup and Shutdown->Session Management.

    All those xembedsnproxy processes were takng 1gb of my ram, and I just did a kill command to them all, ram usage decreased and nothing changed on the tray. Not even sure why this happened in the first place of from where they came from
    Again, this is needed to display old-style icons in the system tray.
    If you don't use applications with old-style system tray icons, you don't need it at all.
    You could even uninstall xembed-sni-proxy in that case, you'd need to "break plasma5-workspace by ignoring some of its dependencies" but that's ok here.

    If it's really necessary I can install the packages, but it would be nice if I could nail down the source of lag. Even with the option to turn off composition while on fullscreen or either pressing alt+shft+f12 to manually disable it, I still get random cpu usage spikes while playng on steam (native) or Wow through wine (It used to work perfectly, not even the desktop would stutter. From a few updates til now, I get this. Not even sure if the lag is related to web or xembedsniproxy, because all my games run in fullscreen (I have an amd singlecore cpu, playing and opening ksysguard bogs everything down, running games on windowed mode is even worse)
    That doesn't sound related to xembed-sni-proxy though.
    Try to disable compositing completely, either in KDE's settings or by pressing Shift+Alt+F12.
    Last edited by wolfi323; 30-Nov-2015 at 04:42.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •