Results 1 to 9 of 9

Thread: Try Wayland on KDE?

  1. #1

    Default Try Wayland on KDE?

    Hi,

    just wanted to see if someone can point me at a 'how-to' to try Wayland on KDE. I can see some useful (early days) info on Martin Gräßlin's blog, but nothing newer. I see allot about GNOME and Wayland, but I gather it's fairly well supported on Plasma 5.4.x as well.

    Apologies if this exists someplace and my google-fu was insufficient to find it. Thanks in advance!


    Russ.

  2. #2

    Default Re: Try Wayland on KDE?

    Quote Originally Posted by russ_hay View Post
    just wanted to see if someone can point me at a 'how-to' to try Wayland on KDE. I can see some useful (early days) info on Martin Gräßlin's blog, but nothing newer. I see allot about GNOME and Wayland, but I gather it's fairly well supported on Plasma 5.4.x as well.
    Not really, I think.
    AIUI, it will be fairly well supported in 5.5, but there still are caveats.

    And AFAIK there is no "easy" way to use it, (a lot of) manual tinkering is required.
    I cannot even give you hints though...

  3. #3

    Default Re: Try Wayland on KDE?

    Thanks anyway - I wanted to have a play, not to break my system (if support's still that early!) I'll wait a while longer. Thx!

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,364
    Blog Entries
    3

    Default Re: Try Wayland on KDE?

    Quote Originally Posted by russ_hay View Post
    just wanted to see if someone can point me at a 'how-to' to try Wayland on KDE.
    I have a test install of the Kaos distro (a rolling Plasma 5 distro). They are usually a little ahead of opensuse, but without the openQA testing.

    They do have experimental support for Plasma 5 under Wayland. So I tried it earlier today.

    I logged into Wayland/Plasma 5. Three Kcrash windows popped up telling me that Kwin had crashed. I closed two of those, then clicked "Restart" on the third. Three more crash windows showed up.

    So I right clicked on the desktop, so as to logout. Nothing happened.

    I tried CTRL-ALT-DEL, and got the logout screen. I clicked "Logout", but nothing happened.

    So I tried CTRL-ALT-F1, etc. I think it was CTRL-ALT-F3 that gave me a login screen. I logged in as root, and did "shutdown -r now" (which actually worked).

    I'm thinking that KDE/Wayland isn't ready for prime time.
    openSUSE Leap 15.1; KDE Plasma 5;

  5. #5
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,935
    Blog Entries
    2

    Default Re: Try Wayland on KDE?

    You can also
    - Install the Enlightenment Desktop. Wayland is installed.
    See this recent Forum thread
    https://forums.opensuse.org/showthre...=enlightenment
    - I thought I saw Wayland installed when I installed the MATE Desktop, but because I already had Enlightenment installed, I don't know if that might have muddied what was running on my system.

    Note that on openSUSE, you can install as many Desktops as you want, and openSUSE will figure out how everything co-exists. If you then disable auto-login you can choose which Desktop you want for that session when you enter your User credentials.

    TSU

  6. #6

    Default Re: Try Wayland on KDE?

    As Plasma 5.5 has been released now, this might interest you...

    Martin Graesslin, one of the main KWin developers, wrote this mail today to warn distributions about installing the now included KDE/Wayland session by default:
    https://mail.kde.org/pipermail/relea...er/009215.html

    Here's the mentioned "Known Issues" section:
    https://community.kde.org/Plasma/5.5...a#KWin_Wayland
    Last edited by wolfi323; 09-Dec-2015 at 10:07.

  7. #7
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,935
    Blog Entries
    2

    Default Re: Try Wayland on KDE?

    Something else for people considering Wayland to take into account...

    My first install of Enlightment (which has Wayland installed) was on fairly old hardware.
    Wayland may enable a number of visual enhancements but I found that you also need sufficient hardware, Wayland isn't going to necessarily be more efficient enabling new capabilities on older video hardware.

    TSU

  8. #8

    Default Re: Try Wayland on KDE?

    I've gotten as far as getting it to try and run, but haven't yet been able to get it past crashing at the progress/loading screen.

    To add it to SDDM, you need to set up a .desktop file in /usr/share/xsessions with the following:

    Code:
    [Desktop Entry]
    Encoding=UTF-8
    Type=wayland-session
    Exec=/usr/bin/startplasmacompositor
    TryExec=/usr/bin/startplasmacompositor
    DesktopNames=KDE
    Name=Wayland
    Comment=Wayland session by KDE
    X-KDE-PluginInfo-Version=5.3.95
    Then you need to go edit
    usr/bin/startplasmacompositor and change the appropriate variable-kajigger to the following:

    Code:
    qdbus=$qbindir/qdbus-qt5
    And then you need to open up YaST2, search for "Wayland" and install the not-already-installed Wayland related packages - I went ahead and installed everything that wasn't 32-bit or -devel to be on the safe side.

    That'll get you to a point where you can at least open Konsole, run "startplasmacompositor" and get a window to run programs in by opening another Konsole window and entering "appname -platform wayland".

    To try and get the entire KDE ecosystem running (maybe it'll work for you, doesn't here):

    Logout, from the SDDM screen go to a TTY (Ctrl+Alt+F3) and log in. Enter the following command:

    Code:
    export $(dbus-launch)
    and then you can either try running it via the
    Code:
    startplasmacompositor
    command as before, or return to SDDM (Ctrl+Alt+F7) and log in from there.

    Hope this helps.

  9. #9
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,364
    Blog Entries
    3

    Default Re: Try Wayland on KDE?

    I fired up my Kaos install, which updated to 5.5 yesterday. So I tried a Wayland login.

    It actually worked. But login was very slow, and logout was very slow. I have the panel set to auto-hide, but it doesn't hide under Wayland. Apart from that, I didn't see any problems. But I did not do much testing. This is with Intel graphics (Haswell, I think), and presumably using SNA acceleration unless Kaos has changed that (I didn't check).
    openSUSE Leap 15.1; KDE Plasma 5;

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •