Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: chrome locks up kde in plasma 5

  1. #1
    grglsn NNTP User

    Default chrome locks up kde in plasma 5

    I have a new installation of Leap 42.1, and it seems to run Plasma 5
    fairly well.

    However I do tend to have this one consistent problem. When I open up
    Chrome, after a few minutes, my desktop and screen locks up. It is not a
    complete lock up, as I can still navigate on the web page I am looking
    at, but I can't go to other tabs, and cannot change focus of any
    windows. Chrome remains in front and won't go away, and I cannot move to
    other virtual desktops or activities.

    I can hit ctrl alt 1 and go to a terminal login, so that allows me to at
    least see what processes are running. But even if I kill chrome and the
    other desktop applications that are open, it doesn't change the desktop
    when I hit ctrl alt 7 and go back in. The only thing I can do to get out
    of it is hit ctrl alt double backspace twice to kill X and then log back in.

    It started doing this after I tried to install a program in wine that
    didn't work.

    I have heard something about some processes trying to use old kde4 files
    or qt4 files and that locking up the screen like this, but I really
    don't know where to begin troubleshooting this problem.

    What do I need to post here to give more information? I can find logs
    and post them or do whatever.

    Thanks,

    --
    G.O.
    Box #1: 42.1 | KDE Plasma 5 | AMD Phenom IIX4 | 64 | 32GB
    Box #2: 13.1 | KDE 4.12 | AMD Athlon X3 | 64 | 4GB
    Laptop #1: 13.1 | KDE 4.12 | Core i7-2620M | 64 | 8GB
    Laptop #2: 42.1 | KDE Plasma 5 | Core i7-4710HQ | 64 | 16GB

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,143
    Blog Entries
    2

    Default Re: chrome locks up kde in plasma 5

    Recommend...
    Take some readings on your system resource usage, particularly memory and memory buffer usage.
    You might find my writeup on using the "Free" tool useful, but in your case run top (info is also available in top, see my article)
    https://en.opensuse.org/User:Tsu2/free_tool

    Open a console and run top.
    Grab a screenshot of top before you open your suspect app (Chrome in your case).
    Take another screenshot when your system is experiencing problems.
    Analyze memory buffer and cache usage changes using the article I wrote.

    Consider running the command I give you in my write-up to clear your memory buffers and cache if you're changing from one major work load to another.

    TSU

  3. #3
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: chrome locks up kde in plasma 5

    What's your graphic card and driver, plasma 5 has known bugs with intel cards and with noveau, the noveau bug is easy to get around just install nvidia's propiatory drivers, the intel bug is hard to fix as it's driver is build-in the kernel maybe use a different desktop, you can try lxqt (0.10 is great) or downgrade to kde4 or use wolfi's repo and install both kde4 and plasma 5.

  4. #4
    golson765 NNTP User

    Default Re: chrome locks up kde in plasma 5

    I don't know why I didn't see your post earlier. Thank you for the
    suggestions. I am working on it now and will take the screen shots and
    do the analysis again next time my machine locks up.

    The problem seems to be intermittent - I just opened chrome with 17
    separate tabs, and there was no issue with having it open. Yesterday I
    had it open with only 4 tabs and my KDE locked up.

    --
    G.O.
    Box #1: 42.1 | KDE Plasma 5 | AMD Phenom IIX4 | 64 | 32GB
    Box #2: 13.1 | KDE 4.12 | AMD Athlon X3 | 64 | 4GB
    Laptop #1: 13.1 | KDE 4.12 | Core i7-2620M | 64 | 8GB
    Laptop #2: 42.1 | KDE Plasma 5 | Core i7-4710HQ | 64 | 16GB

  5. #5
    golson765 NNTP User

    Default Re: chrome locks up kde in plasma 5

    I don't know why I didn't see your post earlier. Thank you for the
    suggestions. I am working on it now and will take the screen shots and
    do the analysis again next time my machine locks up.

    The problem seems to be intermittent - I just opened chrome with 17
    separate tabs, and there was no issue with having it open. Yesterday I
    had it open with only 4 tabs and my KDE locked up.

    --
    G.O.
    Box #1: 42.1 | KDE Plasma 5 | AMD Phenom IIX4 | 64 | 32GB
    Box #2: 13.1 | KDE 4.12 | AMD Athlon X3 | 64 | 4GB
    Laptop #1: 13.1 | KDE 4.12 | Core i7-2620M | 64 | 8GB
    Laptop #2: 42.1 | KDE Plasma 5 | Core i7-4710HQ | 64 | 16GB

  6. #6
    golson765 NNTP User

    Default Re: chrome locks up kde in plasma 5

    On 01/16/2016 12:36 AM, I A wrote:
    >
    > What's your graphic card and driver, plasma 5 has known bugs with intel
    > cards and with noveau, the noveau bug is easy to get around just install
    > nvidia's propiatory drivers, the intel bug is hard to fix as it's driver
    > is build-in the kernel maybe use a different desktop, you can try lxqt
    > (0.10 is great) or downgrade to kde4 or use wolfi's repo and install
    > both kde4 and plasma 5.
    >
    >

    Yes, thank you for the suggestion. I am using a desktop with an MSI 970
    gaming motherboard, and a separate MSI graphics card that uses a GF108
    [GeForce GT 730] nVidia device. I have the nVidia driver installed from
    suse nVidia repository.

    I will try setting up Wolfi's repo and using kde4 also and seeing if
    that helps.

    --
    G.O.
    Box #1: 42.1 | KDE Plasma 5 | AMD Phenom IIX4 | 64 | 32GB
    Box #2: 13.1 | KDE 4.12 | AMD Athlon X3 | 64 | 4GB
    Laptop #1: 13.1 | KDE 4.12 | Core i7-2620M | 64 | 8GB
    Laptop #2: 42.1 | KDE Plasma 5 | Core i7-4710HQ | 64 | 16GB

  7. #7
    golson765 NNTP User

    Default Re: chrome locks up kde in plasma 5

    On 01/16/2016 12:36 AM, I A wrote:
    >
    > What's your graphic card and driver, plasma 5 has known bugs with intel
    > cards and with noveau, the noveau bug is easy to get around just install
    > nvidia's propiatory drivers, the intel bug is hard to fix as it's driver
    > is build-in the kernel maybe use a different desktop, you can try lxqt
    > (0.10 is great) or downgrade to kde4 or use wolfi's repo and install
    > both kde4 and plasma 5.
    >
    >

    Yes, thank you for the suggestion. I am using a desktop with an MSI 970
    gaming motherboard, and a separate MSI graphics card that uses a GF108
    [GeForce GT 730] nVidia device. I have the nVidia driver installed from
    suse nVidia repository.

    I will try setting up Wolfi's repo and using kde4 also and seeing if
    that helps.

    --
    G.O.
    Box #1: 42.1 | KDE Plasma 5 | AMD Phenom IIX4 | 64 | 32GB
    Box #2: 13.1 | KDE 4.12 | AMD Athlon X3 | 64 | 4GB
    Laptop #1: 13.1 | KDE 4.12 | Core i7-2620M | 64 | 8GB
    Laptop #2: 42.1 | KDE Plasma 5 | Core i7-4710HQ | 64 | 16GB

  8. #8

    Default Re: chrome locks up kde in plasma 5

    I've got the exact same problem but I don't use Chrome. So I don't think it's specific Chrome. I use Firefox and have the same issue here described.
    It's a little bit frustrating. I more think (not build of facts!) it's the System Tray.

    I have a intel chipset laptop so I can't change that.

    If someone else has any idea what to do for debugging, please tell me.
    I use Plasma 5 on Leap 42.1

    Paul

  9. #9
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,703

    Default Re: chrome locks up kde in plasma 5

    Is it a Intel + NVIDIA laptop?

    Try turning off effects see if that helps also be sure totally update and try Plasma 5.5

  10. #10
    Join Date
    Jun 2014
    Location
    Italy
    Posts
    76

    Default Re: chrome locks up kde in plasma 5

    Quote Originally Posted by preemeyer View Post
    I've got the exact same problem but I don't use Chrome. So I don't think it's specific Chrome. I use Firefox and have the same issue here described.
    It's a little bit frustrating. I more think (not build of facts!) it's the System Tray.

    I have a intel chipset laptop so I can't change that.

    If someone else has any idea what to do for debugging, please tell me.
    I use Plasma 5 on Leap 42.1

    Paul
    Try killing plasmashell (kill plasmashell) from a console. See what happens next.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •