Results 1 to 10 of 10

Thread: After leap upgrade, my system has a mixed language

  1. #1

    Default After leap upgrade, my system has a mixed language

    I have English (US) as my primary language in both YAST-language and KDE desktop configurations.

    But my system is mainly displayed in secondary language, while only some are in English.

    Funny too that I have two volume controls in two languages reside in the system tray.

    How do I make English the main display language for all again?
    openSUSE Leap 15.0

  2. #2
    Join Date
    Apr 2011
    Location
    loading ...
    Posts
    53

    Default Re: After leap upgrade, my system has a mixed language

    use YaST... not know if in leap changed but in system > lenguage?

    basically yast touch this file:
    Code:
    /etc/sysconfig/language
    take a look at it if you found domething funny...

  3. #3

    Default Re: After leap upgrade, my system has a mixed language

    Quote Originally Posted by bonedriven View Post
    I have English (US) as my primary language in both YAST-language and KDE desktop configurations.
    Make sure that the primary language is on top of the list (on the right) in KDE's language settings.

    But my system is mainly displayed in secondary language, while only some are in English.
    Could you list some examples what is displayed in secondary language?

    Funny too that I have two volume controls in two languages reside in the system tray.
    One is KMix, the other one is the new Plasma "Volume Control" applet (plasma5-pa).

    If you want to get rid of one:
    Just quit kmix (right-click on the icon), and it shouldn't be started any more, unless you manually enabled "Autostart" in its settings.
    Or disable the "Volume Control" applet in the "System Tray Settings".

    You can of course also just uninstall the one you don't want.

    How do I make English the main display language for all again?
    Well, what should work in any case is to remove the secondary language in the settings.
    It's probably not much use anyway, as practically everything should have an english "translation", so there's no need for a fallback.

  4. #4

    Default Re: After leap upgrade, my system has a mixed language

    Quote Originally Posted by wolfi323 View Post
    Make sure that the primary language is on top of the list (on the right) in KDE's language settings.


    Could you list some examples what is displayed in secondary language?


    One is KMix, the other one is the new Plasma "Volume Control" applet (plasma5-pa).

    If you want to get rid of one:
    Just quit kmix (right-click on the icon), and it shouldn't be started any more, unless you manually enabled "Autostart" in its settings.
    Or disable the "Volume Control" applet in the "System Tray Settings".

    You can of course also just uninstall the one you don't want.


    Well, what should work in any case is to remove the secondary language in the settings.
    It's probably not much use anyway, as practically everything should have an english "translation", so there's no need for a fallback.

    Thank you, wolfi. I tried to change the language in yast etc/sysconfig to en_US. Now what was shown in secondary language changed to "?"

    Then I tried to revert back those settings I changed in Yast, delete all other languages except English, and reboot but still I got many "????". Most applications display fine, it seems plasma is having this problem.





    Some serious plasma bug I would say. All I need is pure English for now....
    openSUSE Leap 15.0

  5. #5

    Default Re: After leap upgrade, my system has a mixed language

    Quote Originally Posted by bonedriven View Post
    Some serious plasma bug I would say. All I need is pure English for now....
    Hm, I have never seen anything like this.

    Try rebuilding the .desktop file cache, the system settings entries are stored there:
    Code:
    kbuildsycoca5 --noincremental
    (run that as user)

    Do you have the package desktop-translations installed?
    I know it is broken for some languages (swedish at least), so try to uninstall it.

  6. #6

    Default Re: After leap upgrade, my system has a mixed language

    Quote Originally Posted by wolfi323 View Post
    Hm, I have never seen anything like this.

    Try rebuilding the .desktop file cache, the system settings entries are stored there:
    Code:
    kbuildsycoca5 --noincremental
    (run that as user)

    Do you have the package desktop-translations installed?
    I know it is broken for some languages (swedish at least), so try to uninstall it.
    i got a case when after reboot openSUSE 42.2 Leap KDE system language was other then primarily language specified in the yast settings list

    check a value of two system variables: LANG and LANGUAGE. in my case first was 'en' and second 'ru'

    those those variables are set in ~/.config/plasma-locale-settings.sh so change LANGUAGE to en and log out

    does not looks like YaST updates those values when a primarily language is set

  7. #7
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: After leap upgrade, my system has a mixed language

    I had a similar issue with 42.2 rc2 and stable
    https://forums.opensuse.org/showthre...60#post2799560
    the only way around it was to remove the 2nd language
    I'll try intord's suggestion
    this seams to be a kde bug as I tested it in several languages and in happened in 2 out of 3 languages I tested (2 of those wore the same language different country)
    I think this should be reported upstream to kde

    about the ???? it seams etc->sysconfig editor selected a bad font ie a nonunicode one a font that doesn't have the 2nd language gliphs
    can somebody with a different distro using plasma 5.8 confirm this happens so we can rule out opensuse's build as the culprit? as it didn't happen with plasma 5.7 (down to 5.4) on 42.1 or 13.2

  8. #8

    Default Re: After leap upgrade, my system has a mixed language

    Quote Originally Posted by intord View Post
    does not looks like YaST updates those values when a primarily language is set
    No, it doesn't, and it cannot change the user's settings anyway as it runs as root.

    YaST does set the system's default language.
    $LANG is then set accordingly by the generic X startup scripts when the user logs in.

    But the desktop's user settings override this.
    That's not a bug, but a feature.

    Regading $LANGUAGE: yes, this overrides $LANG, and is not set by the standard scripts. If $LANGUAGE is not set, $LANG is used though.
    That's a standard feature too, not specific to KDE.

    And Plasma does (only) set $LANGUAGE, only this makes it possible to configure more than one language, i.e. a primary language and some fallbacks.

    You can change Plasma's language setting in systemsettings5 ("Configure Desktop") though, you don't have to edit ~/.config/plasma-locale-settings.sh by hand.

  9. #9

    Default Re: After leap upgrade, my system has a mixed language

    Quote Originally Posted by I_A View Post
    I think this should be reported upstream to kde
    Well, I already pointed you to an upstream bug report (about KDE4) in the other thread...

    about the ???? it seams etc->sysconfig editor selected a bad font ie a nonunicode one a font that doesn't have the 2nd language gliphs
    Well, the ???? are indeed likely to be a font problem, but then that's completely unrelated to Plasma.
    And the language in the picture is set to "American English" only, which characters should be available in *any* normal font.
    So for some reason it seems a wrong language is being used for those texts, and that may be caused by an outdated/invalid KDE cache (the cache contains the translated strings for .desktop files), or by wrong translation strings in the translation files (as I wrote this is a known problem in the package desktop-translations for some languages, I don't know if it is fixed already but even if the cache still may contain the old/wrong translations).

  10. #10
    Join Date
    Mar 2010
    Location
    Dublin, Ireland
    Posts
    19

    Default Re: After leap upgrade, my system has a mixed language

    On 42.2, there is also unexpected language output on the command line and in YaST when entering "preferred languages". This suggests the problem is more low level than KDE. Also note that the behaviour is different when a language setting is made more specific such as in "en_US" vs. plain "en". This can be easily replicated by setting the environment variables discussed above, for example

    Code:
    for LANG in '' en en_GB en_IE en_XX de de_DE fr ; do
       for LANGUAGE in en_GB:en_US:fr:de en:fr:de de:fr:en en_IE:fr:de ; do 
            echo -e $LANG '\t' $LANGUAGE '\t' `LANG=$LANG LANGUAGE=$LANGUAGE df | head -1 | cut -c-15`
       done
       echo
    done

    Code:
             en_GB:en_US:fr:de       Filesystem
             en:fr:de        Filesystem
             de:fr:en        Filesystem
             en_IE:fr:de     Filesystem
    
    en       en_GB:en_US:fr:de       Filesystem
    en       en:fr:de        Filesystem
    en       de:fr:en        Filesystem
    en       en_IE:fr:de     Filesystem
    
    en_GB    en_GB:en_US:fr:de       Sys. de fichier
    en_GB    en:fr:de        Sys. de fichier
    en_GB    de:fr:en        Dateisystem
    en_GB    en_IE:fr:de     Sys. de fichier
    
    en_IE    en_GB:en_US:fr:de       Sys. de fichier
    en_IE    en:fr:de        Sys. de fichier
    en_IE    de:fr:en        Dateisystem
    en_IE    en_IE:fr:de     Sys. de fichier
    
    en_XX    en_GB:en_US:fr:de       Filesystem
    en_XX    en:fr:de        Filesystem
    en_XX    de:fr:en        Filesystem
    en_XX    en_IE:fr:de     Filesystem
    
    de       en_GB:en_US:fr:de       Filesystem
    de       en:fr:de        Filesystem
    de       de:fr:en        Filesystem
    de       en_IE:fr:de     Filesystem
    
    de_DE    en_GB:en_US:fr:de       Sys. de fichier
    de_DE    en:fr:de        Sys. de fichier
    de_DE    de:fr:en        Dateisystem
    de_DE    en_IE:fr:de     Sys. de fichier
    
    fr       en_GB:en_US:fr:de       Filesystem
    fr       en:fr:de        Filesystem
    fr       de:fr:en        Filesystem
    fr       en_IE:fr:de     Filesystem
    ("Dateisystem" is German (de) and "syst`eme de fichier" is French (fr).)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •