I have been a Fedora user for a few years and wanted something more stable so removed Fedora and installed SUSE on my desktop. I have been trying to run a zypper upgrade be keep getting invalid repository errors. I have tried to remove these repositories via yast, but cannot. Is this expected from a new install? one reason I went with OpenSUSE was to make use of the hypervisor and I have not had any luck with this either. I also tried VirtualBox and again I have not been able to get that installed and working either. It's been a frustration day to say the least.

Type 'zypper help' to get a list of global options and commands.
linux-i9kq:~ # zypper update
Retrieving repository 'openSUSE-Tumbleweed-Non-Oss' metadata ...........................................................................................................................................................................................................[error]
Repository 'openSUSE-Tumbleweed-Non-Oss' is invalid.
[repo-non-oss|http://download.opensuse.org/tumbleweed/repo/non-oss/] Valid metadata not found at specified URL
Please check if the URIs defined for this repository are pointing to a valid repository.
Skipping repository 'openSUSE-Tumbleweed-Non-Oss' because of the above error.
Retrieving repository 'openSUSE-Tumbleweed-Oss' metadata ...............................................................................................................................................................................................................[error]
Repository 'openSUSE-Tumbleweed-Oss' is invalid.
[repo-oss|http://download.opensuse.org/tumbleweed/repo/oss/] Valid metadata not found at specified URL
Please check if the URIs defined for this repository are pointing to a valid repository.
Skipping repository 'openSUSE-Tumbleweed-Oss' because of the above error.
Loading repository data...
Reading installed packages...