Results 1 to 5 of 5

Thread: VLC Issues

  1. #1

    Default VLC Issues

    Hi,

    I was having trouble watching h264 video on my Leap install. I have since installed the following which appear to have helped (SMPlayer now displays video and sound works)

    k3b-codecs ffmpeg lame gstreamer-plugins-bad gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon gstreamer-plugins-libav libdvdcss2

    When trying to watch h264 video on vlc I get the following though:

    VLC media player 2.2.1 Terry Pratchett (Weatherwax) (revision 2.2.1-0-ga425c42)
    [00000000013a26d8] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
    [VS] Software VDPAU backend library initialized
    libva info: VA-API version 0.38.0
    libva info: va_getDriverName() returns 0
    libva info: Trying to open /usr/lib64/dri/i965_drv_video.so
    libva info: Found init function __vaDriverInit_0_38
    libva info: va_openDriver() returns 0
    [000000000676d8f8] avcodec decoder: Using OpenGL/VAAPI/libswscale backend for VDPAU for hardware decoding.
    [h264 @ 0x6992980] hardware accelerator failed to decode picture



    I have confirmed I am using VLC from packman (as suggested in another article), but I'm still having problems.

    Code:
    S | Name        | Type    | Version     | Arch   | Repository        
    --+-------------+---------+-------------+--------+-------------------
    i | libvlc5     | package | 2.2.1-292.1 | x86_64 | Packman Repository
    i | libvlccore8 | package | 2.2.1-292.1 | x86_64 | Packman Repository
    i | vlc         | package | 2.2.1-292.1 | x86_64 | Packman Repository
    i | vlc-codecs  | package | 2.2.1-292.1 | x86_64 | Packman Repository
    i | vlc-noX     | package | 2.2.1-292.1 | x86_64 | Packman Repository
    i | vlc-qt      | package | 2.2.1-292.1 | x86_64 | Packman Repository
    Any advice please?

    Thanks

  2. #2

    Default Re: VLC Issues

    Quote Originally Posted by yeleek View Post
    Any advice please?
    Uninstall libvdpau_va_gl1.
    It's apparently this that causes your problem:
    Code:
    [000000000676d8f8] avcodec decoder: Using OpenGL/VAAPI/libswscale backend for VDPAU for hardware decoding.
    [h264 @ 0x6992980] hardware accelerator failed to decode picture
    VLC supports VA-API natively, so you would still get hardware decoding (with VLC at least), if your hardware supports it.

  3. #3

    Default Re: VLC Issues

    Quote Originally Posted by wolfi323 View Post
    Uninstall libvdpau_va_gl1.
    It's apparently this that causes your problem:
    Code:
    [000000000676d8f8] avcodec decoder: Using OpenGL/VAAPI/libswscale backend for VDPAU for hardware decoding.
    [h264 @ 0x6992980] hardware accelerator failed to decode picture
    VLC supports VA-API natively, so you would still get hardware decoding (with VLC at least), if your hardware supports it.
    Thank you very much - that got rid of that error.

    Now though (sorry) I get this:

    Code:
    VLC media player 2.2.1 Terry Pratchett (Weatherwax) (revision 2.2.1-0-ga425c42)
    [0000000000c196d8] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
    Failed to open VDPAU backend libvdpau_va_gl.so: cannot open shared object file: No such file or directory
    Failed to open VDPAU backend libvdpau_va_gl.so: cannot open shared object file: No such file or directory
    [00000000031f9098] core video output error: video output creation failed
    [0000000002a45088] core decoder error: failed to create video output
    Failed to open VDPAU backend libvdpau_va_gl.so: cannot open shared object file: No such file or directory
    [00000000056999c8] core video output error: video output creation failed
    [0000000002a45088] core decoder error: failed to create video output
    I am running bumblebee with an Nvidia 960m graphics card... I get the same if I use optirun vlc.

    Thank you

  4. #4

    Default Re: VLC Issues

    Quote Originally Posted by yeleek View Post
    Thank you very much - that got rid of that error.

    Now though (sorry) I get this:

    Code:
    VLC media player 2.2.1 Terry Pratchett (Weatherwax) (revision 2.2.1-0-ga425c42)
    [0000000000c196d8] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
    Failed to open VDPAU backend libvdpau_va_gl.so: cannot open shared object file: No such file or directory
    Failed to open VDPAU backend libvdpau_va_gl.so: cannot open shared object file: No such file or directory
    [00000000031f9098] core video output error: video output creation failed
    [0000000002a45088] core decoder error: failed to create video output
    Failed to open VDPAU backend libvdpau_va_gl.so: cannot open shared object file: No such file or directory
    [00000000056999c8] core video output error: video output creation failed
    [0000000002a45088] core decoder error: failed to create video output
    I am running bumblebee with an Nvidia 960m graphics card... I get the same if I use optirun vlc.

    Thank you
    Actually I fixed it - in preferences, video, windows decoration I set the video output to X11 Video Output.

    THank you

  5. #5

    Default Re: VLC Issues

    Quote Originally Posted by yeleek View Post
    Actually I fixed it - in preferences, video, windows decoration I set the video output to X11 Video Output.
    Shouldn't be necessary, "Auto" should work just fine.

    But, you need to logout/login (or even reboot) after removing libvdpau_va_gl1, or else the system will still try to use it (and give the error messages that you posted).
    Forgot to mention that, sorry.

    With explicitely setting the output to "X11 Video Output", you actually disable all use of hardware decoding, even VA-API which the intel driver supports directly (and should work).
    Last edited by wolfi323; 26-Nov-2015 at 02:02.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •