Results 1 to 5 of 5

Thread: Firefox stops playing mp4 videos

  1. #1
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    893

    Default Firefox stops playing mp4 videos

    Firefox since ever had h.264/mp4 support on my system. The browser stopped working with this format few days ago. Any reason for this?
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  2. #2

    Default Re: Firefox stops playing mp4 videos

    Quote Originally Posted by karlmistelberger View Post
    Firefox since ever had h.264/mp4 support on my system. The browser stopped working with this format few days ago. Any reason for this?
    Firefox uses gstreamer for this.

    Check that you have gstreamer-plugins-bad-orig-addon and gstreamer-plugins-libav installed, and try to delete the gstreamer plugin cache (~/.cache/gstreamer-1.0/)

    There were other threads about problems with gstreamer recently, that seems to have helped.
    There is an issue at the moment, gstreamer-plugins-ugly fail to build and are therefore still at version 1.4.5, while the rest of gstreamer has been updated to 1.6.1.
    But AFAICT the h.264/mp4 plugins are not part of gstreamer-plugins-ugly (and gstreamer-plugins-libav provides a fallback for mostly everything anyway), so it should still work.

  3. #3
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Firefox stops playing mp4 videos

    in the meantime you can try and use ffmpeg directly for multimedia support it has worked for me
    #1 disable gstreamer
    in the address bar type about:config
    set to false
    media.gstreamer.enabled

    # enable ffmpeg
    in the same preference window (about:config)
    find and set to true all of these settings:
    media.fragmented-mp4.ffmpeg.enabled
    media.fragmented-mp4.exposed
    media.mediasource.enabled
    media.mediasource.mp4.enabled

  4. #4
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    893

    Default Re: Firefox stops playing mp4 videos

    Could not find gstreamer-plugins-bad-orig-addon, so I used about:config which works for me.
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  5. #5

    Default Re: Firefox stops playing mp4 videos

    Quote Originally Posted by karlmistelberger View Post
    Could not find gstreamer-plugins-bad-orig-addon
    It is available from Packman, which you need anyway for playing back mp4 videos. (unless you installed ffmpeg from the VLC repo e.g.)

    But using ffmpeg directly is fine as well of course, if it works for you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •