Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: GIMP tooltips getting white text on white background

  1. #1

    Angry GIMP tooltips getting white text on white background

    Hello!

    I have installed Leap 42.1 - KDE desktop.

    When I am firing up GIMP (which I understand is a native GTK2 application) behaves weirdly. When I am hovering mouse over the tool icons, the tooltips that show up have white text on of white or almost transparent background, making the tooltips completely unreadable. Anyone knows a workaround for this problem? I looked up the web and found a solution for the problem but I guess it is targeted for Ubuntu users. Here is the link to the solution.

    Unfortunately, I didn't find the file that has been mentioned in this solution and hence, I am left wondering about how to solve this problem.

    Any kind of help will be greatly appreciated.

    Thanks,
    Sankalan

  2. #2

    Default Re: GIMP tooltips getting white text on white background

    Okay, just installed GNOME desktop environment. Installed a few GTK themes including Numix theme. Switched to KDE desktop, went to system settings >> Application Style >> GNOME Application Style (GTK) and selected Numix Theme for GTK 2 applications and it fixed my problem.

    Thought it might help someone else but my solution is not really a good one because people with less hard disk space may not want to install GNOME desktop environment and eat up precious space. I could afford that and so did that.

  3. #3

    Default Re: GIMP tooltips getting white text on white background

    Thanks for the solution. I didn't install Gnome desktop but only the Numix Theme. This didn't work unfortunately. But hen I tried the Clearlooks theme which came in the default install and it shows tooltips!

  4. #4

    Default Re: GIMP tooltips getting white text on white background

    Quote Originally Posted by sankalan View Post
    Hello!

    I have installed Leap 42.1 - KDE desktop.

    When I am firing up GIMP (which I understand is a native GTK2 application) behaves weirdly. When I am hovering mouse over the tool icons, the tooltips that show up have white text on of white or almost transparent background, making the tooltips completely unreadable. Anyone knows a workaround for this problem? I looked up the web and found a solution for the problem but I guess it is targeted for Ubuntu users. Here is the link to the solution.

    Unfortunately, I didn't find the file that has been mentioned in this solution and hence, I am left wondering about how to solve this problem.

    Any kind of help will be greatly appreciated.

    Thanks,
    Sankalan
    Hi,

    If you configure your gtk themes in systemsettings5, it will create a .gtkrc-2.0 file in your /home/user
    It is a hidden file so you have to enable the show hidden file in dolphin or equivalent.
    That is what the link is pointing to you. With the gtk3 I did not tried to look-up so others might give you another pointer
    regarding that.
    People who do not break things first will never learn to create anything

  5. #5
    Join Date
    May 2015
    Location
    Italy
    Posts
    371

    Default Re: GIMP tooltips getting white text on white background

    There are also other GTK applications that show this problem. One is PDFMod.
    I would prefer to stay with the GTK theme "Breeze" for consistency with my KDE Plasma 5 desktop.
    Would it be possible to fix this theme to avoid the problem? Is it something that comes from OpenSUSE itself or is it upstream from KDE?

    Thank you
    Cris

  6. #6

    Default Re: GIMP tooltips getting white text on white background

    Quote Originally Posted by Cris70 View Post
    There are also other GTK applications that show this problem. One is PDFMod.
    I would prefer to stay with the GTK theme "Breeze" for consistency with my KDE Plasma 5 desktop.
    Would it be possible to fix this theme to avoid the problem? Is it something that comes from OpenSUSE itself or is it upstream from KDE?

    Thank you
    Cris
    Well, I think you can by adjusting the colors in plasma5.
    Code:
    systemsettings5-color
    might do the trick for you, but not 100%.
    People who do not break things first will never learn to create anything

  7. #7
    Join Date
    May 2015
    Location
    Italy
    Posts
    371

    Default Re: GIMP tooltips getting white text on white background

    Hi conram, thank you for your reply!

    Quote Originally Posted by conram View Post
    Well, I think you can by adjusting the colors in plasma5.
    Code:
    systemsettings5-color
    I may be wrong, but I think this will only adjust the color in the Breeze KDE theme, not the equivalent GTK theme.

    Cris

  8. #8

    Default Re: GIMP tooltips getting white text on white background

    Quote Originally Posted by Cris70 View Post
    Hi conram, thank you for your reply!



    I may be wrong, but I think this will only adjust the color in the Breeze KDE theme, not the equivalent GTK theme.

    Cris
    You're not wrong, you have to adjust qt to partner with gtk colors if you don't want to play with the gtkrc or css
    in the gtk themes. That's why I said you can't achieve a 100% accuracy with those two.
    People who do not break things first will never learn to create anything

  9. #9

    Default Re: GIMP tooltips getting white text on white background

    This workaround works for me: Appearance -> Colors -> Options: Disable "Apply colors to non-QT-applications"

    Thanks to: https://bbs.archlinux.org/viewtopic....91107#p1591107

  10. #10
    Join Date
    Mar 2016
    Location
    New York
    Posts
    64

    Default Re: GIMP tooltips getting white text on white background

    Karut, Wow...I have been messing with settings for over 3 weeks trying to figure this problem out. That fixed it for me!

    Thank You very much, my system tweaking is finished for now!
    Motherboard: GA-EP45-UD3P
    CPU: Core2Quad Q8400 2.66GHz.
    Memory: 4 GIB DDR2
    GPU: Geforce GTX 650 1GIB Driver: NVIDIA G03- 340.96
    OS & Desktop: 42.2Leap 64 bit, KDE Plasma 5.8.3,QT 5.6.1 Kernel 4.4.27-2-deafult

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •