Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Plasma 5 frustrations runnenth over

  1. #1

    Default Plasma 5 frustrations runnenth over

    What config directory or file(s) do I need to wipe with Plasma 5 in order to get a stock/default desktop settings and start over.

    I don't have time to track down all the individual problems that have arisen since drawing in the 5.4 updates about a month or so ago .... its funny because prior to that Plasma 5 was really stable, so I never understood the widespread complaints one can find against it ... Now, my long-standing run with a desktop that is conducive to my workflow has hit a real rough patch. Say it ain't over baby, say it ain't so. Come back to me KDE ...

    In brief, here are some of the highly annoying things I'm now encountering and which are really affecting my workflow
    • I leave dolphin open all the time, with multiple tabs (some of which are splits (i.e. F3)) for quick/easy access to the varying stuff I need to work with on a daily basis. Now on boot up into KDE, I frequently find that it (dolphin) is not open, requiring it to be reopened and everything (my tabs and splits) reset again.... sometimes on shutting down the system or logging out of KDE I get messages that I have multiple tabs open and asks if I'm sure I want to quit ... if I say quit (because you can't log out otherwise ... it just hangs forever), it sometimes means that dolphin was exited and on other occasions it is still open as I desire.
    • the application dashboard frequently opens on the wrong monitor (monitor number 2)
    • applications frequently open on the wrong monitor (monitor number 2)
    • firefox opens in a application window the size of about 320x240 ... requiring manual resizing
    • the logout/shutdown window (boxes) opens on the wrong monitor (monitor number 4)
    • in logging into KDE, there is now usually about a 40 second delay before the desktop becomes usable
    • ... others that I can't think of right now

  2. #2

    Default Re: Plasma 5 frustrations runnenth over

    You can rename the directories .config, .kde4 and .kde. These should be enough to reset Kde configuration.
    But there are some real bugs that won't be fixed by reseting the configuration files.
    For instance, I can confirm the dolphin bug on not reopening the tabs :-(

  3. #3
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: Plasma 5 frustrations runnenth over

    Quote Originally Posted by Tyler_K View Post
    In brief, here are some of the highly annoying things I'm now encountering and which are really affecting my workflow
    • in logging into KDE, there is now usually about a 40 second delay before the desktop becomes usable
    • ... others that I can't think of right now
    Confirmed. Some complained of a minute delay. I haven't timed it, but it's significant and irritating. Desktop appears quickly but totally unfurnished. After long delay all furniture appears instantly and usable. Factory ML is aware and IIRC bug report mentioned. Recent snapshot(s) didn't fix it, and a previous one caused it.
    Leap 42.3 (ext4, KDE Plasma 5.8.7) ~ stable
    Manjaro (ext4, Xfce) ~ rolling updates
    Tumbleweed (ext4, KDE Plasma5) ~ managed updates via "Tumbleweed Snapshots" service.

  4. #4

    Default Re: Plasma 5 frustrations runnenth over

    Quote Originally Posted by consused View Post
    Confirmed. Some complained of a minute delay. I haven't timed it, but it's significant and irritating. Desktop appears quickly but totally unfurnished. After long delay all furniture appears instantly and usable. Factory ML is aware and IIRC bug report mentioned. Recent snapshot(s) didn't fix it, and a previous one caused it.
    Thanks. Yeah, the taskbar delay problem is indeed recent. I timed it a couple of times and it was ~40s for me on those occasions (and generally seems to be the case for me), but there have been a few times in which case where the delay was significantly longer, or, rarer, only about 20s.

  5. #5

    Default Re: Plasma 5 frustrations runnenth over

    Quote Originally Posted by marcelovborro View Post
    You can rename the directories .config, .kde4 and .kde. These should be enough to reset Kde configuration.
    But there are some real bugs that won't be fixed by reseting the configuration files.
    For instance, I can confirm the dolphin bug on not reopening the tabs :-(
    Thanks ... the dolphin bug is the most annoying for me ... (its completely disruptive to a smooth work experience)

  6. #6

    Default Re: Plasma 5 frustrations runnenth over

    Hi! I have the same problem. I tried to rename the folders mentioned, but the problem still is there! The past week I didn't had this problem!
    I hope that with the upgrade to plasma 5.4.3 this problem will be solved

  7. #7

    Default Re: Plasma 5 frustrations runnenth over

    Just to add some info:

    *Sometimes* it restores Dolphin session on log in. But that does not happen very often.


    Another issue I found on some machines is that sometimes the knetwork manager icon (or widget, I'm not sure) does not show in the task bar, but it still works.

  8. #8

    Default Re: Plasma 5 frustrations runnenth over

    Quote Originally Posted by loopset View Post
    Hi! I have the same problem. I tried to rename the folders mentioned, but the problem still is there! The past week I didn't had this problem!
    I hope that with the upgrade to plasma 5.4.3 this problem will be solved
    What problem do you mean?
    That dolphin (and other KF5 applications) are often not restored on login by the session management?

    No, that's definitely not fixed in Plasma 5.4.3, I'm afraid.

    Actually it is not a problem with Plasma5's session management, but rather with Qt5. Qt5 unexpectedly quits the application right after it has stored the state, so the session management doesn't see it as running any more (although if you are lucky it is still running at that point) and doesn't save it for being restored at login.
    Apparently they are currently working on a fix though, at least somebody analyzed the problem and explained what happens here yesterday:
    https://bugs.kde.org/show_bug.cgi?id=354724

    As a workaround, you could switch to "Start with a previously saved session" in the session management settings, and then choose "Save Session" in "Session/Powermanagement" in the application menu before you logout. A manually saved session should properly be restored on login.

    For making dolphin not ask for confirmation on logout when multiple tabs are open, just activate the "Do not ask again" checkbox or change that in Dolphin's settings.

    Quote Originally Posted by marcelovborro View Post
    Another issue I found on some machines is that sometimes the knetwork manager icon (or widget, I'm not sure) does not show in the task bar, but it still works.
    Another known problem, currently being investigated (seems to be a bug in Qt5 though):
    https://bugs.kde.org/show_bug.cgi?id=352580
    https://bugs.kde.org/show_bug.cgi?id=352055

    You should be able to make it appear by opening the "System Tray Settings" and disabling the "Miscellaneous" category, pressing "Apply" and enabling it again. Or disable/enable the network manager icon itself there.

    To most of the other points mentioned here I cannot say much because I only have one monitor.

    The Firefox issue I do not see here. Maybe some setting in Firefox?
    You should be able to create a window rule to force a suitable size though (right-click on the window title bar and select "More Actions"->"Special Settings for this Window").

  9. #9

    Default Re: Plasma 5 frustrations runnenth over

    in logging into KDE, there is now usually about a 40 second delay before the desktop becomes usable
    I have recently experienced this same behavior so I did some digging in various KDE forums. It seems to be some issue relating to bluetooth.
    Since I do not need bluetooth capabilities on my desktop, all I did was remove the following packages to make this delay issue go away...
    BLUEZ, BLUEDEVIL, and GNOME-BLUETOOTH

    Hope this helps...

    I am currently running Tumbleweed openSUSE 20151118 with KDE 5.4.2

  10. #10

    Default Re: Plasma 5 frustrations runnenth over

    On Tue, 24 Nov 2015 21:56:02 GMT
    wolfi323 <wolfi323@no-mx.forums.microfocus.com> wrote:

    > For making dolphin not ask for confirmation on logout when multiple
    > tabs are open, just activate the "Do not ask again" checkbox or
    > change that in Dolphin's settings.


    Unfortunately, that will mean that the warning isn't there when you
    need it, like when you've hit the "x" by accident.

    I reported this bug a few weeks ago:
    https://bugs.kde.org/show_bug.cgi?id=354800

    --
    Graham P Davis, Bracknell, Berks.
    openSUSE 13.2 (64-bit); KDE 4.14.9; AMD Phenom II X2 550 Processor;
    Kernel: 4.3.0; Video: nVidia GeForce 210 (Driver: nouveau);
    Sound: ATI SBx00 Azalia (Intel HDA)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •