Hi All,

I am looking for step-by-step tutorial of DC using samba on Opensuse Leap. I tried to follow instructions on samba.org but no success. Everything seams to be working, but when I tried to switch to new domain on Windows, I got error:
Code:
ote: This information is intended for a network administrator.  If you are not your network's administrator, notify the administrator that you received this information, which has been recorded in the file C:\windows\debug\dcdiag.txt.


The following error occurred when DNS was queried for the service location (SRV) resource record used to locate an Active Directory Domain Controller (AD DC) for domain "off.end":


The error was: "DNS name does not exist."
(error code 0x0000232B RCODE_NAME_ERROR)


The query was for the SRV record for _ldap._tcp.dc._msdcs.off.end


Common causes of this error include the following:


- The DNS SRV records required to locate a AD DC for the domain are not registered in DNS. These records are registered with a DNS server automatically when a AD DC is added to a domain. They are updated by the AD DC at set intervals. This computer is configured to use DNS servers with the following IP addresses:


192.168.45.5
192.168.45.4


- One or more of the following zones do not include delegation to its child zone:


off.end
end
. (the root zone)
I added SRV record (_ldap._tcp.dc._msdcs.off.end) to DNS and pointed it to DC (192.168.45.4) but then I got different error that domain controller could not be connected.

Anybody has a success with creating PDC on opensuse?