Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Cannot Change Configuration in KDE Wallet Manager

  1. #1

    Default Cannot Change Configuration in KDE Wallet Manager

    I am trying to learn how to use KDE Wallet and there is no icon in my system tray so I thought I would change that for a start. Using KDE Wallet Manager Control Module I ticked the box accordingly and clicked apply. I was asked for Authentication but whatever I tried, Wallet password, root password, nothing worked and I had message

    Sorry, the system security policy didn't allow you to save the changes
    What am I doing wrong please.

    PS this is a repeat post. It seems if you do not select a prefix to the title the post goes awol. Is that correct?

  2. #2

    Default Re: Cannot Change Configuration in KDE Wallet Manager

    Quote Originally Posted by Budgie2 View Post
    I am trying to learn how to use KDE Wallet and there is no icon in my system tray so I thought I would change that for a start. Using KDE Wallet Manager Control Module I ticked the box accordingly and clicked apply. I was asked for Authentication but whatever I tried, Wallet password, root password, nothing worked and I had message
    You are probably hit by the authentication problem of the polkit update to 0.113.
    Try reverting polkit to 0.112 (using the "Versions" tab in YaST).

    But that should only occur if you logout and then login a second time...

  3. #3

    Default Re: Cannot Change Configuration in KDE Wallet Manager

    Quote Originally Posted by wolfi323 View Post
    You are probably hit by the authentication problem of the polkit update to 0.113.
    Try reverting polkit to 0.112 (using the "Versions" tab in YaST).

    But that should only occur if you logout and then login a second time...
    Hi Wolfi323,
    Thanks for the suggestion. I reverted to polkit 0112 and logged out and back in but the problem still there. How can I get rid of polkit altogether and will that do the trick?

  4. #4

    Default Re: Cannot Change Configuration in KDE Wallet Manager

    I have a similar problem here in Leap 42.1.

    Each time I click on a bookmarked SFTP location in Dolphin I get:

    The application 'kiod5' has requested to open the wallet 'kdewallet'. Please enter the password for this wallet below.
    Neither the GPG password works (obviously because it is not KGpg who wants a password), nor any user/superuser credentials.

    I tried deleting my wallet files with the idea to start from scratch in case this is some misconfiguration but no luck. Before upgrading to Plasma 5 everything worked fine with KWallet. I also tried downgrading to polkit 0.112 but that didn't help.

  5. #5

    Default Re: Cannot Change Configuration in KDE Wallet Manager

    Quote Originally Posted by heyjoe View Post
    I tried deleting my wallet files with the idea to start from scratch in case this is some misconfiguration but no luck.
    And which files exactly did you try to delete?

    kwallet5 uses a new location to store its files: ~/.local/share/kwalletd/.

  6. #6

    Default Re: Cannot Change Configuration in KDE Wallet Manager

    Quote Originally Posted by wolfi323 View Post
    And which files exactly did you try to delete?
    ~/.kde4/share/apps/kwallet/*

    kwallet5 uses a new location to store its files: ~/.local/share/kwalletd/.
    Thanks for explaining. Now after I deleted those too, I was able to create a new "master password" which I can successfully enter when Dolphin asks for it.

    However any attempt to manage wallets in KWalletManager again creates files in ~/.kde4/share/apps/kwallet/. Also for some reason credentials are no longer visible when I open the wallet in the manager. I used to see them in the folder view there.

    Does it mean all passwords are stored now in ~/.local/share/kwalletd/kwallet.kwl and ~/.kde4/share/apps/kwallet/ is simply ignored? What is the way to manage the wallet in KWalletManager in that case? I tried importing ~/.local/share/kwalletd/kwallet.kwl but I am being asked for a password and it doesn't want to accept anything I give to it.

  7. #7

    Default Re: Cannot Change Configuration in KDE Wallet Manager

    Quote Originally Posted by heyjoe View Post
    However any attempt to manage wallets in KWalletManager again creates files in ~/.kde4/share/apps/kwallet/. Also for some reason credentials are no longer visible when I open the wallet in the manager. I used to see them in the folder view there.
    You are using the KDE4 version of kwalletmanager.

    Install kwalletmanager5 instead.

    This will only allow to manage your KF5 wallets though, but KDE4 applications still use the KDE4 wallet.
    Unfortunately, you cannot install both at the same time, as they conflict (they contain some overlapping files).

    Does it mean all passwords are stored now in ~/.local/share/kwalletd/kwallet.kwl and ~/.kde4/share/apps/kwallet/ is simply ignored?
    See above.

    KDE4 applications will use ~/.kde4/share/apps/kwallet/, KF5 applications will use ~/.local/share/kwalletd/kwallet.kwl.

    At first start, kwallet5 will ask you whether you want to migrate the KDE4 wallet, but you cannot sync them later on.
    Unfortunately, the kwallet developers didn't really think this through completely, especially for this transitional period while we still have a mixture of KDE4 and KF5 based applications...
    Last edited by wolfi323; 22-Nov-2015 at 12:51.

  8. #8

    Default Re: Cannot Change Configuration in KDE Wallet Manager

    Thanks wolfi!

    How about KGpg? I can't find an option to use it in kwalletmanager5. I am only offered an option to enter password in the manager itself.

  9. #9

    Default Re: Cannot Change Configuration in KDE Wallet Manager

    Well, I overlooked the question from the OP:
    Quote Originally Posted by Budgie2 View Post
    How can I get rid of polkit altogether and will that do the trick?
    No, you cannot, it would break your system completely.

    Are you using any additional KDE repos?
    If not, you should still have a KDE4 only system, as you are on 13.2.

    But after re-reading the first post:
    I was asked for Authentication but whatever I tried, Wallet password, root password, nothing worked
    AFAIK, if anything, you need to enter your *user* password to modify your wallet.

    Although with the default polkit profile, no password should be necessary at all.
    That's why I thought you're hit by that polkit problem.

    A "wrong" security setting might cause that too, though.
    With "secure" or "paranoid" settings, you do have to enter the user password in this case.

    So, what does this command give?
    Code:
    grep SECURITY /etc/sysconfig/security

  10. #10

    Default Re: Cannot Change Configuration in KDE Wallet Manager

    Quote Originally Posted by wolfi323 View Post
    Well, I overlooked the question from the OP:

    No, you cannot, it would break your system completely.

    Are you using any additional KDE repos?
    If not, you should still have a KDE4 only system, as you are on 13.2.

    But after re-reading the first post:

    AFAIK, if anything, you need to enter your *user* password to modify your wallet.

    Although with the default polkit profile, no password should be necessary at all.
    That's why I thought you're hit by that polkit problem.

    A "wrong" security setting might cause that too, though.
    With "secure" or "paranoid" settings, you do have to enter the user password in this case.

    So, what does this command give?
    Code:
    grep SECURITY /etc/sysconfig/security

    Hi and thanks. Here is result of your command:

    Code:
    :~> grep SECURITY /etc/sysconfig/security
    PERMISSION_SECURITY="easy local"
    # PERMISSION_SECURITY. If PERMISSION_SECURITY contains 'secure' or
    No idea why sentence ends in "or" however you are right as usual, my login password was all that was required.
    Many thanks. Now I can get back to the Luckybackup problem which has not yet provoked any replies.
    Regards,
    Budgie2

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •