Results 1 to 4 of 4

Thread: Cannot change language in KDE plasma 5

  1. #1

    Default Cannot change language in KDE plasma 5

    Hello everybody,

    I have accidentally changed my language settings to polish either by installing aspell-pl or by adding a keyboard or by adding it to translated languages. I have removed it from the translated languages, deinstalled aspell-pl but the menu is still in polish.

    when I go to ./confing/plasma-localerc I see the following.

    Code:
    [Formats]
    LANG=en_US.UTF-8
    
    [Translations]
    LANGUAGE=en_US
    ~                                                                                  
    ~
    Please help me to change the settings back to english.

  2. #2

    Default Re: Cannot change language in KDE plasma 5

    Quote Originally Posted by Mojusko View Post
    I have accidentally changed my language settings to polish either by installing aspell-pl or by adding a keyboard or by adding it to translated languages.
    Installing aspell-pl or adding a keyboard should not change the language.

    But that do you mean with "adding it to translated languages"?
    Where did you add what?

    I have removed it from the translated languages, deinstalled aspell-pl but the menu is still in polish.
    Which menu?

    when I go to ./confing/plasma-localerc I see the following.

    Code:
    [Formats]
    LANG=en_US.UTF-8
    
    [Translations]
    LANGUAGE=en_US
    ~                                                                                  
    ~
    This looks ok, and should lead to an english user session.

    What does "Configure Desktop"->Regional Settings->Translations show?
    Are you actually using Plasma5, or rather something else like GNOME?

    And just to be sure: you need to logout and login again (or reboot) for new language settings to take effect.

  3. #3

    Default Re: Cannot change language in KDE plasma 5

    Well the translations say "American English."

    I just logged in and suddenly the KDE menu is back in English however, the KDE Launcher still shows names of KDE applications in Polish.

    Thanks

  4. #4

    Default Re: Cannot change language in KDE plasma 5

    Quote Originally Posted by Mojusko View Post
    Well the translations say "American English."

    I just logged in and suddenly the KDE menu is back in English however, the KDE Launcher still shows names of KDE applications in Polish.
    Try running "kbuildsycoca5" as user. That should rebuild the menu cache.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •