I am running 13.2 x86_64 with KDE desktop and trying to set up rsync backups to a Qnap NAS. To help with the commands I am using Lucky Backup which I have found to be excellent but I cannot master the password issues.

I do have one luckybackup profile working correctly although I never entered a password file when setting up luckybackup. What I did was run the backup with the correct source and destination addresses and the first time I ran it I had a window pop up with a request for password which I entered. I then had another window headed ksshaskpass to which I answered "yes" and everything worked.

Using KWalletManager I was able to look into the "KDEwallet" and see that the folder ksshaskpass contained the password for the NAS login. Amazingly I could even see it in plain text if I wished.

My problem is that when I tried to set up another rsync profile on luckybackup to a different NAS I could not reproduce the same result. I confess I may have answered one of the pop up windows incorrectly and it seems I do not get another chance.

The Luckybackup manual states:-
Some modules on the remote daemon may require authentication.

luckyBackup, does not support either the definition of passwords as a task property (for security reasons), or the entry of passwords when prompted at the stage of a task execution (because it is possible for the specific task to be scheduled).

If a password is required by the remote daemon, then you have to create a password file and declare it at the relevant text-field (use the browse button to open a graphical file dialog and select your already created file).

The password file must not be world readable and it should contain just the password as a single line.
What is odd it that in the working profile there is no reference to the Kwallet or password file anywhere.
Could somebody please tell me what is going on and help me understand how to get it right.