Results 1 to 4 of 4

Thread: Leap 42.1: YaST, several languages at once.

  1. #1

    Default Leap 42.1: YaST, several languages at once.

    Hi!

    I am having some issues with the locale settings in Leap. I didn't know exactly which forum to put this since the problem perists over the entire system, but it is most visible in YaST.
    Basically, the issue is that I have chosen english_us as primary language, with no secondary languages set. But in spite of this the system language is in a weird mix of english, swedish and what I assume is russian. Needless to say, this is pretty confusing. The GUI I am using is KDE and most KDE things are in machine translated swedish, but some things are in english.



    For the whole shebang we can take a look at YaST where it looks like this.

    http://i.imgur.com/zpAVyAd.png (larger image, did not want to embed)

    Any idea what is going on?

  2. #2

    Default Re: Leap 42.1: YaST, several languages at once.

    Quote Originally Posted by aptushana View Post
    Any idea what is going on?
    The swedish desktop-translations file is broken, see http://bugzilla.suse.com/show_bug.cgi?id=953643 .
    That's why you get those cyrillic strings in the application menu and YaST.

    Regarding KDE:
    Did you set the language in systemsettings5?
    If you used the KDE4 version, it will not be fully applied to KF5/Plasma5.

    And YaST runs as root, so it ignores KDE's user language settings completely.
    If you want to have YaST in english, you should set English as primary language in YaST->System->Language.
    Last edited by wolfi323; 20-Nov-2015 at 06:57.

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,459
    Blog Entries
    2

    Default Re: Leap 42.1: YaST, several languages at once.

    You can experiment also with setting the language explicitly when you login.

    As necessary, make the following settings...

    Open /etc/sysconfig editor
    - Search for, and set your auto login to a specific account (to disable autologin)
    - Search for, and set "language" on login to be enabled if it isn't already (I found it was the default when I installed LXDE as my base Desktop and did not install any other languages).

    The result should be a dropdown box to select your language when you login with your User account.

    TSU

  4. #4

    Default Re: Leap 42.1: YaST, several languages at once.

    Thank you both for the assistance. The problem has now been solved. The issue was that I hadn't explicitly set the prefered language to english in systemsettings5. Changing this fixed the general KDE issue as well as the issue in YaST.

    There might be something off with that YaST ignores KDE thing though. The primary language in YaST was set as english_us the entire time (with no secondary languages chosen) but was still in that weird hybrid as seen in the screenshot until I changed the setting in KDE.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •