Results 1 to 5 of 5

Thread: Amarok doesn't play FLAC!

  1. #1
    Join Date
    Dec 2009
    Location
    Manchester, UK.
    Posts
    74

    Default Amarok doesn't play FLAC!

    Hi all,

    Last night started Amarok to play some tunes, only to be greeted by 'ID3 Tag Demuxer'

    I've got all the correct codecs to play FLAC's, mp3's etc, but still Amarok refuses to play.

    Anyone got any ideas or suggestions to resolve this issue?

    I'm on 13.2 (x64), as Leap 42.1 is too bleeding edge for me.

    Many thanks,
    openSUSE 42.3 (x86_64) KDE Plasma 5.8
    Gigabyte GA-MA785GM-US2H - AMD(R) DUAL CORE 270 @ 3.40GHz
    nVidia Geforce GTX280 - 8GB DDR2 800MHz RAM

    https://linuxcounter.net/user/482859.html

  2. #2
    Join Date
    May 2014
    Location
    Yerevan, Armenia
    Posts
    24

    Default Re: Amarok doesn't play FLAC!

    very strange thread,,,
    can you tell us what codecs did you install exactly and from which repos?

  3. #3
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Amarok doesn't play FLAC!

    flac is open sourced and amarok should play them no matter how your system is set up but...
    where did you get amarok from?
    what is your repo list
    Code:
    zypper lr -d

  4. #4

    Default Re: Amarok doesn't play FLAC!

    Amarok uses KDE's Phonon framework to play files.
    There are two backends available: gstreamer (default) and vlc.

    If you didn't install phonon-backend-vlc manually, you are using gstreamer. The corresponding FLAC plugin and the "ID3 Tag Demuxer" are in gstreamer-plugins-good, so check that you have it installed.
    If it is installed, try to delete the gstreamer plugin cache, i.e. the directory ~/.cache/gstreamer-1.0/.

    If you installed phonon-backend-vlc, better remove it again. The version shipped in openSUSE 13.2 doesn't work with the latest VLC from Packman.
    It is built against and requires VLC 2.1.x (which is also included in 13.2, without restricted codecs though), Packman has 2.2.1 meanwhile.

  5. #5
    Join Date
    Dec 2009
    Location
    Manchester, UK.
    Posts
    74

    Default Re: Amarok doesn't play FLAC!

    Hi wolfi323,

    Renamed ~/.Cache to '.Cache_OLD', starting Amarok this morning all works ok

    Many thanks
    openSUSE 42.3 (x86_64) KDE Plasma 5.8
    Gigabyte GA-MA785GM-US2H - AMD(R) DUAL CORE 270 @ 3.40GHz
    nVidia Geforce GTX280 - 8GB DDR2 800MHz RAM

    https://linuxcounter.net/user/482859.html

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •