Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: No media playback even with codecs

  1. #1
    Join Date
    Oct 2014
    Location
    Lisboa
    Posts
    55

    Default No media playback even with codecs

    This is kind of a mess I brought in. I have a large music library which half are duplicated files. Amarok doesn't clean that cutter up, so I installed perl-duplicate-finder or something and I installed dupeguru pe and dupeguru me (a duplicate finder for songs and the other for photos, which I installed through a repo). I cleaned the clutter and I go to software to remove the apps I've installed and also proceeded to remove the repos related.

    First thing I notice is that for some reason, software manager is removing yast2 and some other core programs along with the apps I've installed. So I interrupted the removal process and rebooted. The 3 programs were removed but but yast meta package handler was removed as well, along with other things. Dragon player wouldn't open and amarok disappeared. I installed amarok again and the codecs from the community, but still I have no music or video playing. Steam, dropbox, and the plasma desktop was not affected but at this point, I cannot say what else got removed.

    Is there a way to revert all the opensuse packages back to default? or is there a way to see what I've removed and what needs to be re-installed? If not, at least a way to play videos and audio again

  2. #2
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,131

    Default Re: No media playback even with codecs

    If you had a default 42.1 installation, the root filesystem will be btrfs an snapper will be aggressively saving snapshots of your system. You can use snapper to roll back to before you installed the de-duplication software. (Un)fortunately the home filesystem is not included in the default snapper configuration.

    Alternatively something like "zypper dup --from openSUSE-Leap-42.1-Oss --from openSUSE-Leap-42.1-Update" should set you back to a default software installation.

    P.S. You might consider using a more relevant title for your thread.
    ~Thank you for sharing an interesting problem.
    --
    slàinte mhath,
    rayH

  3. #3
    Join Date
    Oct 2014
    Location
    Lisboa
    Posts
    55

    Default Re: No media playback even with codecs

    I've re-installed all the missing packages. I think I do not need to revert everything back, but Dragonplayer and Amarok still don't play. I've installed gstreamer base, good, ugly, bad, everything. And still I have no music on amarok and video on dragonplayer, if I can get this to work again, I do not need to revert. Unfortunately I do not know what else to do

  4. #4
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: No media playback even with codecs

    Quote Originally Posted by pdvrosado View Post
    I've re-installed all the missing packages. I think I do not need to revert everything back, but Dragonplayer and Amarok still don't play. I've installed gstreamer base, good, ugly, bad, everything. And still I have no music on amarok and video on dragonplayer, if I can get this to work again, I do not need to revert. Unfortunately I do not know what else to do
    what's your repo list?
    Code:
    zypper lr -d

  5. #5

    Default Re: No media playback even with codecs

    Quote Originally Posted by pdvrosado View Post
    I've re-installed all the missing packages. I think I do not need to revert everything back, but Dragonplayer and Amarok still don't play. I've installed gstreamer base, good, ugly, bad, everything. And still I have no music on amarok and video on dragonplayer, if I can get this to work again, I do not need to revert. Unfortunately I do not know what else to do
    Both use Phonon, what Phonon backends do you have installed?
    Code:
    rpm -qa phonon*
    gstreamer is the default, for full codec support you need to install gstreamer-plugins-bad-orig-addon, gstreamer-plugin-ugly-orig-addon and gstreamer-plugins-libav from Packman.
    If you use VLC, you need to install the package vlc-codecs.

    And you should do a full switch to the Packman repo, to make sure that you don't have some crippled/incompatible libraries installed.
    https://en.opensuse.org/SDB:Vendor_c..._Vendor_change

    If you need more help, please post your repo list:
    Code:
    zypper lr -d

  6. #6
    Join Date
    Oct 2014
    Location
    Lisboa
    Posts
    55

    Default Re: No media playback even with codecs

    |---- | Sim | 99 | NONE |http://download.opensuse.org/distr
    ibution/leap/42.1/repo/non-oss/ |
    10| repo-oss |openSUSE-Leap-42.1-Oss |Sim
    | (r ) Sim | Sim | 99 | yast2 |http://download.opensuse.org/distr
    ibution/leap/42.1/repo/oss/ |
    11| repo-source |openSUSE-Leap-42.1-Source |Não
    |---- | Sim | 99 | NONE |http://download.opensuse.org/sourc
    e/distribution/leap/42.1/repo/oss/ |
    12| repo-update |openSUSE-Leap-42.1-Update |Sim
    | (r ) Sim | Sim | 99 | rpm-md |http://download.opensuse.org/updat
    e/leap/42.1/oss/ |
    13 |repo-update-non-oss |openSUSE-Leap-42.1-Update-Non-Oss |Sim
    | (r ) Sim | Sim | 99 | rpm-md |http://download.opensuse.org/updat
    e/leap/42.1/non-oss/




    rpm-qa phonon*
    phonon4qt5-backend-gstreamer-4.8.2-2.4.x86_64
    phonon-backend-gstreamer-4.8.2-1.2.x86_64

    This are all the outputs from konsole

  7. #7
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,652

    Default Re: No media playback even with codecs

    Please us the code tags for any computer output. it will prevent the editor from changing the formats

    code tags are the # in the forums editor options bars

  8. #8

    Default Re: No media playback even with codecs

    Quote Originally Posted by pdvrosado View Post
    This are all the outputs from konsole
    For playing back MP3 files, you need to install gstreamer-fluendo-mp3 (it's in the standard non-oss repo).
    Either do so with YaST, or run:
    Code:
    sudo zypper in gstreamer-fluendo-mp3
    As already mentioned, for other formats you need to add the Packman repo and install the additional codecs from there.
    Enter YaST->Software Repositories, click on "Add" and choose "Community Repositories", then activate it in the list.
    Then install the packages I mentioned and you should be able to play back practically all multimedia files.
    Choose "Install xxx from Packman Repository (with vendor change)" or similar if asked.

    Or just use the 1-click install in the Multimedia subforum or here: http://opensuse-guide.org/codecs.php

  9. #9
    Join Date
    Oct 2014
    Location
    Lisboa
    Posts
    55

    Default Re: No media playback even with codecs

    Code:
    rpm -qa phonon*
    phonon4qt5-backend-gstreamer-4.8.2-2.4.x86_64
    phonon-backend-gstreamer-4.8.2-1.2.x86_64
    pedro@linux-c7cq:~> zypper lr -d
    #  | Alcunha                             | Nome                                    | Act
    ivado | GPG Check | Refrescar | Prioridade | Tipo   | URI                               
                                          | Serviço
    ---+-------------------------------------+-----------------------------------------+----
    ------+-----------+-----------+------------+--------+-----------------------------------
    --------------------------------------+--------
     1 | Nvidia                              | Nvidia                                  | Sim
          | (r ) Sim  | Sim       |   99       | rpm-md | ftp://download.nvidia.com/opensuse
    /leap/42.1/                           |         
     2 | http-download.opensuse.org-9712c982 | openSUSE:Leap:42.1:NonFree              | Sim
          | (r ) Sim  | Sim       |   99       | yast2  | http://download.opensuse.org/distr
    ibution/leap/42.1/repo/non-oss/       |         
     3 | http-opensuse-guide.org-13af5d6b    | libdvdcss repository                    | Sim
          | (r ) Sim  | Sim       |   99       | rpm-md | http://opensuse-guide.org/repo/ope
    nSUSE_Leap_42.1/                      |         
     4 | http-packman.inode.at-ee74e11e      | Packman Repository                      | Sim
          | (r ) Sim  | Sim       |   99       | rpm-md | http://packman.inode.at/suse/openS
    USE_Leap_42.1/                        |         
     5 | repo-debug                          | openSUSE-Leap-42.1-Debug                | Sim
          | (r ) Sim  | Sim       |   99       | yast2  | http://download.opensuse.org/debug
    /distribution/leap/42.1/repo/oss/     |         
     6 | repo-debug-non-oss                  | openSUSE-Leap-42.1-Debug-Non-Oss        | Não
          | ----      | Sim       |   99       | NONE   | http://download.opensuse.org/debug
    /distribution/leap/42.1/repo/non-oss/ |         
     7 | repo-debug-update                   | openSUSE-Leap-42.1-Update-Debug         | Não
          | ----      | Sim       |   99       | NONE   | http://download.opensuse.org/debug
    /update/leap/42.1/oss                 |         
     8 | repo-debug-update-non-oss           | openSUSE-Leap-42.1-Update-Debug-Non-Oss | Não
          | ----      | Sim       |   99       | NONE   | http://download.opensuse.org/debug
    /update/leap/42.1/non-oss/            |         
     9 | repo-non-oss                        | openSUSE-Leap-42.1-Non-Oss              | Não
          | ----      | Sim       |   99       | NONE   | http://download.opensuse.org/distr
    ibution/leap/42.1/repo/non-oss/       |         
    10 | repo-oss                            | openSUSE-Leap-42.1-Oss                  | Sim
          | (r ) Sim  | Sim       |   99       | yast2  | http://download.opensuse.org/distr
    ibution/leap/42.1/repo/oss/           |         
    11 | repo-source                         | openSUSE-Leap-42.1-Source               | Não
          | ----      | Sim       |   99       | NONE   | http://download.opensuse.org/sourc
    e/distribution/leap/42.1/repo/oss/    |         
    12 | repo-update                         | openSUSE-Leap-42.1-Update               | Sim
          | (r ) Sim  | Sim       |   99       | rpm-md | http://download.opensuse.org/updat
    e/leap/42.1/oss/                      |         
    13 | repo-update-non-oss                 | openSUSE-Leap-42.1-Update-Non-Oss       | Sim
          | (r ) Sim  | Sim       |   99       | rpm-md | http://download.opensuse.org/updat
    e/leap/42.1/non-oss/    
    
    Here are the outputs with the # thing. I've installed the fluendo package, did nothing. Installed the community packages again for codecs and nothing.
    Amarok still doesn't play music and dragonplayer says no files are loaded when I try to play a video. Also noticed that ksnapshot and gwenview were not installed, had to install them again (probably removed when I removed the above mentioned packages).

    Also I got a weird error while trying to update saying this:

    Wrong digest. the file has been changed by accident or by an attacker since the repository creator signed it. Using it is a big risk for the integrity and security of your system. I think this is related to leap/42.1/oss repo, since I said no to the first pop up and another one appeared saying this repo failed to initialize. I want to share a screenshot but can't since I can't upload files here

  10. #10

    Default Re: No media playback even with codecs

    Run this then:
    Code:
    sudo zypper dup --from 4
    If it still doesn't work, try to remove the gstreamer plugin cache, i.e. delete the folder ~/.cache/gstreamer-1.0/.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •