Results 1 to 7 of 7

Thread: LXQT installation problem

  1. #1

    Default LXQT installation problem

    Hello!

    Following instructions in https://en.opensuse.org/LXQT

    I've been failed to install LXQT

    The error is as following:

    Code:
    Problem: nothing provides lxqt-about needed by pattern:LXQT-.noarch
     Solution 1: do not install pattern:LXQT-.noarch
     Solution 2: break pattern:LXQT-.noarch by ignoring some of its dependencies
    My repositories list:
    Code:
     1 | SuSE                      | SuSE (13.2)                                           | Yes     | (r ) Yes  | No     
     2 | X11_QtDesktop             | QtDesktop (openSUSE_13.2)                             | Yes     | (r ) Yes  | No     
     3 | X11_Utilities             | X11 Utilities (openSUSE_13.2)                         | Yes     | (r ) Yes  | No     
     4 | X11_lxde                  | Lightweight X11 Desktop Environment (openSUSE_13.2)   | Yes     | ( p) Yes  | No     
     5 | ftp.gwdg.de-suse          | Packman Repository                                    | Yes     | (r ) Yes  | Yes    
     6 | home_dtufys               | dtufys's Home Project (openSUSE_13.2)                 | Yes     | (r ) Yes  | Yes    
     7 | openSUSE-13.2-0           | openSUSE-13.2-0                                       | No      | ----      | Yes    
     8 | repo-debug                | openSUSE-13.2-Debug                                   | No      | ----      | Yes    
     9 | repo-debug-update         | openSUSE-13.2-Update-Debug                            | No      | ----      | Yes    
    10 | repo-debug-update-non-oss | openSUSE-13.2-Update-Debug-Non-Oss                    | No      | ----      | Yes    
    11 | repo-non-oss              | openSUSE-13.2-Non-Oss                                 | Yes     | ( p) Yes  | Yes    
    12 | repo-oss                  | openSUSE-13.2-Oss                                     | Yes     | ( p) Yes  | Yes    
    13 | repo-source               | openSUSE-13.2-Source                                  | Yes     | (r ) Yes  | Yes    
    14 | repo-update               | openSUSE-13.2-Update                                  | Yes     | (r ) Yes  | Yes    
    15 | repo-update-non-oss       | openSUSE-13.2-Update-Non-Oss                          | Yes     | (r ) Yes  | Yes    
    16 | science                   | Software for Scientists and Engineers (openSUSE_13.2) | Yes     | (r ) Yes  | No
    Any suggestions are very wellcome!

  2. #2
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: LXQT installation problem

    on 13.2 you need the lxqt repo for lxqt support, you don't seam to have that one, the QtDesktop repo does not have lxqt but razorqt, so just add the lxqt repo and install it
    Code:
    sudo zypper ar http://download.opensuse.org/repositories/X11:/LXQt/openSUSE_13.2/X11:LXQt.repo

  3. #3

    Default Re: LXQT installation problem

    Quote Originally Posted by I_A View Post
    on 13.2 you need the lxqt repo for lxqt support, you don't seam to have that one, the QtDesktop repo does not have lxqt but razorqt, so just add the lxqt repo and install it
    Code:
    sudo zypper ar http://download.opensuse.org/repositories/X11:/LXQt/openSUSE_13.2/X11:LXQt.repo
    Thx for the tip. That is mean the opensuse WIKI should be upgraded, yep?

    But after adding both repositories the problem still exist:
    repolist:
    Code:
    2 | X11_LXQt                  | X11:LXQt (openSUSE_13.2)                              | Yes     | (r ) Yes  | No     
     3 | X11_QtDesktop             | QtDesktop (openSUSE_13.2)                             | Yes     | (r ) Yes  | No     
     4 | X11_Utilities             | X11 Utilities (openSUSE_13.2)                         | Yes     | (r ) Yes  | No     
     5 | X11_lxde                  | Lightweight X11 Desktop Environment (openSUSE_13.2)   | Yes     | (r ) Yes  | No
    Code:
    Problem: pattern:LXQT-.noarch requires lxqt-qtplugin, but this requirement cannot be provided
      uninstallable providers: lxqt-qtplugin-0.10.0-1.1.i586[X11_LXQt]
                       lxqt-qtplugin-0.10.0-1.1.x86_64[X11_LXQt]
     Solution 1: Following actions will be done:
      downgrade of libQt5Gui5-5.4.2-22.3.x86_64 to libQt5Gui5-5.3.2-12.2.x86_64
      downgrade of libQt5Widgets5-5.4.2-22.3.x86_64 to libQt5Widgets5-5.3.2-12.2.x86_64
      downgrade of libQt5X11Extras5-5.4.2-9.3.x86_64 to libQt5X11Extras5-5.3.2-1.2.x86_64
      deinstallation of libqt5-qtbase-platformtheme-gtk2-5.4.2-22.3.x86_64
      downgrade of libqt5-qtimageformats-5.4.2-7.1.x86_64 to libqt5-qtimageformats-5.3.2-1.1.x86_64
      downgrade of libKF5ConfigGui5-5.11.0-24.3.x86_64 to libKF5ConfigGui5-5.6.0-8.1.x86_64
      downgrade of libKF5ConfigCore5-lang-5.11.0-24.3.noarch to libKF5ConfigCore5-lang-5.6.0-8.1.noarch
     Solution 2: do not install pattern:LXQT-.noarch
     Solution 3: do not install pattern:LXQT-.noarch
     Solution 4: break pattern:LXQT-.noarch by ignoring some of its dependencies

    The package libQt5Gui5 comes from update repo.

    Code:
    $zypper info  libQt5Gui5
    
    Information for package libQt5Gui5:
    -----------------------------------
    Repository: openSUSE-13.2-Update
    Name: libQt5Gui5
    Version: 5.4.2-22.3
    Arch: x86_64
    Vendor: openSUSE
    Installed: Yes
    Status: up-to-date
    Installed Size: 7.2 MiB
    Summary: Qt 5 GUI related libraries
    Description: 
      Qt 5 libraries which are depending on X11.

    And yes. I've refresh all repo with
    $zypper refresh

  4. #4
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: LXQT installation problem

    Quote Originally Posted by roginovicci View Post
    Thx for the tip. That is mean the opensuse WIKI should be upgraded, yep?

    But after adding both repositories the problem still exist:
    repolist:
    Code:
    2 | X11_LXQt                  | X11:LXQt (openSUSE_13.2)                              | Yes     | (r ) Yes  | No     
     3 | X11_QtDesktop             | QtDesktop (openSUSE_13.2)                             | Yes     | (r ) Yes  | No     
     4 | X11_Utilities             | X11 Utilities (openSUSE_13.2)                         | Yes     | (r ) Yes  | No     
     5 | X11_lxde                  | Lightweight X11 Desktop Environment (openSUSE_13.2)   | Yes     | (r ) Yes  | No
    Code:
    Problem: pattern:LXQT-.noarch requires lxqt-qtplugin, but this requirement cannot be provided
      uninstallable providers: lxqt-qtplugin-0.10.0-1.1.i586[X11_LXQt]
                       lxqt-qtplugin-0.10.0-1.1.x86_64[X11_LXQt]
     Solution 1: Following actions will be done:
      downgrade of libQt5Gui5-5.4.2-22.3.x86_64 to libQt5Gui5-5.3.2-12.2.x86_64
      downgrade of libQt5Widgets5-5.4.2-22.3.x86_64 to libQt5Widgets5-5.3.2-12.2.x86_64
      downgrade of libQt5X11Extras5-5.4.2-9.3.x86_64 to libQt5X11Extras5-5.3.2-1.2.x86_64
      deinstallation of libqt5-qtbase-platformtheme-gtk2-5.4.2-22.3.x86_64
      downgrade of libqt5-qtimageformats-5.4.2-7.1.x86_64 to libqt5-qtimageformats-5.3.2-1.1.x86_64
      downgrade of libKF5ConfigGui5-5.11.0-24.3.x86_64 to libKF5ConfigGui5-5.6.0-8.1.x86_64
      downgrade of libKF5ConfigCore5-lang-5.11.0-24.3.noarch to libKF5ConfigCore5-lang-5.6.0-8.1.noarch
     Solution 2: do not install pattern:LXQT-.noarch
     Solution 3: do not install pattern:LXQT-.noarch
     Solution 4: break pattern:LXQT-.noarch by ignoring some of its dependencies

    The package libQt5Gui5 comes from update repo.

    Code:
    $zypper info  libQt5Gui5
    
    Information for package libQt5Gui5:
    -----------------------------------
    Repository: openSUSE-13.2-Update
    Name: libQt5Gui5
    Version: 5.4.2-22.3
    Arch: x86_64
    Vendor: openSUSE
    Installed: Yes
    Status: up-to-date
    Installed Size: 7.2 MiB
    Summary: Qt 5 GUI related libraries
    Description: 
      Qt 5 libraries which are depending on X11.

    And yes. I've refresh all repo with
    $zypper refresh
    The openSUSE 13.2 version of lxqt has been buld with Qt 5.3 (as it should be because opensuse does not upgrade system libraries on stable builds but you can get them from extra repo's) you have qt 5.4 what to do? downgrade qt to 5.3 option 1 or do not install lxqt option 2.
    Where did you get Qt 5.4 from as far as I know the main repo for 13.2 has Qt 5.3 and you don't seam to have any extra Qt repositories?

    I don't think the wiki needs upgrading cos lxqt is in the main oss repo for LEAP and that version has been build with the latest Qt.

    edit, I might be wrong about the Qt versions butt I upgraded to LEAP a few weeks ago

  5. #5
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: LXQT installation problem

    OK try this remove the previos lxqt repo and try this one cos I think it's newer and build with qt 5.4
    http://download.opensuse.org/reposit...openSUSE_13.2/
    to remove the previos
    Code:
    sudo zypper rr "X11:LXQt (openSUSE_13.2)"
    then try the lxqr next
    Code:
    sudo zypper ar http://download.opensuse.org/repositories/X11:/LXQt:/Next/openSUSE_13.2/X11:LXQt:Next.repo

  6. #6

    Default Re: LXQT installation problem

    Thx in advance again!
    I've checked an update to current openSUSE with other PC. All went clear. Thus I suppose it's the best way to update up to Leap and install from official repo. I need time to check if all of repo I use aviable for Leap, and let you know. Please stay in touch.

  7. #7

    Default Re: LXQT installation problem

    The upgrade to current Leap make a tip, thus the problem is partly solved, not sure the problem solved for 13.2, but I_A suggested a number of solutions which may help.
    Many thx in advance!

    Don't know how yo change the topic to [SOLVED]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •