Page 1 of 3 123 LastLast
Results 1 to 10 of 30

Thread: how to install dislocker?

  1. #1
    Join Date
    Apr 2015
    Location
    The Earth
    Posts
    498

    Default how to install dislocker?

    hi====I want install dislocker but need two libs libfuse-dev and libpolarssl-dev(Headers for FUSE - Headers for PolarSSL) ===== I not found that libs for opensuse.
    Dual-boot openSUSE and win10
    OpenSUSE Tumbleweed ; Plasma 5.15.x:" LVM encrypted"
    My Partition: GPT and UEFI system
    Hp ProBook 450 G1

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,239
    Blog Entries
    15

    Default Re: how to install dislocker?

    Hi
    Your looking for the wrong filenames... openSUSE uses devel, not dev.

    So, look for fuse-devel and polarssl-devel. The fuse is available, however polarssl you will need to build, or grab a src rpm and rebuild locally;
    http://software.opensuse.org/package/polarssl

    eg [build as you USER, not root!);
    Code:
    wget http://download.opensuse.org/repositories/home:/X0F:/HSF/openSUSE_Leap_42.1/src/polarssl-1.3.9-5.1.src.rpm
    rpmbuild --rebuild polarssl-1.3.9-5.1.src.rpm
    Then install the resulting polarssl-devel package via zypper in.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,153

    Default Re: how to install dislocker?

    Code:
    #   zypper install mbedtls-devel
    PolarSSLwas renamed to "mbed TLS" and is in the 42.1 OSS repository. If you use zypper or YaST the appropriate fuse packages should be added automatically.
    ~Thank you for sharing an interesting problem.
    --
    slàinte mhath,
    rayH

  4. #4
    Join Date
    Apr 2015
    Location
    The Earth
    Posts
    498

    Default Re: how to install dislocker?

    thank you=======i use command (rpmbuild --rebuild polarssl-1.3.9-5.1.src.rpm) but error (If 'rpmbuild' is not a typo you can use command-not-found to lookup the package that contains it, like this: cnf rpmbuild)
    Dual-boot openSUSE and win10
    OpenSUSE Tumbleweed ; Plasma 5.15.x:" LVM encrypted"
    My Partition: GPT and UEFI system
    Hp ProBook 450 G1

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,239
    Blog Entries
    15

    Default Re: how to install dislocker?

    Quote Originally Posted by eng-int View Post
    Code:
    #   zypper install mbedtls-devel
    PolarSSLwas renamed to "mbed TLS" and is in the 42.1 OSS repository. If you use zypper or YaST the appropriate fuse packages should be added automatically.
    Hi
    Thanks for that.... the the OP will have some patching of dislocker header files to do.....
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,239
    Blog Entries
    15

    Default Re: how to install dislocker?

    Quote Originally Posted by 123thinksuse View Post
    thank you=======i use command (rpmbuild --rebuild polarssl-1.3.9-5.1.src.rpm) but error (If 'rpmbuild' is not a typo you can use command-not-found to lookup the package that contains it, like this: cnf rpmbuild)
    Hi
    So, the system tells you what to do? You need to read what it tells you... run the command cnf rpmbuild;

    Code:
      cnf rpmbuild
                            
    The program 'rpmbuild' can be found in the following package:
      * rpm-build [ path: /usr/bin/rpmbuild, repository: zypp (download.opensuse.org-oss) ]
    
    Try installing with:
        sudo zypper install rpm-build
    Anyway, you don't need it, see the post from eng-int, install mbedtls-devel.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  7. #7
    Join Date
    Apr 2015
    Location
    The Earth
    Posts
    498

    Default Re: how to install dislocker?

    i install fuse-devel and mbedtls-devel then extract disloker and go to dislocker/scr then open konsole and command run make but error (makecc -Wall -Werror -Wextra -Wconversion -DPROGNAME=\"dislocker\" -DVERSION=\"0.4.1\" -D_FILE_OFFSET_BITS=64 -DAUTHOR="\"Romain Coltel\"" -D__OS=\"Linux\" -D__ARCH=\"x86_64\" -D__ARCH_X86_64 -D__LINUX -I. -I/usr/local/include -fstack-protector -fPIC -D_FORTIFY_SOURCE=2 -O1 -c -o dislocker.o dislocker.c/bin/sh: cc: command not foundMakefile:115: recipe for target 'dislocker.o' failedmake: *** [dislocker.o] Error 127)
    Dual-boot openSUSE and win10
    OpenSUSE Tumbleweed ; Plasma 5.15.x:" LVM encrypted"
    My Partition: GPT and UEFI system
    Hp ProBook 450 G1

  8. #8
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,153

    Default Re: how to install dislocker?

    Quote Originally Posted by 123thinksuse View Post
    (If 'rpmbuild' is not a typo you can ...
    Code:
     #  zypper in rpm-build
    ~Thank you for sharing an interesting problem.
    --
    slàinte mhath,
    rayH

  9. #9
    Join Date
    Apr 2015
    Location
    The Earth
    Posts
    498

    Default Re: how to install dislocker?

    Quote Originally Posted by eng-int View Post
    Code:
    #   zypper install mbedtls-devel
    PolarSSLwas renamed to "mbed TLS" and is in the 42.1 OSS repository. If you use zypper or YaST the appropriate fuse packages should be added automatically.
    please install dislocker your system if successful install=======tell me ======after install fuse-devel and mbedtls-devel but not install dislocker i think mbedtls-devel not PolarSSL=======if that was must install dislocker ========#sorry for my bad english
    Dual-boot openSUSE and win10
    OpenSUSE Tumbleweed ; Plasma 5.15.x:" LVM encrypted"
    My Partition: GPT and UEFI system
    Hp ProBook 450 G1

  10. #10
    Join Date
    Apr 2015
    Location
    The Earth
    Posts
    498

    Default Re: how to install dislocker?

    Quote Originally Posted by eng-int View Post
    Code:
     #  zypper in rpm-build
    run command sudo rpm -i rpm-build polarssl-1.3.9-5.1.src.rpm but error( error: open of rpm-build failed: No such file or directorywarning: polarssl-1.3.9-5.1.src.rpm: Header V3 RSA/SHA1 Signature, key ID 42a81229: NOKEY)
    Dual-boot openSUSE and win10
    OpenSUSE Tumbleweed ; Plasma 5.15.x:" LVM encrypted"
    My Partition: GPT and UEFI system
    Hp ProBook 450 G1

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •