Results 1 to 5 of 5

Thread: Cannot start mariadb

  1. #1

    Default Cannot start mariadb

    When I enter mysqld at command line, I get the following message:
    Absolute path to 'mysqld' is '/usr/sbin/mysqld', so running it may require superuser privileges (eg. root).
    And it doesn't start.
    In services screen it shows as inactive and disabled. I cannot find any log entries.
    Mysqladmin or mysql commands produce the following:
    connect to server at 'localhost' failed
    error: 'Can't connect to local MySQL server through socket '/var/run/mysql/mysql.sock' (2 "No such file or directory")'

    Which are telling me that mysqld isn't running.
    Any ideas? This is a fresh install.

  2. #2
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,037

    Default Re: Cannot start mariadb

    On Tue, 17 Nov 2015 01:16:01 +0000, ezrapound wrote:

    > When I enter mysqld at command line, I get the following message:
    > Absolute path to 'mysqld' is '/usr/sbin/mysqld', so running it may
    > require superuser privileges (eg. root).
    > And it doesn't start.
    > In services screen it shows as inactive and disabled. I cannot find any
    > log entries.
    > Mysqladmin or mysql commands produce the following:
    > connect to server at 'localhost' failed error: 'Can't connect to local
    > MySQL server through socket '/var/run/mysql/mysql.sock' (2 "No such file
    > or directory")'
    >
    > Which are telling me that mysqld isn't running.
    > Any ideas? This is a fresh install.


    You don't run mysqld by executing the command - you start the service.

    Something like:

    sudo systemctl start mysqld

    Should do the trick (you'll want to check the service name, since it may
    be mariadb or something else - don't have leap running here yet to check
    myself).

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,580
    Blog Entries
    14

    Default Re: Cannot start mariadb

    It's
    Code:
    sudo systemctl enable mysql.service
    sudo systemctl start mysql.service
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4

    Default Re: Cannot start mariadb - solved

    Fixed. Thanks folks.
    I thought I could start from command line or YaST.
    I'm moving to openSUSE from openMandriva LX because of issues with Libreoffice and MySQL.
    So far, I am liking openSUSE.

  5. #5
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,430

    Default Re: Cannot start mariadb

    You can in fact start from YaST>System services

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •