Results 1 to 5 of 5

Thread: Problem with screen resolution and (probably) VGA card

  1. #1

    Default Problem with screen resolution and (probably) VGA card

    HI Everyone,

    I have a MSI CX61 with intel Corei7 CPU, 8G RAM, nVidia 720M graphic card. My OS is opensuse 13.2 and kernel version is 4.2.1 (I had issues with upgrading to 4.3) with KDE. I keep my OS updated as much as possible.
    At work, I use an LG W2261VP Flatron as second (an most of the times, primary) monitor. This monitor can support 1920X1080 resolution.
    I have a problem with the screen resolution on my 2nd monitor. EVeryday I come to work I just plug-in the monitor and fire up the laptop using only the 2nd monitor. The monitor's resolution is fine with no problems. But all of a sudden today it has been changed to 840X484. I tried xrandr command and below is the output:
    Note that whatever I've tried is based on this post I've found :
    https://forums.opensuse.org/showthre...ive-resolution

    Code:
    amir@aLuViAn-SuSe:~> xrandr -qScreen 0: minimum 8 x 8, current 1366 x 768, maximum 32767 x 32767
    eDP1 connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
       1366x768      60.00*+
       1024x768      60.00  
       800x600       60.32    56.25  
       640x480       59.94  
    HDMI1 disconnected (normal left inverted right x axis y axis)
    VGA1 connected (normal left inverted right x axis y axis)
       848x480       60.00  
       640x480       59.94  
    VIRTUAL1 disconnected (normal left inverted right x axis y axis)
    amir@aLuViAn-SuSe:~> cvt 1920 1080
    # 1920x1080 59.96 Hz (CVT 2.07M9) hsync: 67.16 kHz; pclk: 173.00 MHz
    Modeline "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
    amir@aLuViAn-SuSe:~> xrandr --newmode "1920x1080" 173.00  1920 2048 2248 2576  1080 1083 1088 1120 -HSync +VSync
    amir@aLuViAn-SuSe:~> xrandr -q
    Screen 0: minimum 8 x 8, current 1366 x 768, maximum 32767 x 32767
    eDP1 connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
       1366x768      60.00*+
       1024x768      60.00  
       800x600       60.32    56.25  
       640x480       59.94  
    HDMI1 disconnected (normal left inverted right x axis y axis)
    VGA1 connected (normal left inverted right x axis y axis)
       848x480       60.00  
       640x480       59.94  
    VIRTUAL1 disconnected (normal left inverted right x axis y axis)
      1920x1080 (0xf0) 173.000MHz
            h: width  1920 start 2048 end 2248 total 2576 skew    0 clock  67.16KHz
            v: height 1080 start 1083 end 1088 total 1120           clock  59.96Hz
    amir@aLuViAn-SuSe:~> xrandr --addmode VGA1 "1920x1080"
    amir@aLuViAn-SuSe:~> xrandr -q
    Screen 0: minimum 8 x 8, current 1366 x 768, maximum 32767 x 32767
    eDP1 connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
       1366x768      60.00*+
       1024x768      60.00  
       800x600       60.32    56.25  
       640x480       59.94  
    HDMI1 disconnected (normal left inverted right x axis y axis)
    VGA1 connected (normal left inverted right x axis y axis)
       848x480       60.00  
       640x480       59.94  
       1920x1080     59.96
    Now the screen resolution is added, I go to "display configuration" and try to change the resolution. Naturally the 1920X1080 is there, but when I select it and press "apply" nothing changes.
    Please lend a hand (or brain!) as soon as you can 'cos its killing me with documents I have to work with daily.

  2. #2

    Default Re: Problem with screen resolution and (probably) VGA card

    Hi Everyone,

    Seems OpenSUSE forums is much more quieter than I thought! Anyway I'm still struggling with my external monitor. Today it doesn't even turn on when I boot SUSE. Xrandr says :

    Code:
    xrandr Screen 0: minimum 8 x 8, current 1366 x 768, maximum 32767 x 32767
    eDP1 connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
       1366x768      60.00*+
       1024x768      60.00  
       800x600       60.32    56.25  
       640x480       59.94  
    HDMI1 disconnected (normal left inverted right x axis y axis)                                                         
    VGA1 disconnected (normal left inverted right x axis y axis)                                                          
    VIRTUAL1 disconnected (normal left inverted right x axis y axis)
    And here is my dmesg info :
    Code:
    [    0.887315] pci_hotplug: PCI Hot Plug PCI Core version: 0.5[    0.887323] pciehp: PCI Express Hot Plug Controller Driver version: 0.4
    [    0.887345] vesafb: mode is 1366x768x32, linelength=5504, pages=0
    [    0.887346] vesafb: scrolling: redraw
    [    0.887347] vesafb: Truecolor: size=8:8:8:8, shift=24:16:8:0
    [    0.887363] vesafb: framebuffer at 0xd0000000, mapped to 0xffffc90001000000, using 4160k, total 4160k
    [    0.960562] Console: switching to colour frame buffer device 170x48
    [    1.033370] fb0: VESA VGA frame buffer device
    [    1.033386] intel_idle: MWAIT substates: 0x42120
    [    1.033387] intel_idle: v0.4 model 0x3C
    [    1.033388] intel_idle: lapic_timer_reliable_states 0xffffffff
    [    1.033680] GHES: HEST is not enabled!
    [    1.033718] Serial: 8250/16550 driver, 32 ports, IRQ sharing disabled
    [    1.035031] Non-volatile memory driver v1.3
    [    1.035061] Linux agpgart interface v0.103
    Also, I've got this error in my dmesg repeated a couple of times. Though I believe it is unrelated, I've copied it here:
    Code:
    [   68.845084] [drm:intel_set_pch_fifo_underrun_reporting [i915]] *ERROR* uncleared pch fifo underrun on pch transcoder A[   68.845096] [drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun
    [   68.847704] [drm:intel_set_cpu_fifo_underrun_reporting [i915]] *ERROR* uncleared fifo underrun on pipe B
    [   68.847712] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe B FIFO underrun
    Another error I have is about system kernel modules :
    Code:
    [    2.361158] sd 4:0:0:0: Attached scsi generic sg1 type 0[    2.433976] systemd[1]: Failed to start Load Kernel Modules.
    [    2.467858] input: Lid Switch as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:00/PNP0C09:00/PNP0C0D:00/input/input3
    Running systemctl gives me this :

    Code:
    systemd-logind.service                                                              loaded active running   Login Servicesystemd-modules-load.service                                                        loaded failed failed    Load Kernel Modules
    systemd-random-seed.service                                                         loaded active exited    Load/Save Random Seed
    This one seems a bug (https://bugzilla.suse.com/show_bug.cgi?id=903576#c5) but im not sure yet.

    Also, here is systemctl status output : http://pastebin.ca/3247163

    Let me know if any other info is needed.

  3. #3

    Default Re: Problem with screen resolution and (probably) VGA card

    I tried bumblebee this time and got the following error messge:

    Code:
    aLuViAn-SuSe:~ # bumblebeed[ 2466.941567] [WARN]Could not open configuration file: /etc/bumblebee/bumblebee.conf
    [ 2466.941584] [WARN]Using default configuration
    modprobe: FATAL: Module bbswitch not found.
    [ 2466.961040] [ERROR]Module bbswitch could not be loaded (timeout?)
    [ 2466.961053] [WARN]No switching method available. The dedicated card will always be on.
    [ 2466.962658] [INFO]bumblebeed 3.2.1 started
    Though bbswitch is installed :

    Code:
    aLuViAn-SuSe:~ # rpm -q bbswitch
    bbswitch-0.8-3.13.2.x86_64
    Also when I'm updating kernel, it always prompts me for "failed to install kernel modules :" which bbswitch is one of them. But I've seen in forums that is normal and might happen from time to time.

    Any ideas?

    If I don't get a reply back in a couple of days I'll abandon this topic. Maybe its completely misleading.

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,907
    Blog Entries
    14

    Default Re: Problem with screen resolution and (probably) VGA card

    Please show output of
    Code:
    rpm -qa | grep bbswitch
    And, just to confirm that your install is not stock, where you're trying to use package built for the stock 13.2:
    Code:
    zypper lr -d
    If you previously installed the NVIDIA driver, reinstall the Mesa package(s). The installer replaces some files by symlinks to it's own versions.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5

    Default Re: Problem with screen resolution and (probably) VGA card

    Quote Originally Posted by Knurpht View Post
    Please show output of
    Code:
    rpm -qa | grep bbswitch
    And, just to confirm that your install is not stock, where you're trying to use package built for the stock 13.2:
    Code:
    zypper lr -d
    If you previously installed the NVIDIA driver, reinstall the Mesa package(s). The installer replaces some files by symlinks to it's own versions.

    Thanks for the reply, Here is the output of the two commands you requested :

    Code:
    aLuViAn-SuSe:~ # rpm -qa | grep bbswitch
    bbswitch-kmp-xen-0.8_k3.16.7_24-3.11.1.x86_64
    bbswitch-kmp-desktop-0.8_k3.16.7_29-3.13.2.x86_64
    bbswitch-kmp-desktop-0.8_k3.16.7_24-3.11.1.x86_64
    bbswitch-kmp-xen-0.8_k3.16.7_21-3.9.2.x86_64
    bbswitch-0.8-3.13.2.x86_64
    bbswitch-kmp-xen-0.8_k3.16.7_29-3.13.2.x86_64
    bbswitch-kmp-desktop-0.8_k3.16.7_21-3.9.2.x86_64
    Code:
    aLuViAn-SuSe:~ # zypper lr -d
    #  | Alias                     | Name                                                                 | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                 | Service
    ---+---------------------------+----------------------------------------------------------------------+---------+-----------+---------+----------+--------+-------------------------------------------------------------------------------------+--------
     1 | DarkSS                    | DarkSS                                                               | No      | ----      | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/DarkSS/openSUSE_13.2/               |        
     2 | KDE_Extra                 | Additional packages maintained by the KDE team (openSUSE_Tumbleweed) | Yes     | (r ) Yes  | No      |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_Tumbleweed/           |        
     3 | dvd                       | dvd                                                                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/13.2/                                                |        
     4 | kernel                    | kernel                                                               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Kernel:/stable/standard/                  |        
     5 | mongodb                   | mongodb                                                              | Yes     | (  ) No   | No      |   99     | NONE   | https://repo.mongodb.org/zypper/suse/11/mongodb-org/3.0/x86_64/                     |        
     6 | nVidia                    | nVidia                                                               | Yes     | ( p) Yes  | No      |   99     | NONE   | ftp://download.nvidia.com/opensuse/13.2/                                            |        
     7 | openSUSE-13.2-1.10        | openSUSE-13.2-1.10                                                   | No      | ----      | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-TSSTcorp_CDDVDW_SN-208DB_R8XQ6YMD6002RK,/dev/sr0 |        
     8 | packman2                  | packman2                                                             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/13.1/                                     |        
     9 | repo-debug                | openSUSE-13.2-Debug                                                  | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/13.2/repo/oss/                      |        
    10 | repo-debug-update         | openSUSE-13.2-Update-Debug                                           | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.2/                                     |        
    11 | repo-debug-update-non-oss | openSUSE-13.2-Update-Debug-Non-Oss                                   | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.2-non-oss/                             |        
    12 | repo-non-oss              | openSUSE-13.2-Non-Oss                                                | Yes     | ( p) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/non-oss/                        |        
    13 | repo-oss                  | openSUSE-13.2-Oss                                                    | Yes     | ( p) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/oss/                            |        
    14 | repo-source               | openSUSE-13.2-Source                                                 | Yes     | ( p) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/source/distribution/13.2/repo/oss/                     |        
    15 | repo-update               | openSUSE-13.2-Update                                                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2/                                           |        
    16 | repo-update-non-oss       | openSUSE-13.2-Update-Non-Oss                                         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2-non-oss/                                   |        
    17 | scalpel                   | scalpel                                                              | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/scalpel4k/openSUSE_13.2/            |
    I will update/reinstall nVidia drivers as well, I have some problem with the server itself but will update you whenever I could update the packages (Won't be that long! )

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •